1.    25 Mar 2017 #1
    Join Date : Mar 2017
    Posts : 5
    W10

    Impossilbe to format EFI in FAT32 using DISKPART


    Hi all,

    This is the first time for me to install W10 and I am facing a kind of strange issue.
    All started with an error code displayed by the W10 installer saying something like "Impossible to format system partition. Wrong file system. Error Code 0x80042425"...
    After so Google search most of the answers were linked to USB key issues as I am booting using a bootable USB Key...Change the key for a bigger one (8Go => 16 Go) no changes...

    Browsed a bit more on Google and understood that W10 is based on 4 partition :
    1.System
    2. MSR
    3. Windows
    4. Recovery

    Made the link with the previous error understanding that it was not a key issue but a system partition formating issue.
    Started to look around and finally landed on that page from Microsoft (in french sorry):In between I got accounted to GPT/EFI rules and noticed that for W10 if EFI boot required, then GPT based disk is mandatory + for W10a dedicated EFI partition in FAT32...
    And this is where I am facing the issue with DISKPART.
    Getting thru the script provided on the MSDN site I have no issue until that line :
    format quick fs=fat32 Label="System"
    Diskpart retuns me the following error:
    virtual disk service error the file system is incompatible
    Formatting using exFAT or NTFS works but for sure will not solve my W10 installed problem...As additional information :


    • I am trying to install W10 on a CRUCIAL 525GO MX300 SSD
    • CSM is disabled
    • Fastboot is disabled
    • Secure boot is disabled


    Any help from a partition Guru would be highly appreciated !
    Thks a lot
      My ComputerSystem Spec
  2.    25 Mar 2017 #2
    Join Date : Jul 2015
    Posts : 9,344
    Windows 10 Pro

    If you are trying to do a clean install then select the custom install option. Delete each partition listed on the SSD until you have nothing but unallocated space. Highlight the unallocated space and click next to let it set up the partitions on the SSD.
      My ComputerSystem Spec
  3.    25 Mar 2017 #3
    Join Date : Mar 2017
    Posts : 5
    W10
    Thread Starter

    THks NavyLCDR ofr your prompt reply.

    Maybe it was not clear in my description but I already did that....And it doesn't work....Installation won't start (step 02) and I get the following message from Windows Installer :
    "Windows could not format the partition on disk 0. The error occured during the preparation of system volume.Error code: 0x80042425"

    That's the starting point for me to play with DISKPART...and to try to format my "System" EFI partition into FAT32.
    When I am launching the command "FILESYSTEM" on the "SYSTEM" partition (EFI type), I only got exFat,NTFS and RESF....No FAT32...I wonder what is going wrong there...
      My ComputerSystem Spec
  4.    25 Mar 2017 #4
    Join Date : Jul 2015
    Posts : 9,344
    Windows 10 Pro

    Boot from the Windows installation USB flash drive or DVD. When you get to the first screen, press Shift + F10. In the command prompt that opens run:

    diskpart
    list disk
    select disk x <Replace X with the disk number of the SSD, probably 0
    clean <this will erase everything on the selected drive
    convert GPT
    exit
    exit

    Then see if the installer will allow you to install to the unallocated space.
      My ComputerSystem Spec
  5.    25 Mar 2017 #5
    Join Date : Mar 2017
    Posts : 5
    W10
    Thread Starter

    Thks for your feedback NavyLCDR

    I did what you ask for without real conviction as I was playing with all these kind of trials for the last two days (nights in fact).
    Nevertheless, W10 is currently installing....So it seems to work...
    However (because an however akways exist) I have to add that in between :
    - I formatted my USB Key again using Rufus with following settings (which I had already tried) : PArtition GPT for UEFI + FAT32 Format
    - I've put on the key another w10 ISO
    And then I've done your actions....
    In conclusion I think I add an issue with the first W10 ISO but I am not sure I am willing to change again to see if it is really the root cause :-)
    I come back to you in some minutes
      My ComputerSystem Spec
  6.    25 Mar 2017 #6
    Join Date : Mar 2017
    Posts : 5
    W10
    Thread Starter

    Finally I decided to check if the ISO what the root cause...
    I am formating another USB key with the old ISO to check...
    Let's see
      My ComputerSystem Spec
  7.    25 Mar 2017 #7
    Join Date : Mar 2017
    Posts : 5
    W10
    Thread Starter

    So coming back with some news.... Old ISO is still not working
    I've done the same procedure as the one proposed by Navy this time without success
    Looking at DISKPART FILESYSTEM for "System" partition with the old ISO brings back only 3 possibilities : RESF or NTFS or exFAT...One thing to notice is that my old ISO is using DiskPart version 10.0.15048.0

    With the new iso, no problem at all, looking at the same partition with DISKPART brought back 5 possibilities: RESF or NTFS or exFAT or FAT or FAT32 (Youpi !!!!!!)...For sure then it is possible to format the EFI partition in FAT32 and everythin runs well...
    One thing to notice is that on the new ISO DISKPART version is 10.0.14393.0 (so older than the Old ISO Diskpart version )...
    But at list it works...

    So to conclude. I don't think the method proposed by Navy is the solution for my problem....I still assume that my problem what link to the ISO I used to create the USB Key and particularly that the ISO used formerly what including a DISKPART version not compatible with my H/W configuration.

    My last W10 ISO version is an All-in-One Version based on V1607 release x64
    The Old ISO versio I used was an Insider Build 15048 x64 (so newer than the working ISO version which explains the differences with DiskPart)

    Hope it helps for people who have same problem as me....And finally thanks to Navy for his/her time
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
FAT32 for 1 T drive
How can I format a 1 T usb drive to FAT32 beyond the Window 10 32gig limit? Ideally I would like to have the entire drive FAT32/ I have seem some free download apps but they look dated. Any specific recommendations?
Drivers and Hardware
USB install - Fat32 OR NTFS ?
Fresh Installing Windows 10 and before downloading file, I was thinking if I should format my drive to Fat32 OR NTFS OR exFAT? Does it make any difference ? - Plz Guide me.
Installation and Upgrade
Solved fat32 efi partition on OS disk and bootloader showing in bios
after i put a friends laptop hd in my computer and fixed his. i have a strange little 99MB fat32 efi volume\partition on the OS disk. and i never saw it before. and i have 2 boot loaders in bios. wont boot without one of them being selected. is...
Performance & Maintenance
Space on a fat32 formatted external drive
Hello, I have a 750Gb external drive that was originally NTFS. Windows shows it as 698Gb. I formatted it to fat32 yesterday, and now windows reads it as 185Gb. In disk manager, as you can see in the screenshot link (from remote desktop) that I have...
Drivers and Hardware
Solved Cloning HDD to SSD-HDD is 512 format & SSD is 4096 format. Matter?
If so, what are my options? This HDD came from HP w/Win 7. I upgraded it to Win 10 but would like to clone it to the SSD for the speed increase. Thanks in advance, jeff
Installation and Upgrade
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 02:00.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums