Windows 10 Anniversary - Modern setup host has stopped working

  1.    19 Sep 2016 #1

    [Fixed] Windows 10 Anniversary - Modern setup host has stopped working

    Hi everybody,
    I'm trying to update my Windows 10 system to the Anniversary edition.
    When the installation process reaches 100% and the system is about to reboot I always get the message 'Modern setup host has stopped working' . All I can do is press OK, quitting the installation.
    After several google searches I tried to:
    • perform a clean boot,
    • unplug all the USB devices,
    • update from the .ISO,
    • disable graphic and sound cards

    No way. Modern setup host won't work properly.
    I don't have any antivirus or firewall installed.

    Any idea on how to complete the installation?
    Last edited by eccoFatto; 01 Oct 2016 at 06:49. Reason: Fixed
      My ComputerSystem Spec

  2.    19 Sep 2016 #2

    Hi, have you seen this? Seems to offer more than you've tried.

    On a more prosaic level, do you have any unallocated disk space on your system drive?
    And around 20Gb spare, allowing working space + the creation of Windows.old in your Windows partition.
      My ComputersSystem Spec

  3.    19 Sep 2016 #3

    Hi dalchina,
    thank you for your answer.
    Yes, I'd already seen that page.
    What do you mean 'And around 20Gb spare, allowing working space + the creation of Windows.old in your Windows partition.'?
      My ComputerSystem Spec

  4.    19 Sep 2016 #4

    You should have about 20Gb spare space (= not used) in your Windows partition minimum.

    You can of course see what the update logs say,
    C:\$Windows.~BT\Sources\Panther\SetupAct.log and SetupErr.log

    but you'd be better off researching what people have done and found to work, as there seem plenty of reports on this.

    Sorry I can't add anything special as I've not had that kind of problem, fortunately, but someone else may well chip in.

    Modern Setup Host has stopped working while installing Windows 10 Tech Preview
    is one where the issue was not having enough space.

    But as you know, there are many posts on this error - probably a variety of possible causes.
    Last edited by dalchina; 19 Sep 2016 at 08:10.
      My ComputersSystem Spec

  5.    19 Sep 2016 #5

    Windows 10 Anniversay

    I've been trying to update to the windows anniversary as well and this is the message I'm getting:

    Cumulative Update for Windows 10 Version 1511 for x64-based Systems (KB3185614) - Error 0x80070005

    Is this the right thread for this issue? I couldn't find another one like this
    Thank you!
      My ComputerSystem Spec

  6.    19 Sep 2016 #6

    Hi, suggest you start a separate post- or join an existing one about
    windows update and 0x80070005
    - there are plenty of reports of the quite common error 0x8007005 - both about windows updates and store updates.

    Some posts suggest this is a permissions error in the registry. (See older comments here:

    Also see:

    You might find using's cautious repair tool (free) may help - just choose the appropriate repair for registry permissions.
      My ComputersSystem Spec

  7.    01 Oct 2016 #7

    Ok, I finally managed to upgrade to anniversary edition.
    The problem was I originally moved the users folder to another drive, as posted here:

    Users Folder - Move Location in Windows 10 - Windows 10 Forums

    It only took moving the users folder back to C:\ (as explained in the same post) before repeating the upgrade procedure, and that's it!

    The reason why I didn't mention that before, is that another upgrade on a similar system went smoothly in my first attempt, without moving back any folder...

    Hope this may help other users
      My ComputerSystem Spec

  8.    01 Oct 2016 #8

    Good, as you say, that doesn't necessarily cause problems. Problem is, MS's non-diagnostic messages!
      My ComputersSystem Spec

  9. Posts : 32
    Win 7 Home Premium and Win 10
       30 Dec 2016 #9

    It shouldn't be this damn hard, trying to get updates to a system that Microsoft pushed so hard for everyone to get. They have their users but then they screw them by making updates almost impossible to get. It was and is the same with Win 7 and the same with Win 10. I'm going back to 7, this is ridiculously stupid. 7 works without updates, just like XP did and Win 95. When I can't get drivers anymore I'll try again.
      My ComputerSystem Spec


Related Threads
setup.exe has stopped working in Performance & Maintenance
Hello ! After installation of Windows 10 1511. When I try to run an ISO image, I receive this message : setup.exe has stopped working and close the program. Also I was receiving the error : Microsoft Setup Bootstrapper has stopped working. How...
Hi For quite some time now, on my main (primary) OS, which is Windows 10 Pro build 10586.218, I am getting this error: Host Process for Windows Services: Stopped working. I see this in my Reliability History. It might appear even several...
Repair Install Fails - Modern Setup Host in Installation and Upgrade
It gets thru part of the set up and I'm getting an error box that says Modern Setup Host has stopped working. I give up. I was hoping a repair would keep my app and docs, but I guess that option is not working. At some point I will do a clean...
Hi, I have been using Windows 10 for almost a month without issue. Then, a few days ago, I received an error message complaining about the registry when attempting to open pictures. I assumed the photo app was broken, as it was the default...
Sometimes I get this Windows Error "Application Host Manager has Stopped Working" it will then show the progress bar and then disappears. Has anyone else experienced this or how do i fix this? Thanks
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 20:55.
Find Us