UEFI Boot problem after bcedit command

Page 2 of 5 FirstFirst 1234 ... LastLast
  1.    09 Sep 2016 #11

    I managed to boot the system again, after using Recovery with the Secure Boot option previously set to Enabled.

    Now, inside W8.1 I used bcedit and it returned EFI\refind\refind_x64.efi in the path option.

    Since the problem started when I used bcdedit /set {bootmgr} path \EFI\refind\refind_x64.efi, I used now
    bcdedit /set {bootmgr} path \EFI\Microsoft\Boot\bootmgfw.efi to set it back to the default. The problem is, the first command was done in W10, is the path that I have set now the correct one for W8.1? How can I know if the system boot when I restart it?
      My ComputerSystem Spec

  2.    09 Sep 2016 #12

    Don't know ..........I have no idea what you are trying to do....

    you have a clean 8.1 from HP Recovery ......just install Windows 10

    or did i miss something? aren't you get rid on LINUX ?

    Or do you mean the linux Boot manager survived the Win 8.1 re-image from HP ?
      My ComputerSystem Spec

  3.    09 Sep 2016 #13

    Fixing Windows Boot Problems

    Most Windows boot problems are best addressed on Windows-specific sites, so I recommend you make the rounds of Windows forums to solve such problems. There is one that deserves mention here, though: If you accidentally erase the Windows boot loader file, EFI/Microsoft/Boot/bootmgfw.efi, you won't be able to boot Windows. The simplest solution is to restore this file from a backup you prepared ahead of time. If you don't have such a backup, though, you can restore it as follows:

    1. Boot from an emergency Windows recovery disk. If you don't have one, you can prepare one from a working Windows system as described here.
    2. Type diskpart to enter the Windows disk-partitioning tool.
    3. In diskpart, type sel disk 0 followed by list vol. You should see a set of partitions. This step is intended to help you identify your ESP, which will probably be the only FAT32 partition on the disk. (If you have multiple disks, you may need to try again with sel disk 1 or higher.) Note the volume number of your ESP.
    4. Type sel vol 1, changing 1 to whatever the ESP's volume number is.
    5. Type assign letter=S: to assign the ESP a Windows disk identifier of S:. (You can use another letter if you prefer.)
    6. Type exit to exit from diskutil.
    7. Type cd /d s:\EFI\Microsoft\Boot\ to change into the Windows boot loader directory. (If this directory doesn't exist, you may need to create it first with mkdir. If rEFInd or some other boot loader occupies this directory, back it up first.
    8. Type bootrec /fixboot.
    9. Type bcdboot c:\Windows /s s: /f ALL. Note that this command should set the Windows boot loader as the default. Omit /f ALL if you don't want to adjust the EFI's default boot program.
    10. Reboot and hope it works! If the computer boots straight to Windows and you want to use rEFInd, use bcdedit in Windows, as described in step 9 of the Installing rEFInd Manually Using Windows section of this page.

    For more information, see this SuperUser question and answer.
      My ComputerSystem Spec

  4.   My ComputerSystem Spec

  5.    09 Sep 2016 #15

    Uzai said: View Post
    Since the problem started when I used bcdedit /set {bootmgr} path \EFI\refind\refind_x64.efi, I used now
    bcdedit /set {bootmgr} path \EFI\Microsoft\Boot\bootmgfw.efi to set it back to the default. The problem is, the first command was done in W10, is the path that I have set now the correct one for W8.1? How can I know if the system boot when I restart it?
    Why don't you just run the bcdedit command and post back with the results. It is amazing how confusing things can get when a solution is rushed and mistakes are made.
      My ComputerSystem Spec

  6.    09 Sep 2016 #16

    bcedit is returning the following:

    Gerenciador de Inicialização do Windows
    identificador {bootmgr}
    device partition=\Device\HarddiskVolume2
    path \EFI\Microsoft\Boot\bootmgfw.efi
    description Windows Boot Manager
    locale pt-BR
    inherit {globalsettings}
    integrityservices Enable
    default {current}
    resumeobject {48ebdf9a-63ba-11e3-a5c5-e8039ae113a5}
    displayorder {current}
    toolsdisplayorder {memdiag}
    timeout 30

    Carregador de Inicialização do Windows
    identificador {current}
    device partition=C:
    path \windows\system32\winload.efi
    description Windows 8.1
    locale pt-BR
    inherit {bootloadersettings}
    recoverysequence {2175f4c9-6b7b-11e4-825d-24f5aa658942}
    integrityservices Enable
    recoveryenabled Yes
    isolatedcontext Yes
    allowedinmemorysettings 0x15000075
    osdevice partition=C:
    systemroot \windows
    resumeobject {48ebdf9a-63ba-11e3-a5c5-e8039ae113a5}
    nx OptIn
    bootmenupolicy Standard

    I plan to do a Windows 10 clean install. What I'm afraid of is that the problem I had wasn't just being unable to boot into Windows, but also having no option in bios to boot from a DVD/USB. If I restart and I can't boot in the W8.1, probably still there will be no option to boot from DVD/USB in bios. So booting from DVD/USB to fix the boot is not an option.
      My ComputerSystem Spec

  7.    09 Sep 2016 #17

    I am reading at this link as I do not use or know rEFInd but it says those commands don't work in windows 10 and to use EasyEFI instead.

    The rEFInd Boot Manager: Installing rEFInd
      My ComputerSystem Spec

  8.    09 Sep 2016 #18

    what is the exact model number of your computer/laptop I think Samsung make several Ativ PC's ,should be on the back on a sticker perhaps? . I want to look at the Manual....
      My ComputerSystem Spec

  9.    09 Sep 2016 #19

    It looks like your command worked as BCedit seems like it is pointing the boot loader to the windows directory but I am no Linux expert

    you should check the second partition on the HDD to make sure it contains the EFI as BCedit think it does...

    Minitool Partition wizard is Free and Good , right click a partition and choose Explore to see inside....

    and of course I don't speak Portuguese :)

    Hopefully @Saltgrass will comeback and look too.
      My ComputerSystem Spec

  10.    09 Sep 2016 #20

    The one entry I don't recognize is the:

    integrityserives Enabled

    But it is just Win 8.1, so I assume all references to Win 10 are gone... not much I can do.

    If you were to do a bcdedit /enum all it might show the prior Win 10 option but you may have gone beyond that.

    If you still had Win 10 installed, or even have replaced the Win 10 with Win 8.1 a command can replace the boot files which is bcdboot c:\Windows and will replace the boot files with whatever OS is in the C:\Windows directory.

    Your option might be, if you had activated Win 10 would be to do a clean install of Win 10.
      My ComputerSystem Spec

Page 2 of 5 FirstFirst 1234 ... LastLast

Related Threads
Is there currently any way to configure a custom boot logo for UEFI booting? I can only find methods for Legacy users, but no luck with UEFI. I'm kind of new to custom boot logos, so if anybody could give me some information as to if it's...
Solved Cannot boot into UEFI BIOS or Boot Menu in Performance & Maintenance
Belarc reports UEFI: American Megatrends Inc. P11-B2 Operating System: Windows 10 Home (x64) Version 1511 (build 10586.494) Installed: 4/27/2016 5:58:22 AM Servicing Branch: Current Branch (CB) Boot Mode: UEFI with successful Secure Boot. ...
Recently I played around with dual booting Linux Mint on my system. I decided that I would delete it for the present as I have other things to focus on. However, after deleting partitions and fixing my MBR to only boot windows my UEFI BIOS still...
I've been an insider since FEB. Last ISO I installed was 10074. Since updating to 10240/rtm things have gotten buggy, apps don't function, can't update etc. I want to install the latest ISO on the 10240 oartition, but when I try I get,...
Boot mode uefi with secure boot disable in Installation and Upgrade
Ok im about to upgrade to win 10 then do a clean install afterwards of win 10, but i wanted to assure i have everything correct before i start. I updated again my profile with Belarc to assure i have a completed list of my software, i notice this...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 15:49.
Find Us