I have 2 exactly the same configured Windows installations, both 32bit and 64bit. These Windows installations are referring to other other drives for specific settings, such as:

* The users folder is redirected to the `U:\Users` drive
* Some programs are installed on the `P:\` drive.

The OS is installed on the `C:\` drive.

For constantly testing these configured machines with the settings, I used a non-generalized sysprep, and booted back into the same virtual machine (I did not test it on another machine yet).

These non-generalized syspreps into OOBE worked perfectly.

When I was done configuring the machines how I wanted, and knew they both worked in a non-generalized sysprep. I sysprepped them with the generalize option on.

From here I made a WinPE boot environment and captured an image of the `OS` partition (`C:\`) and the `PROGRAMS` partition (`P:\`).

Now I made a new virtual machine and booted into WinPE with the device connected where the captured images we're on.

Here I created the following (needed) partitions using diskpart:

Click image for larger version. 

Name:	4SOsK.png 
Views:	9 
Size:	8.8 KB 
ID:	99861

These are the partitions that correspond to the sysprepped machines that worked without generalize. The system partition was just a try, I also tried doing it without it.

After having created the partitions I applied the images to the corresponding disks (`C:\` -> OS partition, `P:\` -> Programs partition). This by using the DISM /apply-image command. I am sure I choose the right index of the .WIM file.

Then I used the `bcdboot C:\Windows /s C:` for creating the boot files, this successfully worked.

After restarting the machine using the `exit` command and not booting into WinPE, I got the following error message.

Click image for larger version. 

Name:	dvtwh.png 
Views:	9 
Size:	19.5 KB 
ID:	99862

When opening up notepad via SHIFT + F10 and opening the `\Windows\Panther\setuperr.log` file, there is this line:

2016-08-20 21:13:01, Error [0x0606ae] IBS [SetupCl library] Required profile hive does not exist [\??\E:\WINDOWS\system32\config\systemprofile\NTUSER.DAT].
Note: removed whitespace from the error message

Also, when I open up notepad and check for my drives when opening a file, there are all kind of drives I did NOT make in WinPE.

Click image for larger version. 

Name:	ZBdWw.png 
Views:	9 
Size:	3.0 KB 
ID:	99863

The only thing that is correct is the `C:\` drive, the PROGRAMS drive should be `P:\` and the USERS drive should be `U:\`.


  • Where did these random drive letters come from? I already set them

in WinPE before starting the Windows installation.

  • How can I make my generalized sysprep work with these settings?