Windows 10: Upgrade from build 10061 to 10074 fails (Inaccessible Boot Device) Solved

Page 2 of 2 FirstFirst 12
  1.    20 May 2015 #11


    I learned a very useful bit of info. Actually, quite a few things. For starters, at any point (after a few seconds anyways) during Windows Setup after it reboots, Shift+F10 brings up a cmd window. This window uses the System account (to check, enter the set command and look at the value for %USERNAME%). Let the games begin.

    Found from DiskPart, as I suspected:

    Microsoft Windows [Version 10.0.10074]
    Microsoft DiskPart version 10.0.10074
    Copyright (C) 1999-2013 Microsoft Corporation.
    On computer: MININT-KVSOTNG
    DISKPART> list volume
      Volume ###  Ltr  Label        Fs     Type        Size     Status     Info
      ----------  ---  -----------  -----  ----------  -------  ---------  --------
      Volume 0     E   J_CCSA_X64F  UDF    DVD-ROM     3606 MB  Healthy
      Volume 1     C   Win 7        NTFS   Partition    300 GB  Healthy
      Volume 2     F   XP BE        NTFS   Partition     15 GB  Healthy
      Volume 3     G   Data         NTFS   Partition    460 GB  Healthy
      Volume 4     H   Win 10       NTFS   Partition     48 GB  Healthy
      Volume 5     D   System       NTFS   Partition   1500 MB  Healthy    Hidden
    Now, let me back up a bit:

    I had already moved the actual files back into an actual DriverStore\FileRepository folder. I used the system account, you can see how to do that here, but the TL;DR is use Sysinternals' psexec from an elevated cmd prompt like so:

    psexec -i -s -d cmd
    Follow that (in the new CMD window) with

    whoami /user
    to double-check that it worked (side note: on an old Windows version {like XP}, enter the set command and look at %USERPROFILE%). Also note that you can launch things (like Explorer, regedit, etc etc) from this System cmd prompt and the new processes will be run as System as well.

    So, I don't know if what I did during setup would have worked, as I had already taken care of the problem by moving the files.

    To make this work, I noted that by having compression on, the 16GB folder became 9.7GB on disk. I then disabled hibernation with
    powercfg hibernate off
    , saving myself 5GB (your amount will vary depending on the amount of physical memory you have).

    I then used WICleanup (working download link is now here) to delete my orphaned/unused MS Installer (*.msi) and Installer Patch files (*.msp) from \Windows\Installer (AFTER backing the entire folder up -- you don't want to be caught looking for a specific version of an .msi file from one of your programs while trying to upgrade / uninstall it; I've been there, it's a pain. I know these are supposed to be unused... but you don't know for sure they won't be needed later (as I can attest from previous experience!). Back 'em up! In WICleanup, you can select the first in the list (not the checkbox, I mean highlight the row), then scroll to the bottom, hold the shift key, and click to select the last row. Then, click the checkbox of any of the now-selected rows, and all of the items will be checked. To delete, for every entry, you're going to have to press "Y" to confirm deletion and then Enter or Spacebar to acknowledge success, I would do it in alternating fashion (Y-Space-Y-Space-Y-Space....) unless you want to click two boxes for every item being deleted...
    So that (WICleanup) saved me 1.5GB.

    I ran CCleaner, ran Disk Cleanup on the system files and also under additional options erased all but the most recent restore point.

    Also, I knew Win 10 setup wouldn't take as much space during installation, as all temporary files, backup files, new files, etc etc are all going to be compressed since the drive is compressed by default now.

    So, with the drivers on the Win 10 drive again, I had 14 or 15 GB of space free IIRC. Initiated 10074 setup from DVD I burned. Now we're at Windows setup and I investigate (using Shift-F10 cmd prompt) the drive letters, yup, Setup assigned my hidden system partition to the letter D.
    I then opened regedit, (this is the registry of whatever Windows environment is responsible for the setup) and went to HKLM\SYSTEM\MountedDevices
    Copied the value for my Data partition under \DosDevices\G: (be sure to get it all , it will also select to the right / left) and then went to \DosDevices\D: and replaced the values there with the values for my data partition. Then I deleted the \DosDevices\G: entry (this makes Windows re-assign that drive).
    Upon the 2nd phase of Windows Setup, loaded up DiskPart and my Data partition was listed as drive D.

    So there's that.

    For more reading, (definitely if you are at all confused or unsure of what I did) check these out:

    Editing the MountedDevices Registry Key
    How to Use the Diskpart Utility to Assign and Remove Drive Letters (couldn't really do this while the D: drive was in use (although it might not have been once Win Setup loaded, but I didn't want to chance it), but I knew if I edited the registry, it would take effect on next boot, so I did that instead)

    Oh, and here's where the Windows Setup logs (failed or successful) get put: Log files that are created when you upgrade to Windows Vista from an earlier version of Windows
      My ComputerSystem Spec

  2. banger's Avatar
    Posts : 398
    Windows 10 Pro x86 and x64 dual boot
       20 May 2015 #12

    I just upgraded to 100122 after deleting the filerepository contents, everything seems ok. Running disk cleanup (system) and it found 10gb of drivers packages and 15gb previous installations.

    So far so good, only took about 30 mins to upgrade, seems much more polished.

    Edit: FileRepository is no 1.02gb
      My ComputerSystem Spec

  3.    25 May 2015 #13

    Hmph. Attempted install of 10122, got Inaccessible_Boot_Device, tried creating normal empty FileRepository directory instead of symlink and doing the install again, failed again. *shrug* Imma have to play with this one. First things first, deleted the temp install files and try allowing another install to start. If that fails, I'll try human-parsing the log files. Fun, fun.

    Error code show after failover to old version was 0x80070070 - 0x30017
    Last edited by 0x6A7232; 25 May 2015 at 12:12.
      My ComputerSystem Spec

  4.    02 Jun 2015 #14

    Update -- I just went through with WinDirStat and found which folders took the most space, found which ones looked similar in structure, selected them all, and hovered over them while selecting and based my criteria on what the first file in the folder was -- I only allowed one folder to exist that started with the same file. By doing this, I slimmed down my drivers to 1 or 2 GB total, which allowed me to update.

    Now that Disk Cleanup has the delete old / redundant drivers, I should have no more problems.
      My ComputerSystem Spec

Page 2 of 2 FirstFirst 12

Related Threads
Hi there seems to occur randomly but the toolbar suddenly stops Autohide until the next boot. Can't specify exactly when it occurs but seems to happen randomly. Cheers jimbo
Sysprep fails - Windows 10 build 10162 in Installation and Upgrade
Hello Guys I'm trying to sysprep a Windows 10 Enterprise build 10162 so that i can capture, but i'm getting some errors and hope you guys have some sort of solution. I've tried removing The upgrade key in HKLM system, but that didn't help. ...
Trying to dual boot build 10130 iso on a fresh install of 8.1. Received a message: "Windows cannot be installed to this disk. The selected disk is not of the GPT partition style" Laptop is an Asus x550c. System recovery to Asus factory...
Upgrade to build 10074 fails in Installation and Upgrade
When I try to upgrade to build 10074 I get a failure message that reads fbl_impressive Professional 10074 - Error 0xc1900107. I have tried Google and Bing but can't find a fix. Help!
Build 10061 in Windows Insider
Anyone getting a prompt to update to Build 10061 but having it fail? I'm getting a 'Push' but, seeing as I'm running a leaked build, it seems to be failing out.
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 15:00.
Find Us