Windows 10: Help installing raid 0 using Samsung 850 EVO SSDs on Dell XPS 8300

Page 1 of 4 123 ... LastLast
  1.    17 Aug 2016 #1

    Help installing raid 0 using Samsung 850 EVO SSDs on Dell XPS 8300


    System: Dell XPS 8300, i7-2600, 3.4 GHz, 16 GByte memory running Windows 10 PRO. Currently the boot device is a Samsung 850 EVO 500 GB. The motherboard is a Dell 0y2mrg containing an H67 Express Sata/6 controller(chipset). The performance is very good, particularly with Rapid mode(a disk caching app by Samsung) enabled. There is a secondary 1 TB hard drive which is used as storage for less active files. The graphics has been replaced with an NVidia 750 GTX with two HDMI outputs. I have to admit this is a quick system, my major uses are using Excel with large files(5-100 MB) and number crunching. I've decided not to replace the CPU or MBoard until one or the other fails, thinking i7-6800. I run an incremental Acronis backup every day with full saves every 20 days.

    I'd like to add another Samsung 850 EVO 500 GB to this system and run both together in raid 0 and use the raid structure as the boot device. I already own the second 850 EVO. My major motivation is capacity, followed by speed. I should have purchased a 1 TB SSD but didn't.

    Can anyone direct me to the literature that explains how to implement raid 0 with Windows 10 PRO? I realize the entire conversion process may involve a lot of moving stuff around and so forth. Any advice would be appreciated.

    Thanks, Glen
      My ComputerSystem Spec

  2.    17 Aug 2016 #2

    Most likely, it would involve a clean install. Your first step is to check the BIOS to see if it is supported. I was going to make the case to not even bother with RAID0 with SSDs, but if your BIOS doesn't support it, I would avoid software RAID at all costs.
      My ComputerSystem Spec

  3.    17 Aug 2016 #3

    The gain on ssd with raid is zero and if one disk dies everything is lost
      My ComputerSystem Spec

  4.    17 Aug 2016 #4

    Re: Help installing raid 0 using Samsung 850 EVO SSDs on Dell XPS 8300


    I realize there won't be much of a performance gain if any. However the capacity gain is worth some effort.

    The MB does have a raid option. Where do I go from here?

    Thanks for your efforts and I should have purchased the 1 TB 850 EVO but what I have is 2 500 GB 850 EVOs.
      My ComputerSystem Spec


  5. Posts : 5,011
    Windows 10 Pro X64 15063.138
       18 Aug 2016 #5

    From Wikipedia: RAID - Wikipedia, the free encyclopedia
    RAID 0
    RAID 0 consists of striping, without mirroring or parity. The capacity of a RAID 0 volume is the sum of the capacities of the disks in the set, the same as with a spanned volume. There is no added redundancy for handling disk failures, just as with a spanned volume. Thus, failure of one disk causes the loss of the entire RAID 0 volume, with reduced possibilities of data recovery when compared to a broken spanned volume. Striping distributes the contents of files roughly equally among all disks in the set, which makes concurrent read or write operations on the multiple disks almost inevitable and results in performance improvements. The concurrent operations make the throughput of most read and write operations equal to the throughput of one disk multiplied by the number of disks. Increased throughput is the big benefit of RAID 0 versus spanned volume,[12] at the cost of increased vulnerability to drive failures.
    I agree with you, should have gone for the 1TB SSD As long as you have good backups I think you'll be okay.
      My ComputersSystem Spec

  6.    19 Aug 2016 #6

    It will require a fresh install, but you connect both SSDs, configure the array in the BIOS, and then boot to your Windows 10 and install as you normally would. Your system should see a single 1 TB drive, if you configured the array properly.
      My ComputerSystem Spec

  7.    20 Aug 2016 #7

    DeaconFrost said: View Post
    It will require a fresh install, but you connect both SSDs, configure the array in the BIOS, and then boot to your Windows 10 and install as you normally would. Your system should see a single 1 TB drive, if you configured the array properly.
    there is no need for that ........ and no data is lost ... if you use the Intel RST Software in Windows...... if the drives are of equal size ....which they are in this case, it's fairly easy, you can also set the Stripe size etc (64K) while doing it . In my case the 2 SSD's aren't even the same brand ..a Crucial M4 and a Plextor M5 both at 128GB though.

    Certainly it may have been easier for me as I already had Raid Enabled , as I have a Raid0 Data Array too , I am using RST Driver and Software Package 11.7.4.1001 , since Drivers in the 13 series Corrupt Data in Windows 10 on the ICH10R.

    Personally , on this old machine as it is only SATA2 capable It didn't double the speed in AS SSD Benchmark but it certainly looks like it helps in some areas but I am no expert on this.

    Happy to post more if you still need help.....

    KB
      My ComputerSystem Spec

  8.    20 Aug 2016 #8

    Click image for larger version. 

Name:	Capture.JPG 
Views:	36 
Size:	75.0 KB 
ID:	97259

    the Plextor on its own

    Click image for larger version. 

Name:	Capture1.JPG 
Views:	36 
Size:	75.6 KB 
ID:	97260

    the Crucial on its own


    Click image for larger version. 

Name:	Capture3.JPG 
Views:	1 
Size:	75.4 KB 
ID:	97261

    and the Raid0 array


    It did tell me there was an Error when I told it to make the Array , I couldn't stop the "create" process but once it was completed and verified it turn out the Error was that although RST saw the 238GB Array , it had not Merged the two drives as far as Windows was concerned , so I had to Use Minitool Partition Wizard to Expand C:\ into the Unallocated Space on the Array. Not sure if that is usual or not as I have only done this once , so far all seems well.


    KB.
      My ComputerSystem Spec

  9.    20 Aug 2016 #9

    I assume you are on AHCI now ? so you would need to do this below. 1st to get Raid Enabled ...however be prepared for a failure and make sure to have full image backs 1st just incase.


    Change to RAID mode from AHCI mode or IDE mode:Warning: Spoiler! (Click to hide)
    • Exit all Windows-based programs.
    • Press [Win] + R or take the RUN option from the start menu.
    • Now type regedit there and press Enter Key to open up the Registry Editor Window.
    • If you receive the User Account Control dialog box, click Continue.
    • Locate and then click the following registry subkeys:Code:
      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\msahci
      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\iaStorV
      HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\iaStor

    • In the right pane, right-click Start in the Name column, and then click Modify.
    • In the Value data box, type 0 [3 is default], and then click OK.
    • On the File menu, click Exit to close Registry Editor.
    • Restart your computer
    • Go to UEFI/BIOS and enable RAID, Save & Reboot
    • Another restart will be required to finish the driver installation.
      Note: If you have an AMD systems you may need to look here too: http://superuser.com/questions/30003...s-installation





    above info stolen from :

    How to: Change SATA Modes After Windows Installation
      My ComputerSystem Spec

  10.    24 Aug 2016 #10

    Thanks to both DeaconFrost and KBird. I'm slowly working my way through this. So far I've been unsuccessful so here goes:

    1. I opened up regedit and located iaStorV, but not iaStor or msahci. Variations of those two keys exist elsewhere in the registry but not in

    • HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\. None of these variations is exact.

    2. if I do find the proper keys, there several names listed, which one do I change? None has the value 3.
    3. I did get two SSDs connected and I can boot from either one. Neither is new; both have Windows 10 OSes installed.
    4. Changed the SATA mode from AHCI to RAID, saved and then rebooted.
    5. The Intel Rapid Storage Technology screen came up and listed all the devices attached to the SATA controller. The status of each drive was non-raid which is correct. The screen also had a line that said "type control-I" to enter the configuration dialogue. I pressed control-I and f6 both in various combinations and in all cases the screen closed and I received an error that said no boot device could be found. Also if I failed to press any key, the screen disappeared in a few seconds and I received the same error. Since I failed to update the registry, maybe the system would configure raid.

    Any ideas?

    Thanks again.
      My ComputerSystem Spec


 
Page 1 of 4 123 ... LastLast

Related Threads
Dell is not checking the Inspiron 620 for Windows 10 compatability and has no plans to update drivers. Has anybody successfully installed Windows 10 on a Dell Inspiron 620?
On my personal file server PC, I have two 1TB drives that are configured in Windows Storage Spaces to be I'm assuming a RAID1 array. Basically my two 1TB drives show up as one 1TB drive. Eventually I am going to replace Windows 10 with Server 2016...
Hello everyone, I have encountered a problem with Samsung 950 PRO 512GB M.2 NVMe. I would appreciate your help as my knowledge in hardware and software is minimal. So thank you in advance. I have just finished installing windows 10 in a new pc...
Further to my thread regarding removing the crapware on my new Dell: https://www.tenforums.com/installation-setup/48639-new-dell-pc-removing-crapware.html I've done a clean install, and want to install some drivers from the Dell web site. I've...
I've have an 8 year old Dell XPS 410 that has had a number of upgrades, to include a new video card and solid state drive. It is currently running great with Win7 but I am probably going to take MS up on their offer for a free upgrade and go with...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 19:26.
Find Us