Lost Win10 in Multiboot disk partition Win7, Win10 and LM Rafaela Solved

  1. Posts : 39
    win7 home premium 64 bit
       15 Aug 2016 #1

    Lost Win10 in Multiboot disk partition Win7, Win10 and LM Rafaela

    My disk contains 5 partitions:
    part1 = ntfs-win10 free upgrade of win home premium (primary)
    Part2 = ntfs-win7 home premium (primary)
    Part3 = ext3-Extended (logical)
    Part4 = ext3-LM rafaela (extended)
    Part5 = swap (extended)
    This setup worked good.

    Part2 win7 got buggered, and reinstalled (nvidia chip-set melt down during win7 boot). The MB was replaced.

    I can no longer get to win10 boot Part1. Booting to Part1 or Part2 results to booting the newly installed win7. Rafaela boot did not change: still working.

    How can I reclaim my win10 boot? I can't upgrade for free anymore so I'm hoping there's a way to work with what's there.

      My ComputerSystem Spec

  2. Slartybart's Avatar
    Posts : 3,506
    Win_8.1-Pro, Win_10.1607-Pro, Mint_17.3
       15 Aug 2016 #2

    You could use EasyBCD to add Win10 to the boot code.
    EasyBCD Documentation

    Take care not to screw up the Linux entry.
    I'm pretty sure EasyBCD makes a backup - but it's been quite a while.

    Read first, plan 2nd, backup the BCD store - then execute the plan
      My ComputerSystem Spec

  3. Posts : 39
    win7 home premium 64 bit
    Thread Starter
       16 Aug 2016 #3

    Easybcd in use

    easybcd has been in use. It does allow you to alter win7 boot loader simply. The problem is that once win7 was re-installed on part2 it took over the boot loader that win10 made/altered during its upgrade.
    On boot there are 3 choices Win7, Win10, Rafaela. Both win7 and win10 boot to the newly installed win7. Rafaela boots as before.
    I need to direct win10 boot to part1. Part1 has not changed since the re-install of win7 on part2. It's just the boot loader that did. easybcd doesn't doesn't make one it manipulates loaders but doesn't generate them.

    Did not see tab to post again to this thread so I edited my last post:

    I want win10 so I took a shot at below:
    win10 partition (part1) copied d:\Windows\Boot to d:
    copied d:\Windows\Boot\PCAT\bootmgr to d:
    This file and folder were never at root (d:) before
    made part1 (win10 part) active in boot manager

    Got Blue screen that read: there is a problem with set up and I think the only option was to shut down.

    I used gparted standalone to make win7-part2 boot drive or active in windows terms.

    I back to my first post - win7 and win10 boot selections boot to win7 , rafalea boots ok

    I removed copied files from d: and over wrote bootmgr in c: drive to it's former self. It was a copy of win10's Windows\Boot\PCAT\bootmgr: as suggested in this post.

    I don't know what to do so I will wait till there's another direction.


    ANSWER is on another post (here). <cmd> BCDBOOT D:\Windows
    Last edited by klong915; 16 Aug 2016 at 20:42. Reason: did not see tab to post another post here
      My ComputerSystem Spec

  4.   My ComputerSystem Spec


Related Threads
I had WIN 7 on my desktop computer did the upgrade to WIN10 free. Everything was working fine then one day I turned on the computer and received a boot disk error. I went into BIOS and tried booting from there and it worked the first time. A couple...
I'm still playing with Win10 on a tablet and not ready to install it on my main computer. Meanwhile, there are 32 Windows 7 updates pending. I've selected all 32 in Windows Update, then clicked the OK button, but that just takes me to a screen for...
Here's the situation. I have a 17" laptop with two Win 7 drives set up with dual boot. One is a 128gb SSD with all my work software. (AutoCad, Rhino, etc) The other is a new 256 SSD with only the Win7 OS installed. Both use the same laptop...
My machine has two boot volumes. vol3 (win7 now win10) and vol5 (win8 tp10). After automatic upgrade of win7p to Win10p(64) on vol3, all appeared to be well. It activated just fine (good network) and Edge and Chrome work fine. However, IE11,...
As per title, i have this annoying issue. Having a 3TB hard drive in win7, after partitioning normally the first 2GB of it, i opted to use partition wizard to partition the remaining 1GB of the drive. It did so, i assume, by creating a permanent...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 02:46.
Find Us