How do I add RAID / other drivers to W10 installation media

  1. jimbo45's Avatar
    Posts : 9,059
    Windows / Linux : Arch Linux
       #1

    How do I add RAID / other drivers to W10 installation media


    Hi there

    I need to add a RAID driver (I have the driver) to the Windows install media (got iso and usb via media creation tool - the iso / usb was created on a different machine).

    Previous versions would let you via an Fn key load drivers from a "Diskette" image. This option of course isn't there.

    If I don't load the RAID driver at boot Windows gives the standard message "No Hard Disks found".

    Any EASY way to do this.

    Note this has to be done at install time - it can't be done afterwards as Windows won't see any HDD's. !!!!!

    I find often when stuff is "Simplified too much" --such as 1 click or "Easy install" options then when stuff does need to be modified it's usually a pain. I can't see what was wrong with the original optional prompt to load drivers at install (XP / W7 etc). W10 install is easy if it's a bog standard installation but if you have things like Hardware RAID it's a pain.

    Cheers
    jimbo
      My Computer

  2. jimbo45's Avatar
    Posts : 9,059
    Windows / Linux : Arch Linux
    Thread Starter
       #2

    Hi there

    Found a real SILLY way to do this on an HP server -- I had to BURN an old fashioned ISO (fortunately I still had an old USB DVD writer).
    Then on the server bios boot options there;'s an option called "Intelligent provisioning" which installs both rhe OS and driver at the same time. The intelligent provisioning requires a PHYSICAL ISO image !!! - one on HDD won't do and it loads the driver and does the install.

    However this method is specific to this particular machine. ("Yesterday's technology Tomorrow" !!!!!).

    Surely there must be a better method of adding drivers PRE-INSTALL if these are required - for example hardware RAID controllers etc.

    so although I've solved it for this particular piece of hardware (HP Proliant GEN 8 Microserver) I'd still like a better generic method.
    The Gen 8 server uses the W12 (or W8) server RAID driver - works fine on W10.

    I want a Windows image on this server (while it's a free upgrade from W7 / W8.1) so need to get it working before 23.59 today !!!!!!.

    Any assistance on this would be really appreciated -- I've looked at using nLite and the WAIK tools but a) it's complicated and b) I think WAIK for W10 has changed so no good.

    I can't believe I'm the only person who has this problem with Hardware RAID.

    Cheers
    jimbo
      My Computer


 

Related Threads
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 20:46.
Find Us




Windows 10 Forums