Keyboard issues after migration from Win7-dropped/missed/repeated keys

  1. Posts : 37
    Windows 10 x64

    Keyboard issues after migration from Win7-dropped/missed/repeated keys

    I recently migrated all of my 5 home machines to Win10. It was a big job to get all the drivers right.
    On one of of them however, I have encountered a very strange problem that I just can't fix.

    1) I am seeing problems with repeated keys - sometimes I type a word like "search" and the s or the r for example is repeated indefinitely even though the key has been released, until I hit another key. This happens with any key. It's particularly annoying when you hit PgDn in Reader and suddenly it scrolls all the way to the last page.

    2) Other times, there is a very long delay - about 5 seconds - between the time I press keys on the keyboard, and the time they appear on the screen. This happens in any application.

    3) The third issue is an outright drop of many of the keys I type. This is usually paired with the delay (second issue) For example, I can type "windows key" then "search settings", and there is a delay, and when the Windows menu finally appears, only the word "settings" appears - "search" is dropped. Other times, the first key (Windows key) is dropped, and then nothing appears at all.

    These issues happen randomly, but are completely reproducible by repeating "Windows key" + "search settings" quickly (by which I mean at about 80-100wpm), and doing this 10 times over. One or more of the above issue always shows up on that machine.

    All these keyboard problems happen only since migrating to Windows 10.
    When reverting to Windows 7 with an OS image (thank god for Acronis True Image), all these problems go away. This makes me quite confident there is some sort of software issue with Windows 10 in play here.

    Nevertheless, I do have a complex hardware configuration, and I'm a software engineer, and thus I have tried to find out what might be triggering the issue. I have also been assembling my own PCs for about 25 years, so I know my way around hardware. The problematic machine in question here is a home-built box.

    So, here goes the hardware description.

    a) The keyboard is an AZERTY (French) keyboard, PS/2 type, Cherry brand, model RS6000 . Replacing the keyboard is not an easy proposition as I'm located in California, and those AZERTY keyboards are not easy to come by locally.

    b) This keyboard is connected to the keyboard port of a PS/2 to USB mouse/keyboard adapter.

    c) The USB port of this adapter is then connected to the keyboard port of an Iogear KVM switch, model GCS1104.

    d) a cable of about 12' in total - including 6ft + 6ft extension - runs from the KVM computer port #3 type B to one of the USB type A ports on the computer

    Things I have tried that fix the issue :
    I) reimaging to Windows 7
    II) connecting the keyboard + PS/2 adapter directly to one of the USB type A ports on the computer, ie. bypassing the KVM and the long cable altogether

    Obviously, the fact that I) works denotes some sort of compatibility issue between Windows 10 and my hardware.
    And the fact that II) works points the finger at the KVM switch and/or cable.

    However, it is not so simple.

    I have another machine attached to the very same KVM switch that I migrated from Windows 7 to Windows 10, and it experienced no keyboard issues whatsoever. The other machine is attached to computer port #2 of the KVM, and is using a shorter USB cable, without extensions. It is the machine I'm using to type this on.

    So, I tried to proceed by elimination. Here are many of the things that tried, which did not help :
    a) doing a full Windows 10 reset of the problematic machine - as the original was a migration. This does not fix the problem. FYI, the other machine that works, on the same KVM, was also a migration.
    b) switching the KVM computer ports . Ie. connecting the problematic computer to another KVM port. I tried to connect it to every port - no luck, keyboard issue is still there on that machine. I think I can conclude the problem is not related to a specific port on the KVM.
    c) switching the USB cable used to connect to that computer, including using a shorter 6ft cable, without extension - fortunately, the machine is on wheels and can temporarily be brought closer to the KVM switch. But unfortunately, it does not solve the issue either. I even tried the same USB cable that works with the other machine - no luck. I believe I have ruled out a USB cable issue.
    d) connecting the USB cable from the KVM to a different USB port on the computer, including a port on a different controller. The motherboard comes with 3 different controllers - USB 2.0, 3.0 and 3.1 . This is a recent Asus Z170-AR . It doesn't make any difference which port or controller the KVM is connected to - the keyboard issue is still present.
    e) updating the firmware of the KVM switch. There is a recent (2016) update for it. It did not solve the problem, unfortunately.
    f) disabling keyboard emulation in the KVM switch. No help.
    g) connecting the keyboard to one of the USB "hub" ports of the KVM switch, instead of the USB keyboard port on the KVM. Again, no help.

    At this point, I'm really at my wits end as to why I can't properly use the keyboard on that particular Win10 machine, but the other works fine - when both are using the same KVM switch, same keyboard, and same PS/2 to USB adapter.

    FYI, the mouse is a Kensington Expert Mouse, connected to the "hub" port. I'm not using the Kensington software for it.

    Description of the machine with the keyboard issue on the KVM :
    Asus Z170-AR motherboard - latest BIOS
    32GB (2x16) Patriot DDR4-3000 RAM - checked with memtest
    Intel i5-6600k CPU - OC at 4.4 GHz (I downclocked it to stock; same issue)
    nVidia GTX 750 Ti GPU PCI-E
    TI 1394b PCI-E card
    SI-PEX40063 PCI-E x2 SATA controller
    2x 128GB Crucial M4 128GB in RAID 0
    2x WD Green 3TB HDDs (striped)
    2x optical drives (one DVD, one BD)
    2x SATA Hotswap bays

    Description of the machine without issue on the KVM :
    MSI X99A Raider motherboard - latest BIOS
    32GB (4x8) Corsair DDR4-2666 RAM
    Intel i7-5820k CPU - OC at 4.3 GHz
    nVidia GTX 960 Ti GPU PCI-E
    TI 1394b PCI-E card
    Silicon Image PCI-E SATA controller
    2x Sandisk Ultra II 480GB SSD in RAID 0
    2x Seagate 4TB HDDs (striped)
    2x BD optical drives
    2x SATA Hotswap bays

    Really, pretty similar machines overall - one Z170, the other X99, and quite puzzling that one would have this major keyboard issue and be basically unusable under Win10, and the other is completely fine, when both are on the same KVM. IMO, both machines should be able to work on the KVM, or neither. It doesn't make sense that one does, and the other doesn't. Both work fine with Win7 on that KVM.
    Last edited by madbrain; 26 Jul 2016 at 19:32.
      My Computer

  2. Posts : 37
    Windows 10 x64
    Thread Starter

    I also tried imaging the problematic machine with a copy of the SDD on the working machine. The hardware was similar enough that it just booted - both were Intel RAID 0 volumes, similar USB, same brand of graphics card.

    Unfortunately, that did not solve it either. The Z170 box still has the weird keyboard behavior when connected to the KVM - while the X99 is fine.

    I don't know what else to try at this point, except another KVM/another USB to PS/2 adapter.
      My Computer

  3. Posts : 37
    Windows 10 x64
    Thread Starter

    I actually replaces the PS/2 AZERTY keyboard + PS/2 - USB adapter with a straight USB AZERTY keyboard.

    No improvement, unfortunately.

    Asus came up with a BIOS update for the Z170-AR motherboard, version 1902. No improvement either.

    To make things easier to test, I used a spare Kingston SATA II 96GB SSD to create a Windows 10 installation, and left Windows 7 on the RAID array. This way, I can go back and forth between the two operating systems easily by changing the boot order in the BIOS settings.

    The problem definitely doesn't occur in Windows 7, but occurs in Windows 10.

    Another extremely weird data point : if I disable the XMP Tuner in the BIOS, then the problem disappears ! This causes the RAM to run at DDR4-2133 speed, instead of its its rated 1.35 / DDR4-3000 speed. Extremely weird.

    So, at this point I have ruled out the PS/2 to USB adapter.
    But I'm not really any closer to finding out the root cause.

    The bottom line is still an odd problem with dropped/repeated/delayed keys between KVM, Win10, and the particular Z170-AR motherboard. I think I will make a video to demonstrate it...
      My Computer

  4. Posts : 37
    Windows 10 x64
    Thread Starter

    This was resolved by keeping the RAM speed at DDR4-2400 on the Z170-AR motherboard. Any faster, and there is a problem with the USB keyboard.
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 22:16.
Find Us

Windows 10 Forums