Windows 10: Latest Build Windows 10 fail, wont allow BIOS access

Page 3 of 3 FirstFirst 123
  1.    26 Sep 2015 #21

    killless said: View Post
    I can't get into BIOS anymore.
    I don't see "Press F2 or del to enter BIOS" anymore! It just goes into windows immediately!
    Have you tried what was mentioned in this thread?
      My ComputerSystem Spec

  2.    26 Sep 2015 #22

    alphanumeric said: View Post
    Have you tried what was mentioned in this thread?
    Motherboard (Asus Hero VIII) had a fit. Nothing would work. I even unplugged all disks and still it would not let me get into BIOS.
    Asus tools to get into BIOS did not work.
    I ended up removing the battery from the mother board. This erased all motherboard setting and I could get into BIOS again.
    I got into this situation by trying to change device from which motherboard works - once I did it no more "press F2 or Del"

    I guess in this case: Not Windows 10 fault
      My ComputerSystem Spec

  3.    21 Dec 2017 #23

    I upgraded to windows 10 from 7 a few days ago, now every time I restart the progress circle that indicates windows is loading is overlaid on top of my bios splash screen. This prevents me from accessing bios. This is the same board I have been using for years and this is the first time I have experienced this. I have turned off fast boot, any suggestions?
      My ComputerSystem Spec

Page 3 of 3 FirstFirst 123

Related Threads
26390 Hi I have pinned a picture to help explain my issue. Every time I try to pin skype,, itunes a new icon is pinned to the taskbar but not the jump list version. when I click on the icon on the task bar it opens another icon/program...
Hi there One computer upgraded to build 10240 PRO and was activated -- the other 3 machines I'm testing this on won't activate --get message saying Activate Windows. The published key doesn't work if you try and activate manually.. So I got...
I had the latest build of Windows 10 installed and then in the process of resetting the computer due to an error, the operating system has been removed so I can no longer boot into the system. As Microsoft is no longer allowing anyone to download...
I've been using WIndows 7 for a year, but i just have decided to make a switch to Windows 10 preview, and format my C: since it was full of garbage. So i downloaded a brand new ISO from Microsoft, and put it in a USB stick and Installed Windows 10. ...
Alright, so I have a separate partition and I'm using a program called EasyBSD to mount the boot.wim so that I can boot to the ISO to install Windows onto the separate partition. When I load Setup, it askes for DVD/USB drivers. What should I do from...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 11:36.
Find Us