Windows 10: Need help with setuperr.log on failed upgrades to Build 10586 Solved

  1.    18 Jul 2016 #1

    Need help with setuperr.log on failed upgrades to Build 10586


    Since I installed Win 10 Build 10240 a few months ago Windows Update has been trying on an almost daily basis to upgrade it to the current Build 10586. While all other updates seem to have installed normally, this one has consistently failed. Yesterday I tried a manual upgrade using a DVD of the downloaded Build 10586. I turned off Windows Defender and Windows Firewall and ran Setup from the DVD as Administrator. But it failed during the initial Installing Windows phase at roughly the 18% mark, leaving what has to be the most useless message Microsoft has ever come up with: "Something happened--Windows 10 installation has failed". I looked at setuperr.log but am not able to decipher what may have happened. I've attached that log; can anyone come up with a reason the installation failed and what I might be able to do about it? (I realize that I could probably do a clean install of Build 10586 but would prefer to do the upgrade if possible.)
    Need help with setuperr.log on failed upgrades to Build 10586 Attached Files
      My ComputerSystem Spec


  2. Posts : 5,012
    Windows 10 Pro X64 15063.138
       18 Jul 2016 #2

    This is the error that caused it to fail I believe:

    Code:
    SP     CMountWIM::DoExecute: Failed to mount WIM file C:\$WINDOWS.~BT\Sources\SafeOS\winre.wim. Error 0xC1420127[gle=0xc1420127]
    SP     Operation failed: Mount WIM file C:\$WINDOWS.~BT\Sources\SafeOS\winre.wim, index 1 to C:\$WINDOWS.~BT\Sources\SafeOS\SafeOS.Mount. Error: 0xC1420127[gle=0x000000b7]
    Does this file exist: C:\$WINDOWS.~BT\Sources\SafeOS\winre.wim

    What anti-virus program do you use. Disable it or uninstall it then try the upgrade again.
    Ditto if you use a 3rd party firewall like Comodo. Disable for the upgrade.
      My ComputersSystem Spec

  3.    18 Jul 2016 #3

    Thanks for looking at the error log. There were so many supposed "errors" listed that I had no idea which were temporary and resolved and which were fatal.

    There is no SafeOS subfolder and thus no winre.wim file under Sources; the three subfolders of Sources remaining after the upgrade attempt are Diagnostics, Panther and Rollback. However, is it possible that the SafeOS subfolder existed during the attempted upgrade and was deleted in the cleanup after the failure? If it should be there before and after after the upgrade, what would be the possible cause of its absence? Is there some way I can create or copy it there before another attempt?

    As for AV and Firewall, both are the built-in Windows components, and both were disabled for the attempt.
      My ComputerSystem Spec


  4. Posts : 5,012
    Windows 10 Pro X64 15063.138
       18 Jul 2016 #4

    Cleanup probably did remove that folder.

    Found this: http://answers.microsoft.com/en-us/w...a-6476cdd411be
    See the 2nd post in the thread by Rahul_compfreak.

    It's for 8.0 to 8.1 upgrade but the error is the same so this solution may work.

    When I look at HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\WIMMount\Mounted Images there is nothing under it.
      My ComputersSystem Spec

  5.    19 Jul 2016 #5

    Thanks for the tip. While it didn't directly solve my problem it did give me a lead which resulted in a solution.

    I looked at the post by Rahul_compfreak you suggested. There was no entry under the Registry key he named. But the gist of your replies was that there was a problem with mounted images. So I Googled a bit and found:

    Unmount and Clean up a Wim Image using DISM

    which gave me guidance on dealing with such problems. My first check with DISM told me the mount status was Invalid and pointed to a mount directory in the Recycle Bin and an image file C:\$Windows.~BT\Sources\SafeOS\winre.wim, exactly the file you told me to look for in your first reply. So I used DISM to clean up the mount status and tried the upgrade again. This time it went successfully.
      My ComputerSystem Spec


  6. Posts : 5,012
    Windows 10 Pro X64 15063.138
       19 Jul 2016 #6

    Excellent and darn good detective work. I saved the link you posted, good information.
      My ComputersSystem Spec


 

Related Threads
Are there any tools that help pinpoint the real errors as opposed to all the "noise". My setuperr file is "only" 65KB but the setupact file is, and I'm not making this up, 32,866 KB. Is a setupact file that big a "good thing" or a "really,...
I have a 4 week old HP notebook with Windows 10 already installed. The above Upgrade (Update??) has failed 3 times & I suspect it is the root of other problems (Can't create more user accounts, can't sign in to Cortana.) According to the web...
The windows update 'Upgrade to Windows 10 Enterprise, version 1511, 10586' fails with 'Windows can't be installed because this PC has an unsupported disk layout for UEFI firmware'. This PC (laptop) is running Windows-To-Go (Windows 10) from a an...
Build updates for W10 upgrades in Windows Updates and Activation
I'm sure this has been discussed before, but I wonder if Microsoft intends to update the W10 upgrades in the same manner that the TP versions are. Insiders using the TP generally look forward to a new build even though it is disruptive, I can do a...
Woke up and turned the machine on this morning and saw this in Windows Update. 26470 I am not sure what to do.
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:25.
Find Us