Windows 10: New clean install on Win 7 Pro Key Solved

  1.    13 Jun 2016 #1

    New clean install on Win 7 Pro Key


    Hi

    New install of Win 10 Pro appears to have installed all drivers, chipset, graphics audio etc.

    I previously downloaded all updated drivers that supported Windows 10. Would it be wise to update them or should I stick with the defaults that Windows has installed? Particularly with the chipset drivers. I have a feeling that these will in any case be the win7 or 8 drivers as my mobo is not officially supported for win 10 as yet and may not be.

    Thanks in advance.
      My ComputerSystem Spec


  2. Posts : 12,408
    W10Prox64
       13 Jun 2016 #2

    kevvyb said: View Post
    Hi

    New install of Win 10 Pro appears to have installed all drivers, chipset, graphics audio etc.

    I previously downloaded all updated drivers that supported Windows 10. Would it be wise to update them or should I stick with the defaults that Windows has installed? Particularly with the chipset drivers. I have a feeling that these will in any case be the win7 or 8 drivers as my mobo is not officially supported for win 10 as yet and may not be.

    Thanks in advance.
    Hi kevvyb and welcome to Tenforums.
    If everything seems to be functioning properly and there are no bangs in Device Manager, I would stick with what's been installed by the OS. If you begin to have issues, you could look at updating some of the drivers, depending on what issues arise. W10 has gotten pretty good at this, so, if it ain't broke... (Just keep your previously downloaded drivers in case you need them in the future.)
      My ComputerSystem Spec

  3.    13 Jun 2016 #3

    Driver installation


    Thanks for quick reply. That was my inclination so thanks for confirming.
      My ComputerSystem Spec


  4. Posts : 12,408
    W10Prox64
       13 Jun 2016 #4

    kevvyb said: View Post
    Thanks for quick reply. That was my inclination so thanks for confirming.
    No problem. Enjoy W10! Cheers!
      My ComputerSystem Spec


 

Related Threads
Hey guys! I have a new ASUS ROG G751JT-DH72 laptop, and I have been trying to install Windows 10 and Ubuntu on it. It came with Windows 8.1, so I upgraded to 10, then did a clean install of 10. Version was Home 64 bit. That went reasonably...
Hi I have looked through solutions for this issue, but the suggestions don't seem to fix my issue... I am running Windows 7 SP1 Pro 64-bit on a Dell Optiplex 760, and try to do a clean install of Windows 10, using the ISO file which I downloaded...
Hey folks. Just did a windows 10 clean install in my system. ASUS p8z77-m + 3770k + samsung 850 evo + 2TB HDD. I got no exclamation marks in device manager and everything seems to work. LAN and Sound are alright for instance. Do I still...
Sorry if this has been addressed already (a search didn't yield exactly what I was looking for). I'm planning on doing a clean install of Win10 next weekend after upgrading from 7 x64 Pro. I'm wondering if anybody has a detailed account on what...
When I upgraded to windows 10 from windows 7, it worked fine for the next few hours then i couldnt acess the log in screen it was just stuck on the slider and then it flickers. tried to trouble shoot, system restore, clean installed (using...

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 02:42.
Find Us