1.    09 Jun 2016 #1
    Join Date : Sep 2014
    Nashville, TN
    Posts : 3,143
    Windows 10 Pro

    New Win 10 install doesn't remap OS parittion to C:


    I'm not sure how this happened, but I created a dual boot of Windows 7 and 10. When I installed 10 on a second partition (MBR, not EFI) Windows 10 does not remap it's OS partition to C: but stays on E:

    This is causing a lot of problems because I need to install various home-grown installation tools that assume the OS runs on C: and has hard coded paths to look for things. (Yes, I know they're poorly written, I don't have control over them).

    It's more or less impossible to change the partition letter after Windows has been installed (too many registry entries that have the paths wired in), but How can I ensure that when I do a custom install of Windows 10 to the second partition that it considers the partition to be C:?
      My ComputerSystem Spec
  2.    09 Jun 2016 #2
    Join Date : Jul 2015
    Posts : 9,419
    Windows 10 Pro

    Leave the space where you want to install Windows 10 to unallocated (delete the partition there). Install to the unallocated space and let Windows 10 setup create the partition.
      My ComputerSystem Spec
  3.    09 Jun 2016 #3
    Join Date : Sep 2014
    Nashville, TN
    Posts : 3,143
    Windows 10 Pro
    Thread Starter

    I'm fairly certain that's what I did, but I can't remember. So I'll try again.

    Thanks for the advice.
      My ComputerSystem Spec
  4.    12 Jun 2016 #4
    Join Date : Sep 2014
    Nashville, TN
    Posts : 3,143
    Windows 10 Pro
    Thread Starter

    So, I ended up going a different route. I wiped my Windows 10 install, made an image of my Windows 7 system with Macrium Reflect. Then I wiped the disk, installed Windows 10 in UEFI mode (with legacy csm support), then I converted my image to a VHD, then added a boot entry for it...

    Nice, easy dual boot. The Win 7 seems a little slower, but that's ok.
      My ComputerSystem Spec

 


Similar Threads
Thread Forum
Solved Windows 10 clean install - hard drive doesn't show up before install
Hi I have looked through solutions for this issue, but the suggestions don't seem to fix my issue... I am running Windows 7 SP1 Pro 64-bit on a Dell Optiplex 760, and try to do a clean install of Windows 10, using the ISO file which I downloaded...
Installation and Upgrade
Build 14291. What works and what doesn't on my install.
1. Sfc /scannow does not work...........Windows Resource protection could not start the repair service. 2. Dism /online /cleanup-image /restorehealth works. 3. Safe mode does not work. Once got to safe mode, the screen kept...
Windows Insider
Display goes black ~5m after fresh install. Doesn't come back.
Hi all, I'm quite stuck. Finished my machine build last night, got it to POST ok, and am now having some real trouble trying to install Windows 10. Here's what happens: - Boot from windows 10 usb - Install windows successfully (can navigate...
Installation and Upgrade
Solved Windows 10 install doesn't
I am trying to install Windows 10 on a computer that is running 8.1. All checks and prerequ's passed and I finally selected "Install Now". Windows 10 downloaded (pretty slow btw.) and then the box rebooted. It then slowly counted up to 100%...
Installation and Upgrade
Market doesn't update/install apps, error 0x80070005
Any apps I try and update attempt to install, but stay at 0.0mb downloaded, then it stops and produces this error: 30251 The happens with every app. I read on some other forums on why this may be happening and someone suggested that it was...
Software and Apps
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:49.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums