Windows 10: No working USB drivers after W10 install

  1.    28 May 2016 #1

    No working USB drivers after W10 install


    Hi. I've done update installs of W10 on 2 of my older computers with W7 64bit systems, no problems at all. Then feeling confident tried it with my latest built computer, also W7 64bit, which has an Asus Sabertooth mb Rev 2, with latest bios. Using the Media Creation Tool, everything seemed to go ok with the update. However, I had no mouse (USB) and investigating I found that none of the USB drivers were working. All the usb drivers had yellow '!' marks: "the software for this device has been blocked because it is known to have problems with Windows[code 48]. Tried the update drive procedure and the response was that the latest drivers were already installed. After a few hours trying to figure it out I gave up and recovered my W7 os with again working usb ddrivers and ports.

    Any ideas so that I can install W10 successfully? I do not want to do a clean install.
      My ComputerSystem Spec


  2. Posts : 1,835
    Windows 3.1 to Windows 10
       28 May 2016 #2

    if you have your windows 7 recovery on external media - then try a clean installation of windows 10
      My ComputerSystem Spec


 

Related Threads
Hello Everyone! Thank you a head of time for you time and efforts! THE QUESTION: How do I fix my display drivers in XP in my win10 Hyper-v virtual machine? WHAT HAPPENED: Installed XP in Hyper-V (Win10). For some reason now the display...
Hey folks. Just did a windows 10 clean install in my system. ASUS p8z77-m + 3770k + samsung 850 evo + 2TB HDD. I got no exclamation marks in device manager and everything seems to work. LAN and Sound are alright for instance. Do I still...
I Installed Windows 10 the other day and it seems that the ATI Radeon HD 4300/4500 graphics card drivers aren't working. If anyone has/had the same porblem, please if you know how to solve it tell me. I will be greatful. By the way when i start the...
I installed windows 10 for my Asus laptop(which was running windows 8.1 pro and the mic worked perfectly) , and the microphone just doesn't work. I tried to install the latest win 10 drivers for Via, and that didn't help. Are there any fixes for...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 10:02.
Find Us