I bought two new SSDs to be used in a RAID 0 configuration with a Dell 9020 under Windows 10.

Before the drives I arrived I configured two old HDDs in RAID 0 and installed Windows 10 as a clean install. This worked perfectly.

Once the new SSDs arrived I configured these in RAID 0 and started a clean install. Windows correctly identified the disk and the capacity and the install completed without issue.

When the computer restarts I got a "A disk read error occurred" error.

If I boot from the installation media to a command prompt I can see that the Windows files have been correctly installed to the C drive of the RAID 0 array.

I try fixing the MBR but this does not solve the issue.

I also tried loading the RAID drive during Windows install but this made no difference, and if it was the driver causing the issue it would not have worked with my old HDDs.

If I open diskpart I see that the drive is not marked as boot, which it is when I check these details on the old HDDs in RAID0.

Any help will be greatly appreciated.

Many thanks