Hello everybody I normally search for my own answers but after 6 days trying and testing without any luck what i'm going to do is to post here all the solutions i have tried so everyone in the future could know what works and what doesn't:
Device: Tablet from Amazon: Rotor TU-W1402 comes with win10 32bits. Link: (spanish): Rotor rtu1402cblack.eu - Tablet de 10.1 (WiFi, Bluetooth, Intel Baytrail T Z3735F Quad Core, 1.33 GHz, 2 GB de RAM DDR3, 32 GB Flash, doble cámara, Intel HD Graphics Gen 7, Windows 10 OS): Amazon.es: Informática 

Specs: Intel Atom Z3735F @1.33GHz. Quadcore (which according to Intel supports 64bits)
BIOS: UEFI American Megatrends Inc 5.6.5 11/08/2015
BIOSChipName: Winbond 25x/Q Series
Want to: I'm trying to install windows 10 Pro but on the 64bit version. As i stated above before i bought it I researched and the Z3735F according to Intel supports 64bits. But can't manage to boot any .iso from usb. All it does is to pass it and boot windows normally.

Solutions tested:

1 - Downloaded 3 different ISO from microsoft and everywhere i could find it.
2 - Secure and Fast boot disabled
3 - At same time tried Quiet boot enabled/disabled but no changes
4 - Boot USB drive override from my BIOS options but screen only flash for a second and nothing happens.
5- No CMS but Legacy compatibility is enabled. (option found in USB configuration of my BIOS)
6- Created my boot usb using rufus with GPT for UEFI and tried: 
- FAT32 format
- NTFS format (Coz i read that the bios could not support FAT32) but I got error: "the ntfs partition could not be mounted 14 not found"
6- Created the usb boot drive manually using diskpart: select disk #, clean, create partition primary, format fs=fat32 quick, active, assign, exit. And then copied all the files inside the .iso image to the usb drive. Even copied the efi\microsoft\boot to efi\boot and renamed the bootmgfw.efi file to bootx64.efi (just in case).
HTML Code:
7- Downloaded and created the usb boot using Microsoft MediaCreation Tool:
- First time was a 64bit only and same results it just pass it and windows starts normally.
- Then i downloaded a double version that includes 64 and 32 bits and made the usb boot and interesting thing happened: Finally booted at first try and told me to select 64 or 32 bit version. I Chossed 64 bits and this error came: "Windows failed to star. A recent hardware or software change might be the cause. To fix the problem: 1- Insert your windows installation disc and restart your computer. 2. choose language settings and click next. 3. Click repair your computer ... File: \windows\system32\boot\winload.efi
Status: This 64bit application couldn't load because your pc does not have a 64 bit processor. If you're using windows To Go, make sure your USB device has a version of windows that's compatible with your PC.
32 bit version it's working without problems i just installed it on the mini pc
- Tried to do it from the EFI shell (which i'm not familiriazed but was desperate) and when typed \EFI\BOOT\BOOTx4.EFI got the error: "Image type x4 is not supported by this IA32 shell" which i found reading that could mean the processor is locked with this EFI shell for only 32 bits so i can't install any 64bit OS.

All this solution were tested also with a Bben mini pc with exactly the same specs and got same results. It worked on and old Dell Studio 1537 though and could install the 64bit version of win10.

Finally i just gave up on my mini pc and will install 32 bit version win10 (it was win8 before) at the moment and will keep researching about what to do with the tablet. Maybe i should just get my refund from amazon and buy another with a better proccessor. Whatever the guys on intel are doing it's not nice

Hope this is helpful and if you have any ideas don't hesitate to post it.