I am trying to update my Laptop which has Windows 7 Home Premium 32 Bit with SP1, to Windows 10.

I have downloaded the Windows 10 ISO files and successfully burned a DVD. During the burning process the integrity of the burn process was checked and was confirmed as OK.
I inserted the DVD and the process started indicating that the process was "preparing". I was then presented with a window " Get important updates" and I chose to Download and install updates, as recommended. The window changed to show 'Getting Updates" with an indication that it was "Checking for updates". This process went on for 20 minutes with no apparent update files being downloaded. I decided to close the window in the normal fashion but was unable to do so - it appeared that the process had locked up and the only way I could exit was to use the CTRL/ALT/DEL option and kill the process. During the killing of the process, it reported that "Modern setup host is not responding".
I tried the procedure again but got the same result.....
I would be grateful for any suggestions as to how I can cure the problem.

Thank You