I am not the most computer savvy and had been putting off upgrading from Windows 8.1 home 64 bit to Windows 10 but I eventually gave in to the pestering of Windows 10 upgrade messages and went about trying to upgrade. The Get Windows 10 report said that my PC was "good to go" with everything meeting requirements. My only worry was that elsewhere I had read that my C drive would need 16GB free and at the time of installing, my SSD C drive had only 14.5GB out of 111GB free. (I have a disc drive with 898GB of 931GB free too but I don't think that makes any difference to this). I first of all made sure that all other Windows updates were done and that my drivers were up to date.

Anyway, as Microsoft says it's fine, I went ahead updating with the Windows 10 app. It took about an hour to 100% complete the download part. It then went to preparing for installation and the wee green bar shuffled along till about a third of the way along and the next time I looked there was the EULA which I accepted. I chose to start the upgrade and then the smaller windows upgrade screen showed "Preparing for the upgrade" with a green band continually scrolling along and round. I left it for a while and it never changed. Left it for about 12 hours overnight and still the same. I tried to find out what might be the problem and found a suggestion that I should remove any unnecessary devices connected to the PC. I have a connection to my TV which I disconnected and then almost immediately the process stopped! The "Preparing for upgrade" and the Windows Update screens vanished!

There has been something downloaded (but I don't know what) as there are now only 8.76GB free so about 5.74GB has been used up. I checked the Windows Update history and it shows Upgrade to Windows 10 home, version 1511, 10586 failed. When I view the details, there is an error code C1900104 but Microsoft give no real help with this error.

I don't want to download again as I've precious little room left on the C drive now, so my only other option would be to try the Media Creation Tool. However, as I don't know if the problem has been lack of memory, the connection to the TV or something else, I am wary of trying this. Even if I can't upgrade this way, I'd still like to get my memory back but I don't know how to go about this either.

Sorry for the long winded post but I'm not sure what parts of the process are the important ones and which are not. Any advice would be very much appreciated. Thanks.