I just got a new laptop (HP Envy 13-d004na) which had Windows 10 already installed but along with a heap of bloatware that was still leaving entries in context menus and the like even after I'd uninstalled everything with Revo so I decided to do a clean install but I'm having some problems booting from my USB. Every time I try I get an error message saying:

Windows failed to start. A recent hardware or software change might be the cause. To fix the problem:
1. Insert your Windows Installation disc and restart your computer.
2. Choose your language settings, and then click "Next."
3. Click "Repair your computer".
If you do not have this disc, contact your system administrator or computer manufacturer for assistance.
File: \EFI\Microsoft\Boot\BCD
Status: 0xc000000f
Info: The Boot Configuration Data for your PC is missing or contains errors.

I get the above error message whether I have secure boot enabled or not. I've tried switching to legacy mode and did manage to get further but then got errors saying I couldn't install Windows on any of my drives because they were GPT partitioned and google told me the way to fix that is by not using legacy mode so it wasn't much help. Unfortunately at this point I'd formatted the drive to see if that would help so I can't just give up and go back to the original installation now.

I'm not sure if it's relevant but my laptop only has USB 3.0 ports and I don't have a CD drive so that's not an option either. I've remade my USB installation media once as well on a different laptop and that didn't help any. This is the first time I've done a clean install so I'm a bit stuck. I've tried googling and searching through the forums for every search term I can think of but haven't found anything that's helped yet. Any assistance would be very welcome to save me the 40 to get the computer shop round the corner to fix it!