Last night I decided to install W10TP on my MacBook Pro w/Retina using Parallels 9. Running OSX Yosemite, so I had to get the latest update to version 9 of Parallels to even use it.

Started with a Win7 VM, made a copy of it and upgraded the copy to W10TP. Install was extremely slow and didn't complete the first time and had to restart the upgrade process from the control panel. When done, the results were not great and in fact, not very good.

Here's some notes I took along the way:
1. Might have worked better with Parallels 10, but I don't use VMs enough to want to pay the money to get it. Parallels notes that version 10 is optimized for Yosemite while version 9 works. I did note that W7 worked a bit slower than it had prior to upgrading to Yosemite and the latest build of Parallels 9.
2. You cannot go full screen in the VM with W10. You could with W7, but probably some support isn't there in this tech preview.
3. Overall operation is very slow, no matter what I wanted to do, it took it awhile to load a program and then get data for it. For example, opening the Bing News app took almost 45 seconds to just open the app, and then every story picked took 20-30 seconds to load the story. Other software acts similar.
4. Numeric keypad on my full size USB Apple keyboard doesn't work with W10 at all.

This was done on a late 2012 MBPr w/8Gb of RAM. The VM was on an SD card and would be part of the slowness of load, but should not be an issue once W10 is running and an app is loaded.

IMO, useless at this point in a VM w/Parallels 9.