Windows 10: 0x800F081F when using WSUS on Domain

  1.    06 Nov 2015 #1

    0x800F081F when using WSUS on Domain

    Hey guys,

    I ran into a snag when trying to install .NET 3.5 (from Programs and Features) on our Windows 10 Enterprise domain machines.

    We recently started using Windows Server Update Services (WSUS) for our domain machines to save bandwidth when installing updates on everybody's PCs. I created a GPO and configured automatic installs, as well as specified the Intranet WSUS server connection. I did NOT disable checking online, so in Windows 7+8 there is an option to "check online for updates", and in Windows 10 we have this:
    Click image for larger version. 

Name:	ZokaOOg.png 
Views:	14 
Size:	21.5 KB 
ID:	46574

    However, it seems to ONLY check the WSUS server when trying to add optional features, and thus causes an error as the files are not there. I did some searches, and found what was said to be a solution: enabling this policy:
    Administrative Templates, System, “Specify settings for optional component installation and component repair” to “Enabled” and checking the box “Contact Windows Update directly to download repair content instead of Windows Server Update Services (WSUS)”
    What's interesting is that this DID fix the problem... on Windows 8 and 8.1 machines. But on Windows 10 I still get the error. I have seen threads where people said that GPO fixed it for them, so I'm not sure why it isn't working in my case. Yes, I've done gpupdate /force several times, and it's not just one machine that has this problem, all of our W10 domain machines do it.

    To clarify, we're using the x64 version of Windows 10 Enterprise. Not LTSB, just the normal one.

    Does anyone have any other ideas? Yes, I know I can mount the install ISO and use "dism" to do it, but that's a huge pain when we have numerous domain computers. I also don't want to specify the .wim location in Group Policy, because we have a combination of 7, 8.1 and 10 computers on our domain and that would be problematic if I only point to a Windows 10 image. Really, the solution here SHOULD be to force it to check against Windows Update online rather than our WSUS server, but somehow it doesn't want to do that.

    Here is our Windows Update GPO:

    Click image for larger version. 

Name:	nCrhoPO.png 
Views:	2 
Size:	52.6 KB 
ID:	46578
      My ComputerSystem Spec

  2.    06 Jan 2016 #2

    I have the same exact issue in my environment.

    The GPO setting to bypass WSUS for adding features works on 2012 and 8.x but not on Windows 10. This is not just one or two but all Windows 10 Enterprise systems that have this issue.

    If you watch the network, when you try to add a feature it still connects to the WSUS server instead of Microsoft directly, as though it's ignoring the GPO option.

    If they are removed from the domain, it works fine downloading from Microsoft directly.

    Using source media via command line also works, but I don't want to do that long term for many systems on the network.

    Anyone found a fix yet?
      My ComputerSystem Spec

  3.    06 Jan 2016 #3

    It actually seems to have fixed itself recently, I didn't do anything. Might have been build 1511 of Windows that did it, might have been some other update, but I'm able to install .NET now and it does download the files from Microsoft.
      My ComputerSystem Spec

  4.    06 Jan 2016 #4

    It's still not working for me, even with 1511 and brand new imaged systems. I'm stumped.
      My ComputerSystem Spec

  5.    06 Jan 2016 #5

    seems i may need this:

    I'll give it a go and provide my results
      My ComputerSystem Spec

  6.    06 Jan 2016 #6

    Ah yeah, that might be it. I have it auto-approving and auto-installing WSUS updates too so it probably did that.
      My ComputerSystem Spec

  7.    06 Jan 2016 #7

    Ok so I didn't need that update.

    All I needed was under "Products" - Windows 10 Feature on Demand and that's it. Then approve the features I want to deploy and voila.

    I'm not sure why it doesn't allow the other GPO setting though, you would think that it wouldn't ignore talking directly to Microsoft.

    The only updates that can be approved under this product are .net 3.5, directx, insider hub and language packs.

    I hope this post helps someone else. Not much else out there that explains how to solve this without using media.
      My ComputerSystem Spec


Related Threads
Hello everyone! I tried everything that can be found on the internet, i tried to download from microsoft website, no luck, tried the offline install with the win 10 installer, nothing worked. I really need a fix, so please try to help me! :(
I'm running WSUS 3.0 on a Windows Server 2012 R2. It doesn't seem to recognize a Windows 10 machine because my Windows 10 Pro x64 machines are listed as "Vista" on my WSUS Server. No WSUS update has been issued to bring WSUS up-to-date.
Windows 10 Home not connecting to intranet WSUS in Windows Updates and Activation
Anyone know if the Windows Update client for Windows 10 Home is limited in any way compared to Windows 10 Pro and Windows 7? The usual 3 registry keys: "WUServer"="http://<intranetserver>" "WUStatusServer"="http://<intranetserver>" ...
WSUS offline now with W10 support in Windows Updates and Activation
WSUS Offline is an app. to download updates from Windows Update and install them later. Very useful if you are an IT person and must update a lot of Windows installations. WSUS Offline Update - Update Microsoft Windows and Office without an...
.NET Framework Error (0x800F081F) in Software and Apps
Whenever I try to use anything that uses .NET Framework I need to re download it. The problem is that whenever i try to the error message "Windows couldn't find the required files to complete the requested changes. Make sure you're connected to the...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 06:03.
Find Us