Page 1 of 2 12 LastLast
  1.    08 Oct 2015 #1
    Join Date : Aug 2015
    Posts : 45
    Windows 10 Pro

    Moving to RAID 0 - INACCESSIBLE_BOOT_DEVICE


    I am converting an existing Windows 10 Pro laptop to RAID 0 - and I keep getting to the final boot where it says INACCESSIBLE_BOOT_DEVICE. What am I doing wrong? The laptop has two 1 TB Samsung 850 SSDs that are identical. Laptop is a HP Zbook 17.

    Here are my steps:

    1. Made a good System Image of C: drive on separate external SSD drive connected by USB. D: drive didn't have anything on it to be saved.
    2. Used Win 10 Pro DVD to delete all partitions/format drives.
    3. Went into BIOS and changed from AHCI to RAID, and also to turn on ability to do Control-I to get to Intel RST ROM.
    4. Rebooted, did Control-I, created a RAID 0 of the two disks.
    5. Rebooted, installed Windows 10 fresh. Verified it would reboot on its own.
    6. Rebooted, went into Repair on Windows 10 DVD. Selected external SSD image to do image restore from.
    7. Rebooted - verified on Control-I that the RAID 0 array is listed as "bootable"
    8. Rebooted - get INACCESSIBLE_BOOT_DEVICE.

    The place it dies - I see the little Windows 10 blue window, and the spinning circle at the bottom - then I get the blue screen with the message.

    I think I listed everything I did - what am I missing?
      My ComputerSystem Spec
  2.    08 Oct 2015 #2
    Join Date : Apr 2014
    Posts : 3,361
    W10 Pro x64/W7 Ultimate x64 dual boot main - W10 Pro Insider Preview/W7 Pro x64 - remote pc

    The need to install 10 fresh! When similarly working with a storage array of two drives with each still seeing a separate volume but configured into a SCSI array they were fortunately brand new at the time without much on either of them to see backed up onto a 3rd drive. The change of the change of mode in the bios is presently seeing 10's boot configuration made useless where you may end up needing a repair install if not able to use the Startup repair tool or rebuild the boot sector. For that the bootrec /rebuild command would be used once the drive has been selected at the command prompt option when booted live from the 10 media.

    Potential problem? When nuking the first of two primary partitions on the second desktop once the first 7 upgraded to 10 primary was nuked to move the second with the clean 10 install forward the drive was not able to see a new BCD store and boot sector created where the second clean install was then needed to replace the first! When changing from Native IDE to AHCI it took a few full startups for 10 to smooth out but later had to be reverted back in order to boot from optical media.

    For your situation the change is a bit more involved where you may have to revert back or face the need for a replacement install. When setting up any array the usual expectation is to start fresh not simply expect everything to work in an instant due to the pronounced effect the change has on any existing Windows or other OS installations.

    I found one MS solution but was originally intended for 8 on AHCI/RAID issues where the Windows installaiton goes into a loop cycle of restarts you can try out. Changing the ATA Drive setting in System Bios causes reboot loop on Windows 8

    Mainly during the change of bios settings you can run into this type of BSOD situation usually as a result of not seeing a necessary Plug'n'Play type driver go on.
    Last edited by Night Hawk; 08 Oct 2015 at 15:45. Reason: additional information added
      My ComputerSystem Spec
  3.    08 Oct 2015 #3
    Join Date : Aug 2015
    Posts : 45
    Windows 10 Pro
    Thread Starter

    Thanks for the reply but sorry that was very hard to understand what part of what you said applied to my situation! Are you saying this will only work to install fresh and then reinstall apps etc. fresh (and restore of files) - in other words can't be done using a system image?
      My ComputerSystem Spec
  4.    08 Oct 2015 #4
    Join Date : Jul 2015
    Posts : 9,146
    Windows 10 Pro

    I would use Macrium Reflect Free to make an image of the System Reserved or EFI partition that the system is using to boot - when the new install Windows 10 is functioning correctly. Also make a Macrium Reflect Free rescue disk. Restore you previous system image, which will result in the inaccessible boot device error. Then boot from the Macrium Reflect Free rescue disk and restore only the boot partition that was working.

    You can also boot from the Macrium Reflect Free rescue disk and just attempt to run the fix startup problems utility to recreate your boot files to match the Raid 0 setup.
      My ComputerSystem Spec
  5.    08 Oct 2015 #5
    Join Date : Apr 2014
    Posts : 3,361
    W10 Pro x64/W7 Ultimate x64 dual boot main - W10 Pro Insider Preview/W7 Pro x64 - remote pc

    Why does he have to download Macrium to another machine being used at the moment to post here? Since 10 isn't booting up to the desktop where he could download and install MR in order to see the image made he needs a live option he can work with if he is unable to access the F8 Repair options like the Automatic repair or command prompt options.

    Another post regarding this type of problem in 10 refers to the use of the Check Disk tool if the Automatic repair previously Startup repair tool fails to work. This was a post at the MS answers site of a similar problem without the AHCI to RAID change but still regarding the same type of error. http://answers.microsoft.com/en-us/w...f-71d1472847d1

    Now since the F8 option didn't work and the Automatic repair was attempted when booted live from the 10 dvd only once? that often takes two or maybe 3 runs to see results. The other option would be seen to at the command prompt option for a run of the Disk Check tool with the command seen in the reply there. The command you can try out as well as is simpy typed as "chkdsk /f/r" without the quotes with the fix and repair switches added onto the command to start the Disk Check tool up.
      My ComputerSystem Spec
  6.    09 Oct 2015 #6
    Join Date : Aug 2015
    Posts : 45
    Windows 10 Pro
    Thread Starter

    So what is the issue I am having? See if I have it correct:
    1. By changing the BIOS to RAID from ACHI, and doing the Control-I to set up a RAID 0 array, the hardware/firmware is set up
    2. When I installed Windows 10 fresh, it created a master boot record (MBR) that supported a boot from RAID array
    3. When I restored my single disk Windows 10 image using the Windows system image backup, it rewrote the MBR to boot from a single disk. So when I rebooted, the system could not find a boot device.

    Is that a correct assessment of what happened?

    If so, I need an easy way to either restore my Windows image and the restore the MBR to boot from RAID, or to restore some other image I created from a third party that I can selectively restore all but the MBR. Unless there is some way to "fix" the MBR after I get to step 3 above, to get it to boot from th existing RAID array.

    Is that correct? Is this the easiest by Navy LCDR - boot from the Macrium Reflect Free rescue disk and just attempt to run the fix startup problems utility to recreate your boot files to match the Raid 0 setup? Where is "Fix Startup Problems Utility", is that Macrium?

    or is there an easier way to do this?

    Thanks for your patience and help!
      My ComputerSystem Spec
  7.    09 Oct 2015 #7
    Join Date : Jul 2015
    Posts : 9,146
    Windows 10 Pro

    Quote Originally Posted by awalt View Post
    So what is the issue I am having? See if I have it correct:
    1. By changing the BIOS to RAID from ACHI, and doing the Control-I to set up a RAID 0 array, the hardware/firmware is set up
    2. When I installed Windows 10 fresh, it created a master boot record (MBR) that supported a boot from RAID array
    3. When I restored my single disk Windows 10 image using the Windows system image backup, it rewrote the MBR to boot from a single disk. So when I rebooted, the system could not find a boot device.

    Is that a correct assessment of what happened?
    Yes, that is what happened.

    Quote Originally Posted by awalt View Post
    If so, I need an easy way to either restore my Windows image and the restore the MBR to boot from RAID, or to restore some other image I created from a third party that I can selectively restore all but the MBR. Unless there is some way to "fix" the MBR after I get to step 3 above, to get it to boot from th existing RAID array.
    Correct.

    Quote Originally Posted by awalt View Post
    Is that correct? Is this the easiest by Navy LCDR - [COLOR=#333333]boot from the Macrium Reflect Free rescue disk and just attempt to run the fix startup problems utility to recreate your boot files to match the Raid 0 setup? Where is "Fix Startup Problems Utility", is that Macrium?

    or is there an easier way to do this?
    Yes, on the Macrium Reflect Rescue Disk will be an option, I think under restore, to fix startup problems. That is just a utility program that will search your hard drive(s) for windows installations and make the proper entries in the BCD to boot from them. Not sure if that will fix your problem or not.

    You can also try booting from Windows 10 install media and select the repair option in the lower left hand corner instead of install now.

    To summarize your problem - the clean install created the proper MBR/Boot Record/BCD to boot from RAID 0. Restoring the system image replaced the RAID 0 boot files with the boot files required to boot from standard AHCI disk setup. Your solution is to now replace those boot files with those required for RAID 0 again.

    If you set your bios back to standard booting and boot into your non-Raid Windows 10, you can use Macrium Reflect to create a system image of your standard install that you have now. Then set bios back to RAID 0, do a clean install of Windows 10, and use Macrium Reflect to restore only the C: drive operating partition. I think that will work. Windows system image only lets you backup up and restore the entire hard drive. Macrium Reflect allows you to back up and restore individual partitions.
      My ComputerSystem Spec
  8.    10 Oct 2015 #8
    Join Date : Aug 2015
    Posts : 45
    Windows 10 Pro
    Thread Starter

    Thanks for the help on this, I have spent the last day reading and trying, as Macrium was new to me. Here is what I did, it still does not work; something else is going on.

    I made a Windows image backup on the spare 2nd drive that I intend to use as RAID 0, as "backup" since Macrium was new to me. I then made an image an an external SSD using Macrium. I then deleted my partitions and restored from the Macrium image, knowing I had the Windows image if I messed up the Macrium image backup somehow. Everything worked perfectly.

    So then knowing I had a good Macrium image, and a rescue USB stick, I set the BIOS and firmware to RAID 0/created a RAID 0 array. I then installed a fresh Windows 10 on the RAID array, ensuring it could reboot. I then started a restore of my Macrium image of C: drive.

    I saw there were two partitions the Windows 10 fresh install made, the first a System Reserved partition, the second a C: drive. So I dragged the Macrium image backup to the second partition, so it would not touch the System Reserved partition. On the last screen in Advanced Options it let me select "do not restore MBR from image backup". I thought this would work, but this still gives the INACCESSIBLE_BOOT_DEVICE, and trying both the Macrium boot repair and the Windows 10 boot repair doesn't fix it.

    Note, I also tried in a previous attempt just restoring the whole image backup onto the RAID 0 array, also selecting "Do not replace MBR". But that also did not work - it wiped out the System reserved partition leaving only one partition, which I thought might have been the problem. That's why I thought the first attempt I described above would work - but it didn't.

    So I am out of ideas. Something else is going on that prevents this from booting. Unless someone has an idea, I suppose my choices are stay with single drive, or reinstall everything fresh on a RAID 0 array.
      My ComputerSystem Spec
  9.    10 Oct 2015 #9
    Join Date : Jul 2015
    Posts : 9,146
    Windows 10 Pro

    Try this:
    How to: Change SATA Modes After Windows Installation
    Change to RAID mode from AHCI mode and vice versa:
    1 If currently installed, uninstall your RAID or AHCI SATA driver (for intel, intel rapid storage technology)
    2 Basically open msconfig -> boot tab -> check safe boot -> restart
    3 Go into UEFI/BIOS and set SATA mode to which ever one you want
    4 Boot up into windows safe mode
    5 Open msconfig again -> under the main menu tab (general) click the normal startup circle - > restart
    6 Your system should boot into windows fine and you can install your AHCI or RAID driver.
    If you can't get into safe mode, I think after three failed attempts at booting, Windows 10 automatically goes to Safe Mode.
      My ComputerSystem Spec
  10.    11 Oct 2015 #10
    Join Date : Apr 2014
    Posts : 3,361
    W10 Pro x64/W7 Ultimate x64 dual boot main - W10 Pro Insider Preview/W7 Pro x64 - remote pc

    When you allowed the 10 installer to create the new primary partition automatically not having selected the Drive tools option that saw the 10 installer automatically create the System Reserved partition which has been seen with Windows since Vista. Most prefer to partition the drive first and then install Windows on the single primary as a rule to avoid seeing that second partition.

    Once you opted not to replace the existing boot sector for the alternate seen with the image being stored you left the drive unbootable by not working the type of set up the image was created from as far as which drive mode. The restoration automatically from a single primary type drive overwrote the entire drive in favor of the image as would any imaging software even the Windows image made if not by another program.

    With all the fuss seen already the quickest and easiest solution was what you had already done with the spare drive instead of the intended SSD drive where you should simply backed up everything you wanted to keep and wipe it clean for a fresh install of 10 only in RAID this time around. Already having download MR you would have simply created the first image of 10 in AHCI with that in the name of the image by the way if MR allows you to name the image your way or not. The Windows option is numbered by Windows only.

    With the AHCI image made up you would then simply proceed to wipe the single primary or replace it fresh with a new single primary and then allowed the 10 installer to proceed from there. Once you have everything back on as far as files backed up and the programs you run you then create a new RAID image not replace the first but to back up the array's install. That would allow you to switch back and forth at any time without the need to see a clean install each time but simply restore the appropiate image giving you options.

    You can try NavyLCDR's suggestion there to see how far you get with it of course but should be prepared to see a fresh copy of 10 go on which generally will insure the best results. Just because something doesn't go immediately wrong is not any guaranty it won't after so many system restarts, power ups, etc.

    Here when previously seeing the two former no longer present storage drives put into a SCSI array I had to do some fast tweaking to avoid losing everything on the drives while most as fortunately backed up between the two OS drives one not in use at the time. And that was with two brand new single partitions on each drive without any OS involved.
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Raid
I have a main hard drive PLUS 2 more on a raid. With windows 7 everything appeared BUT when I upgraded to windows 10 I can not see the raid drives. It does show a raid through properties but it will not update or find the drivers automatically. I...
Drivers and Hardware
Can I boot Windows from an HDD via USB? inaccessible_boot_device
I have a Toshiba P55T-B5262 that came with a 1TB HDD containing 5 partitions: 1.00 GB Healthy (Recovery Partition) 100 MB Healthy (EFI System Partition) 918.77 GB NTFS C: Healthy (Primary Parition) 791 MB Health (Recovery Partition) 10.75...
Installation and Upgrade
Inaccessible_boot_device error after upgrade and restart
Microsoft strikes again... :mad: Upgrade worked fine using the DVD .iso I downloaded, apart from taking 3 hours. Upon restart tonight, I got an endless Inaccessible_boot_device error loop. I was able to revert to Win 7 using the Advanced...
Installation and Upgrade
Inaccessible_boot_device
Updated from Windows 7 to Win 10 And when everything finished it came up with a blue screen, I don't know what to do it keeps doing a loop.
Installation and Upgrade
1 SSD or 2 SSD RAID-0
In preparation for Windows 10 I plan on completely resetting my hard drive configuration since I currently have it spanning four hard drives. Right now my OS sits on a 128GB SSD while all the programs, games, photos, family videos, etc. sit on a...
Drivers and Hardware
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 20:55.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums