Windows 10: Stuck 12% / 42% on update installation Solved

Page 1 of 2 12 LastLast
  1.    27 Sep 2015 #1

    Stuck 12% / 42% on update installation

    Hi, I have a desktop PC running 8.1 x64. I decided to upgrade using Windows Update to 10. The files are downloaded with no problems, and then it asks for reboot. And when installing the system, the process stuck at 12% (copying files 42%). It just stays there for hours. If I force a reboot, the operation starts to revert to 8.1, and when it finally boots, I see this error: C1900101-2000D.

    I haven't found much information about the error, and honestly I have no idea what may cause and error in a simple file copy.

    I've tried the installation for a couple of times now, and I'm getting a bit desperate.

    How can I fix that weird error? Thanks.
      My ComputerSystem Spec

  2.    27 Sep 2015 #2

    You don't say how you tried the installation, but I guess it was the little flag icon and then Get Windows 10 app.

    Anyway, there are reports of people on the net, who after getting this error also tried with a DVD and the error stayed the same.

    There are a few hundred Google hits on this error code, but quickly scanning them I could not find a solution.

    After the failed upgrade, there will be upgrade log files, which may contain more information on what is going wrong in your case...
      My ComputerSystem Spec

  3.    27 Sep 2015 #3

    Reading other peoples' posts, I believe this might be a hardware or driver issue.

    Possible solutions might be:

    Update all drivers.
    Disconnect all devices (SATA, USB, ...), which you don't need during the upgrade.
    Uninstall your antivirus program before trying to upgrade.
      My ComputerSystem Spec

  4.    27 Sep 2015 #4

    I did say how, I said Windows Update. I've tried with the Windows 10 Media Tool and now the installation stucks at 41% of the copying files action, 12% overall.

    Where are those logs so I can try to determine the error?
      My ComputerSystem Spec

  5.    27 Sep 2015 #5

    This was on one of the logs:

    MOUPG MoSetupPlatform: SetupPlatform::SetSqmDatapoint(DWORD) returned: [0x80004005]

    Any clues?
      My ComputerSystem Spec

  6.    28 Sep 2015 #6

    Here's the log. I found nothing. I saw in one of then two drivers that couldn't be copied, so I deleted them but the installation keeps freezing at the exact same point.

    Can anyone set something from the log?
    Stuck 12% / 42% on update installation Attached Files
      My ComputerSystem Spec

  7.    28 Sep 2015 #7

    I am not an expert in analyzing these log files, but if you ask me, the last relevant error might well be this one:

    [0x0808fe] MIG Plugin {ff9c714f-b864-4f43-ae39-ec07d7385abe}: Skipping device 'PCI\VEN_10B9&DEV_5287&SUBSYS_AA768A01&REV_01\4&5D18F2DF&0' without driver.

    The device "PCI\VEN_10B9&DEV_5287" obviously is a ULi SATA/RAID Controller. After setup cannot find a driver for that device, setup is basically dying.

    Maybe a newer driver for that device would help getting around this error. Another option in case of failing devices is to disable them during setup, but as far as I understand it, in case of the SATA controller, if Windows cannot use a generic driver, this will basically render the PC non-functional.
    Last edited by Joergi; 28 Sep 2015 at 05:43.
      My ComputerSystem Spec

  8.    28 Sep 2015 #8

    OK, so I cleaned some drivers and tried another few times. Still no luck. The exact error is Error during SAFE_OF during MIGRATE_DATA operation (apart from the number of this topic name).

    Here's the latest log (from C:\$Windows.~BT\Sources\Panther, is that correct?).

    What could be the next step?
    Stuck 12% / 42% on update installation Attached Files
      My ComputerSystem Spec

  9.    28 Sep 2015 #9

    I just saw that the same device appears on the second log. But I deleted it. How can I get rid of it at least during the upgrade proccess?
      My ComputerSystem Spec

  10.    28 Sep 2015 #10

    The SFC command reports no errors, but DISM does. I'm gonna try to solve that first over eightforums and if I manage to do it I will come back here.
      My ComputerSystem Spec

Page 1 of 2 12 LastLast

Related Threads
Update stuck at 47% in Windows Updates and Activation
i had chosen defer upgrades but the update download reached till 47%, now its stuck. its been stuck for around a week. i unchecked defer upgrades, but its still stuck. please help!!386253862638627
Windows 10 Installation stuck @ 32% in Installation and Upgrade
Hello, I am using Sony VGN-150J with Windows 7, I tried to install windows 10 through online update but it was stuck @ installing featured and Drivers after completing 6%, I wait for more than 8hrs and then restarted my laptop. I tried with...
Installation stuck! in Installation and Upgrade
Windows 10 setup stuck at getting updates!! I use media creation tool to upgrade my old netbook to windows 10
Ask people have problem: installation stuck in Installation and Upgrade
how do you get ISO file? by MCT or MSDN? if MCT, do you download with you pc or other pc then copy?
tl;dr at bottom I started downloading windows 10 home edition for my laptop a few hours ago, and everything was going smooth until the download was finished and the updater displayed preparing for installation. It started out fine, it was going up...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 20:54.
Find Us