Windows 10 installation on NVME

Page 5 of 6 FirstFirst ... 3456 LastLast

  1. Posts : 22
    Windows 10
    Thread Starter
       #41

    When i turn off CSM my bootdrive starts and goes into installation but it tells me it needs a driver, so probably CSM enabled is better? Tomorrow ill check the install and maybe try to get a pc to clone windoes from an ssd to my NVME because the booting of windows from the drive is probably the issue
      My Computer


  2. Posts : 1,039
    windows 10
       #42

    Ok. I'm a bit lost because I haven't read the whole thread.
    No csm is not better, your motherboard is supported for windows 11 your processor too I believe. Amd ryzen 5 360p is not 3600?

    You have to disable csm, leave only the nvme ssd and do a clen install with the microsoft tool.
      My Computer


  3. Posts : 22
    Windows 10
    Thread Starter
       #43

    Ok, but when i try to install i get an issue where it tells me to install some kind of driver. And for the clean install i still need the installation device. Iíll try to get it on a USB stick or clone Windows from another drive, reset windows to factory settings and see if it works.
      My Computer


  4. Posts : 1,039
    windows 10
       #44

    Ok. If you have another ssd/hdd connected with a Windows installation, you unplug it during the clean install. And with csm disabled that old install may need to be converted to uefi/gpt.
    How to see if your installation is mbr or gpt: Check if Disk is MBR or GPT in Windows
    How to convert from mbr to gpt: Convert Windows 10 from Legacy BIOS to UEFI without Data Loss

    For the requested driver, look in the bios, there is an ahci or raid setting for nvme sdds (not the same for sata ports), by default it must be on ahci.
      My Computer


  5. Posts : 22
    Windows 10
    Thread Starter
       #45

    Yes no other drive exept for the destination and the install Device are plugged in during install. I might need to convert the installation Medium so Iíll look into that. If none of this works i might try what i already said: Clone from a finished Windows install and reset the cloned windows to factory settings. This should work if i canít resolve the issue right?
      My Computer


  6. Posts : 1,039
    windows 10
       #46

    No, the installation medium cannot be converted, it is an installation on an sdd/hdd which can be converted.
    I don't know if cloning will work but try if you can.
      My Computer


  7. Posts : 6,195
    Windows 11 Pro - Windows 7 HP - Lubuntu
       #47

    I gave you all the instructions to install on the NVMe on the second post. I will repeat them.

    Reset BIOS or load defaults.
    Set Disk mode to AHCI, not RAID
    Select OS mode = UEFI
    Disable fast boot and secure boot (you can turn it on after installation)

    Windows can be installed in two ways: Legacy-MBR or UEFI-GPT
    To install as Legacy-MBR you must boot the installation drive as Legacy
    To install as UEFI-GPT you must boot the installation drive as UEFI.

    As you have a UEFI BIOS, you should install as UEFI-GPT
    Detach all other drives (SATA or Power cable) from the MB.

    During POST, press F12 to launch the boot menu. You will see two options for the USB drive. USB UEFI (Name) and USB (Name). Select USB UEFI (Name) if you want to install as UEFI-GPT or select USB (name) if you want to install as Legacy-MBR.
    Go to install and delete ALL partitions on the main drive till you have one and only one unallocated space and then proceed.
    If you don't want to use MS account, don't enable updates or connect to the internet during installation.
      My Computers


  8. Posts : 6,195
    Windows 11 Pro - Windows 7 HP - Lubuntu
       #48

    LeDuck said:
    Hello, thanks for replying.

    My BIOS is not the newest one but itís from last year. I did update it today (when windows was still working) through the @bios app for Gigabyte Mainboards. I pulled the ďnewest oneĒ from one of the servers and it installed it, but i think it still is not the newest kne bc 08.02.23 is the newest BIOS and mine is from 01.04.22 so ill look into that.

    The installation device was created by MCT and is Fat32 and the BIOS settings are on default and fast boot is disabled.

    I will try your instructions and get back to you wetherbit works or not.
    And just as a follow up question: my old drive is probably corrupted so is it possiple to access the files by plugging it in as a 2. drive and try to read from it? Because there are only like 2 files i really need and the rest is games so i could put them on a stick and it should sork because im not booting from it, right?

    Again, thanks a lot for helping me, i really appreciate it.

    - - - Updated - - -

    Side note, the Aorus logo is showing up instead of a windows logo( because of the standard settings) but it is just showing the logo, no loading signs or anything just the logo. Is that normal or is that an issue?
    Megahertz said:
    Recovering your drive is another task for a new thread.

    On BIOS, did you selected OS mode = UEFI ?
    Did you hit the F12 during POST to launch the boot menu so you able to select the USB win 10 installation drive as UEFI?
    LeDuck said:
    Yes the installation has worked without a problem, but when it reboots, it sets me into the installation process again. Should i unplug the installation device or try to boot from the NVME after the installation?

    - - - Updated - - -

    Ok even when i boot directly onto the NVME im hit with the windows installation from before. Should i reboot, unplug the installation device and try again?

    - - - Updated - - -

    I tried again without the installation device and the system couldnít find a boot device. For the boot UEFI only is enabled and i donít know what could cause the issue, when i can see the partitions of a windows system, when im prompted with the windows installation process. So i think itís not necessarily the installation but more a booting error?
    - You have to disconnect ALL other drives (SATA or power cable) from the MB specially the old windows drive, leaving on only the NVMe drive.
    - You have to boot the Win 10 installation drive as UEFI and delete ALL partitions on the NVMe drive so it will install as UEFI-GPT.
    - During installation, after it copies all files from the Win 10 USB installation drive it will reboot. When it shuts down to reboot, remove the Win 10 USB installation drive.
      My Computers


  9. Posts : 1,039
    windows 10
       #49

    Look in the bios if the nvme ssd is detected under the boot parameter after doing a clean install.
    If there is not probably this nvme ssd is not supported by your motherboard, buy another one.

    I already answered a thread here where the op have multiple nvme ssd's that were detected in bios under boot, but 1 was not detected, surely not supported.

    Edit: I read again...yes try microsoft tool usb installation media with csm disabled. Update the motherboard bios.
    Last edited by itsme1; 10 Mar 2023 at 09:27.
      My Computer


  10. Posts : 22
    Windows 10
    Thread Starter
       #50

    So those instructions didnít work. After the installation the m.2 canít be found and it goes straight into the bios no matter which way i install it. Iíll try it again and maybe update the bios but it probably wonít change anything
    Last edited by LeDuck; 10 Mar 2023 at 10:20.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 19:14.
Find Us




Windows 10 Forums