Clean Install on ROG: Error 0x8007025D (cannot install required files) Solved

  1.    28 Aug 2015 #1

    Clean Install on ROG: Error 0x8007025D (cannot install required files)

    Hey guys!

    I have a new ASUS ROG G751JT-DH72 laptop, and I have been trying to install Windows 10 and Ubuntu on it. It came with Windows 8.1, so I upgraded to 10, then did a clean install of 10. Version was Home 64 bit.

    That went reasonably well: only thing after the clean re-install was that on boot, the screen did nothing but flash on and off. I found out that I could get it unstuck by mashing F12, and that disabling fast boot fixes the problem permanently. My cleanly installed fresh Windows 10 worked perfectly.

    I then installed Ubuntu 15.04 in the small space that I had left for it on the SSD, and gave it the whole 1 TB drive for my "home" folder.

    Afterwards, Windows was gone. Mind you, the bootloader still showed up in the Grub menu, but when I tried to launch it, it told me something was wrong and I had to recover it. I tried, but couldn't: bootrec /scanos told me it found no Windows installations.

    So I figured: second attempt! I rebooted using the Windows 10 DVD, and during parititioning nuked everything and created new partitions from scratch.

    About 90% through the "Getting files ready" part, it failed. Error:

    "Windows cannot install required files. Make sure all files required for installation are available, and restart the installation. Error code: 0x8007025D"

    I see some people here had the same thing, but not on laptops as far as I can tell. Anybody out there who has any idea how to fix this? I tried:

    - Two Windows 10 discs
    - UEFI and CSM mode

    Right now, I'm installing Ubuntu on the PC in CSM mode. That way, it'll at least have *one* operating system... o_O

    Really hope anybody has any idea here. Thanks in advance, everybody!
      My ComputerSystem Spec

  2.    29 Aug 2015 #2

    I have the same problem.. I have tried different ways to clean install windows 10 but I still get the 0x8007025D error code :/
      My ComputerSystem Spec

  3.    29 Aug 2015 #3

    Hey n0xi! I fixed the problem on my end just now, and I hope my solution can help you.

    A quick history: when I first re-installed Windows 10 yesterday morning (the one time it worked properly!), I did it from a DVD that I had burned on July 29th from an ISO downloaded using Microsoft's tool that very day. After reinstalling fresh yesterday morning, I left that disc at my girlfriend's place (cos she wanted to reinstall on her own PC).

    After I screwed up my Windows partition with Ubuntu the same afternoon, the good disc was still at my gf's place. So I burned a NEW disc from another ISO. That ISO was from mid-August.

    The short story is: the 2 discs that failed me yesterday were both burned from a corrupted ISO!!

    This evening, I got the original disc (from the July 29th ISO) back from my girlfriend and it worked. Questions you could look into:

    • When did you burn your disc?
    • When did you download the ISO for it?
    • Did you check the ISO's integrity? (I found an article for this online, but bookmarked it on my desktop PC's Windows partition and right now I'm in Ubuntu. I'll follow up).

    You might try downloading the ISO again and making another startup DVD or USB key. If you have a friend who has burned him/herself a Windows 10 DVD and managed to install it from that, borrow their disc.

    Also, definitely make yourself an Ultimate Boot CD, boot your PC with that and use all its cool tools to test your PC's hardware. You want to make 100% sure all components are working properly.

    This freaked the hell out of me and I really hope some of the above can help you. I'll continue monitoring this thread and will try to help, so by all means report back.
      My ComputerSystem Spec

  4.    29 Aug 2015 #4

    Here's an article on Microsoft Answers that might help you, too. It includes the information about checking the ISO's integrity:

    How to A list of things to do if Windows 10 Setup fails. - Microsoft Community
      My ComputerSystem Spec

  5. Posts : 3
    Windows 10 64bit
       26 Sep 2018 #5

    I had this error today. I found a solution to do a clean install by changing my HDD in Bios to IDE which let me complete the install. Since AHCI is a much better performance than IDE I then followed these instructions to change back both the OS and the BIOS. How to Enable AHCI for SSD in Windows 10. - Microsoft Community
      My ComputerSystem Spec


Related Threads
I've spent the whole of today and yesterday trying to install windows 10 onto my SSD, it's not partitioned as i have read from various sites that the installation software will you all of that but everytime it get to the step after copying the files...
Hi. I helped my friend install windows 10 on his desktop pc. but after installation, it wont boot, rather showing bsod error 0xc000021a, we have tried reinstalling for a couple of times, but the error persisted. BTW, the previous os was windows 7....
Windows cannot install required files. in Installation and Upgrade
I have a Acer Aspire which is bought 5 years back.It was running windows 7 ultimate x64 and has 2 gb ram and 500 gb hdd and intel pentium.Three monts back,there was an unexpected shutdown and when started it again,it shows an error and says that ...
windows 10 activation error after clean install in Windows Updates and Activation
Hi, Was wondering if someone can help Upgraded to win 10 on my surface pro from win 8.1, on the insiders program Upgraded win 10 on release date Clean install of win 10 yesterday Now it says the windows needs to be activated but my product id...
Just a curiosity of mine - Is there a difference between a clean install and performing an upgrade while keeping only the files? In other words, is this sort of upgrade the same as a clean install, only with the files restored to 'documents',...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 13:11.
Find Us