Cant upgrade to 21H2 - Error 01xc1900101


  1. Posts : 4
    Windows 10
       #1

    Cant upgrade to 21H2 - Error 01xc1900101


    Hi All,

    I work for a large organisation and we are having problems updating over 100+ devices from 1803/1909 to 21H1/21H2. No matter what I do I continue to get the error above and they will not update.

    Just for some info we use almost exclusively Dell machines (different models) but we are only getting the issue on Laptops (different models) and the few Surface Pro's we have. I am using the latest ISO for my testing but we have the same problem when using Software Centre. As I said it works perfectly on our PCs so I am guessing it is something specific to the laptops. I have read this is probably a driver issue but I have no idea what one it is. So far I have done the below and nothing has worked.

    Removed all connected devices apart from network lead
    Removed all AV and security software
    Disabled firewall
    Deleted the $WINDOWS.~BT folder
    Removed all printers
    Removed all printer drivers
    Removed all unused drivers
    Updated all drivers from Dell (including BIOS) and Intel website
    Uninstalled all software (apart from office and driver software)
    Removed all profiles from device and created a new clean public profile
    Disabled unused devices in the bios (Wifi, Bluetooth, Card Reader, Camera etc...)

    I know a clean install will work but obviously we are talking a large number of devices so it's not really an option.

    I have the logs from Panther and Rollback and have uploaded here - Microsoft OneDrive - Access files anywhere. Create docs with free Office Online.

    I have also run setupdiag and it has come back with something but I am not sure what it is saying (results included in link above)

    Any help you can provide, much appreciated.

    - - - Updated - - -

    Quick update I completed an update successfully when I chose save my files but not apps. So that suggests its software. Will have to remove more and see what happens. If anyone can point me in the correct direction using the logs above it would be appreciated.
      My Computer

  2. dalchina's Avatar
    Posts : 34,201
    Win 10 Pro (1903) (2nd PC is 21H2)
       #2

    Hi, this is likely to be a driver migration issue but further investigation is needed.
    @Tekkie Boy is the expert here if he's willing to help, but please be aware some investigations can run to 10s of posts and require many patient iterative attempts and mutiple log submissions.

    There's usually no quick resolution.
      My Computers


  3. Posts : 4
    Windows 10
    Thread Starter
       #3

    Thanks for the response. I am willing to be patient and will post back my findings.

    As per my update I upgraded without moving apps and it worked. I have now just reverted back to the previous version (with all apps on) and just checking it fails again when I try an upgrade with apps. If it does I will remove all the software I can from the machine and see what happens then.

    As you said I think it is a driver so I will try uninstalling all I can and using Windows defaults but that will take some time and might cause other issues.

    Thanks Again
      My Computer

  4. MaloK's Avatar
    Posts : 1,416
    Windows 7 Pro
       #4

    Hi,

    A thing to try would be to Remove kaspersky endpoint protection and retry the update.
      My Computers


  5. Posts : 4
    Windows 10
    Thread Starter
       #5

    I have removed Kaspersky Endpoint Security and used the Kaspersky removal tool to remove any remnants. If there's something else hidden in there without going through the registry I wont be able to remove anything else.

    EDIT - Just looked through logs and can see it is littered with Kaspersky references. Will check again what is left on the system Thanks for advice.
      My Computer

  6. MaloK's Avatar
    Posts : 1,416
    Windows 7 Pro
       #6

    Ok,

    the log still show it as registered

    Code:
    2021-12-02 12:39:12, Info                  CONX   Windows::Compat::Appraiser::WmiQueryAntiMalware::IsUpgradeExePresent (272):   Av with display name "Kaspersky Endpoint Security 10 for Windows" (stripped name is "Kaspersky Endpoint Security 10 for Windows") has no upgrade exe dir.
    2021-12-02 12:39:12, Info                  CONX   Windows::Compat::Appraiser::WmiQueryAntiMalware::IsUpgradeExePresent (272):   Av with display name "Windows Defender" (stripped name is "Windows Defender") has no upgrade exe dir.
    2021-12-02 12:39:12, Info                  CONX   Windows::Compat::Appraiser::WmiQueryAntiMalware::IsUpgradeExePresent (272):   Av with display name "Windows Defender" (stripped name is "Windows Defender") has no upgrade exe dir.
    2021-12-02 12:39:12, Info                  CONX   Windows::Compat::Appraiser::WmiQueryAntiMalware::IsUpgradeExePresent (272):   Av with display name "Kaspersky Endpoint Security for Windows" (stripped name is "Kaspersky Endpoint Security for Windows") has no upgrade exe dir.
    2021-12-02 12:39:12, Info                  CONX   Windows::Compat::Appraiser::WmiQueryAntiMalware::IsUpgradeExePresent (272):   Av with display name "Kaspersky Endpoint Security for Windows" (stripped name is "Kaspersky Endpoint Security for Windows") has no upgrade exe dir.
    2021-12-02 12:39:12, Info                  CONX   aepic: TRACE,File::SetBaseFileInfoForPic,371,File does not exist: c:\program files (x86)\kaspersky lab\kaspersky endpoint security 10 for windows sp2\x64\wmi64.exe
    
    2021-12-02 12:39:12, Error                 CONX   Windows::Compat::Appraiser::WicaApplicationInventory::ConstructFileAsset (715):   Failed PicRetrieveFileInfo: [0x80004005].[gle=0x80004005]
    2021-12-02 12:39:12, Error                 CONX   Windows::Compat::Appraiser::WicaApplicationInventory::AddAntiMalwareFiles (616):   Failed to construct file asset [c]: [0x80004005][gle=0x80004005]
    2021-12-02 12:39:12, Info                  CONX   aepic: TRACE,File::SetBaseFileInfoForPic,371,File does not exist: c:\program files (x86)\kaspersky lab\kaspersky endpoint security for windows\avp.exe
    
    2021-12-02 12:39:12, Error                 CONX   Windows::Compat::Appraiser::WicaApplicationInventory::ConstructFileAsset (715):   Failed PicRetrieveFileInfo: [0x80004005].[gle=0x80004005]
    2021-12-02 12:39:12, Error                 CONX   Windows::Compat::Appraiser::WicaApplicationInventory::AddAntiMalwareFiles (616):   Failed to construct file asset [c]: [0x80004005][gle=0x80004005]
    2021-12-02 12:39:12, Info                  CONX   Windows::Compat::Appraiser::WicaApplicationInventory::GetInventory (295):   Finished reading Application Inventory. 146 Apps, 581 Files.
    2021-12-02 12:39:12, Info                  CONX   Windows::Compat::Appraiser::WicaEngine::RunComponents (1345):   Tier complete: Inventory.
      My Computers

  7. dalchina's Avatar
    Posts : 34,201
    Win 10 Pro (1903) (2nd PC is 21H2)
       #7

    In some cases repeatedly using the manual removal tool has helped.
      My Computers

  8. Tekkie Boy's Avatar
    Posts : 811
    Win 10
       #8

    Hello and Welcome @97browng

    The log files you uploaded are incomplete.

    I miss the setupmem.dmp

    Does every installation on the other computers crash with a blue screen like this one?

    Edit:
    There are still references to Kaspersky, but no relevant drivers or services are available on the system.

    Therefore, Kaspersky will not be the culprit.
      My Computer


  9. Posts : 4
    Windows 10
    Thread Starter
       #9

    Thanks for the response. I have just uploaded the setupmem.dmp now. It was 1gb in size so have zipped. Please note this is the one I had from the latest update attempt so won't be from the same attempt as the previous files.

    As far as I can tell they all come back with the same error (obviously not manually tested all machines but the 5 or so I have done have all been the same). I have however not been in front of the other devices and have been attempting it remotely so can't physically see the blue screen.

    Thanks again
      My Computer

  10. Tekkie Boy's Avatar
    Posts : 811
    Win 10
       #10

    Thanks for uploading the dump file.

    Restore the system to its original state.

    I am assuming that the original state already includes the current drivers from the Dell website.

    Then remove Kaspersky and use the removal tool.

    Then remove Safend Data Protection Suite and also use its removal tool if you provide one.

    And finally, please remove Sysmon from the system.

    Then try the update again.

    If it fails, use the SetupDiag tool to create a new Log.zip package and make it available again.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 18:10.
Find Us




Windows 10 Forums