Win 7 to Win 10 Upgrade Failure

Page 1 of 3 123 LastLast

  1. Posts : 10
    Win 7 Ultimate

    Win 7 to Win 10 Upgrade Failure

    Hello All,

    First post.

    Been trying to upgrade from Windows 7 Ultimate to Windows 10 Pro, with no success, and have reached the end of my limited knowledge. I’m receiving the typical C19000101-40017 Windows 10 couldn’t be installed message.

    When Microsoft was officially giving away the free update I did do the update successfully, to retain the ability to update in the future when I was ready. I uninstalled that update and everything went smooth.

    I don’t want to do a clean install.

    I’ve attempted the update directly with the Media Creation Tool and downloading the ISO and burning to CD and/or USB with no luck. Receive the same failures with all methods I’ve tried. I even downloaded the ISO file of the version of Win 10 I installed back when and still no luck.

    All external accessories besides the mouse/keyboard disconnected, firewall/antivirus disabled, clean boot, uninstalling programs, etc.

    Per an article I found online, I’ve checked the “compatdata” file in the Panther directory and am getting 3 driver packages that look to be preventing the update.

    Two of the OEM files listed, point to .inf files for the Windows XPS service/viewer, which is strange since I have it disabled/unchecked in the “turn windows features on/off” of the programs and features section.

    The other OEM file points to “inspect.inf -- Comodo NDIS LWF Driver”. I have no idea how/why this is there as I haven’t installed anything from Comodo but I’m not smart enough to figure out where this driver/file is and what to do about it. Same thing for those .inf files that point to XPS.

    Below is the section for the driver packages from the “compatdata” file.

    <DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem183.inf"/>
    <DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem160.inf"/>
    <DriverPackage HasSignedBinaries="False" BlockMigration="True" Inf="oem79.inf"/>
    <DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem41.inf"/>
    <DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem42.inf"/>
    <DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem49.inf"/>
    <DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem181.inf"/>
    <DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem65.inf"/>
    <DriverPackage HasSignedBinaries="False" BlockMigration="True" Inf="oem0.inf"/>
    <DriverPackage HasSignedBinaries="False" BlockMigration="True" Inf="oem1.inf"/>
    <DriverPackage HasSignedBinaries="True" BlockMigration="False" Inf="oem175.inf"/>

    At this point my limited computer abilities have been exhausted so I’m turning to the experts for help….

      My Computer

  2. steve108's Avatar
    Posts : 19,399
    19041.1466 - 2004/20H1 Pro x64

    danohall hello and welcome to tenforums ,

    If you use a 3rd party firewall, VPN, or antivirus - you must uninstall them before trying to upgrade - disabling may not be good enough.

    I would make sure all drivers and BIOS are up to date from PC manufacturer website.

    Check your installed apps to see if anything Comodo related shows up - then uninstall it.
      My Computer

  3. steve108's Avatar
    Posts : 19,399
    19041.1466 - 2004/20H1 Pro x64

    DriverView: Loaded Windows Drivers List

    See if this helps figure out what driver files are that you are seeing. Check related apps from the link too.
      My Computer

  4. steve108's Avatar
    Posts : 19,399
    19041.1466 - 2004/20H1 Pro x64
       #4 this may also help you get to the bottom of the failure reasons
      My Computer

  5. Posts : 10
    Win 7 Ultimate
    Thread Starter

    All previous anti-virus programs (Norton) have been uninstalled. I used Norton Power Eraser back when I uninstalled it. Mobo is fairly old and the BIOS and drivers have been updated for years. Nothing related to Comodo shows up anywhere on my system. I did just find a couple entries in the registry with the name Comodo. Deleted them.

    Ran setupdiag and pasting the results below. Not sure how to read it but it does say "Error: Found unsigned driver related boot failure."

    I deleted my "Machine Name" below so you can ignore it.

    Matching Profile found: UnsignedDriverBootFailure - CD270AA4-C044-4A22-886A-F34EF2E79469
    SetupDiag version: 1.6.2107.27002
    System Information:
    Machine Name =
    Manufacturer = Gigabyte Technology Co., Ltd.
    Model = Z87X-D3H
    HostOSArchitecture = 1033
    FirmwareType = PCAT
    BiosReleaseDate = 20140825000000.000000+000
    BiosVendor = BIOS Date: 08/25/14 15:45:56 Ver: 04.06.05
    BiosVersion = F9
    HostOSVersion = 6.1.7601
    HostOSBuildString = 7601.24545.amd64fre.win7sp1_ldr_escrow.200102-1707
    TargetOSBuildString = 10.0.19041.900 (vb_release_svc_prod3.210311-1736)
    HostOSLanguageId =
    HostOSEdition = Ultimate
    RegisteredAV = Microsoft Security Essentials
    FilterDrivers = FileInfo
    UpgradeStartTime = 10/27/2021 6:16:33 PM
    UpgradeEndTime = 10/27/2021 6:37:23 PM
    UpgradeElapsedTime = 00:20:50
    CV = DcyRA8kChkaw4sVh
    ReportId = 8726eb31-2f11-449c-b1b4-ead8b64f1ae2

    Error: Found unsigned driver related boot failure.
    Last Phase: FirstBoot,End.
    FatalErrorStatus: -1073740760
    WinLoadErrorCode: 1
    For help finding unsigned drivers see the follow blog entry: Verify if System Files and Drivers are Digitally Signed in Windows
    To remove unsigned drivers via Device Manager: Using Device Manager to Uninstall Devices and Driver Packages - Windows drivers | Microsoft Docs
    To remove unsigned drivers via admin cmd prompt: Using Device Manager to Uninstall Devices and Driver Packages - Windows drivers | Microsoft Docs
    To fix corrupted system files:

    Last Setup Phase:
    Phase Name: Post First Boot
    Phase Started: 10/27/2021 6:36:26 PM
    Phase Ended: 10/27/2021 6:37:22 PM
    Phase Time Delta: 00:00:56
    Completed Successfully? True

    Last Setup Operation:
    Operation Name: Ensure suspended services are stopped
    Operation Started: 10/27/2021 6:37:22 PM
    Operation Ended: 1/1/0001 12:00:00 AM
    Operation Time Delta: 0:00:00:00.0000000
    Completed Successfully? False
      My Computer

  6. steve108's Avatar
    Posts : 19,399
    19041.1466 - 2004/20H1 Pro x64

    Did you put those links in the above reply about finding unsigned drivers, etc? Have you tried finding the unsigned driver with the link?
      My Computer

  7. dalchina's Avatar
    Posts : 34,278
    Win 10 Pro (1903) (2nd PC is 21H2)

    Your initial error number given approximately is typical of a driver-related issue,- failure to migrate.

    You will need to inspect the upgrade logs for clues- try searching for, yes, driver.

    Then you can uninstall the appropriate program.
    @Tekkie Boy
    - here's another for you.
      My Computers

  8. Megahertz's Avatar
    Posts : 3,517
    Windows 7 HP 64 - Windows 10 Pro - Lubuntu

    A Z87X-D3H isn't very old. I had Win10 installed without issue.
    A upgrade is never a good solution, specially on a 8 year old computer.
    I suggest you do a data backup on an external drive and do a clean install.
    When asked for a key, insert the Win 7 key you have used on the Win 7 installation.
      My Computers

  9. Posts : 10
    Win 7 Ultimate
    Thread Starter

    So I ran the driver view program. Going to try and attach the results. Sorted it to show the four unknow files at the top but other than that, I don't know what info is useful or not. Hopefully the file comes through in a readable format. Thanks.
    Win 7 to Win 10 Upgrade Failure Attached Files
      My Computer

  10. Tekkie Boy's Avatar
    Posts : 812
    Win 10

    Please upload the package created with the SetupDiag Tool on

    Instructions for the wetransfer website you can find there:

    Repair install for win 10 failing
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 19:21.
Find Us

Windows 10 Forums