Laptop w/ 1909 installed, no upgrade is offered

Page 2 of 2 FirstFirst 12

  1. Posts : 161
    Windows 10 Professional x64
    Thread Starter
       #11

    itsme1 said:
    Did you create an ei.cfg file when windows wouldn't let you install the edition of your choice?
    I was aware of such an option (though I'm not sure it was exactly the same), but I came to the conclusion that removing the OEM Activation data from the BIOS was better since it ensured I would not have to resort to such tricks in the future, whatever may happen (e.g. in case I have to reinstall Windows from scratch in a few years).

    That being said, I saved the data before removing it, just in case...

    Btw, in case someone is interested, the process of removing such data is fairly straightforward, at least on my Aptio V BIOS, I don't remember the exact command line but it involved the generic BIOS management utility with the /OAD switch to delete OA data. Conversely, there's a switch to insert OA data that takes a file as an argument.

    EDIT :
    I removed the safeguard hold but it didn't change anything, now I'm suspecting a malware. I tried Malwarebytes which didn't change anything, but I can't shake the feeling there's something fishy. I will do an in-place upgrade soon.
    Last edited by NovHak; 17 Sep 2021 at 22:11.
      My Computer

  2. dalchina's Avatar
    Posts : 33,109
    Win 10 Pro (1903) (2nd PC is 21H1)
       #12
      My Computers


  3. Posts : 161
    Windows 10 Professional x64
    Thread Starter
       #13

    Yes, I based myself on this tutorial but it didn't work. Thinking of it it's not that surprising, I mean 20H1 is old enough that all safeguard holds must have been lifted by Microsoft...

    But it was worth trying since the symptoms are really those of an SH.

    I didn't upgrade the laptop yet, but I will update this thread as things go.
      My Computer

  4. dalchina's Avatar
    Posts : 33,109
    Win 10 Pro (1903) (2nd PC is 21H1)
       #14

    Specifically, 3rd time:
    Hi, if it's Win 10 Pro, check no group policy is in place related to Windows Updates, in particular that related to deferring feature upgrades.
    which I don't think you've responded to. Apologies if I've missed it.

    Otherwise try the MS upgrade assistant, or download an iso file and use that.
      My Computers


  5. Posts : 161
    Windows 10 Professional x64
    Thread Starter
       #15

    I didn't respond because I said earlier it's a home edition.

    Right now I'm trying to get a 21H1 installer bootable USB stick from the official ISO, which I have problems doing since I'm on Linux and don't have access to tools such as Rufus. Of course I could run Rufus on the target machine, or probably even more simply use MCT, but :
    • I consider the machine possibly corrupted, so I won't let it create its own upgrade tool
    • I'm not a fan of the concept behind MCT, that's to create an installation medium from running system files, with variable software components, making it non-reproducible hence not verifiable
    • I want to remain autonomous as much as possible, doing things myself instead of relying on helper programs


    But that's matter for another thread, which I'm going to create !
      My Computer

  6. dalchina's Avatar
    Posts : 33,109
    Win 10 Pro (1903) (2nd PC is 21H1)
       #16

    Not in your first post you didn't...

    I'll leave you with it. Good luck.
      My Computers



  7. Posts : 161
    Windows 10 Professional x64
    Thread Starter
       #17

    So, failing (for now) to boot a Win10 installer USB stick on this computer, I tried the Upgrade Assistant, which is an available option at https://www.microsoft.com/software-download/, but it didn't work :
    1. The assistant checks the machine and agrees to upgrade
    2. The assistant downloads the 21H2 upgrade
    3. Takes ages preparing the upgrade
    4. Reboot
    5. The computer remains with the manufacturer logo and the spinning balls thing for a long time
    6. Back to the login screen
    7. Once logged in, I check and discover much to my dismay, that version is still 1909


    Any ideas how I can check what failed, more precisely ? Because I got absolutely no info, neither success, nor failure.

    @dalchina I hope I didn't offend you, that wasn't my intention. Anyway I've updated my first post, fwiw !

    - - - Updated - - -

    Finally, problem solved ! The computer needed a BIOS update.

    Once done, Windows Update was still not proposing to upgrade, but I retried the Win10 Upgrade Assistant and it worked this time. Clearly BIOS-related, as the Upgrade Assistant has failed three times before, and Windows installers were refusing to boot, and now the same Windows installer is finally booting.
      My Computer


 
Page 2 of 2 FirstFirst 12

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 11:38.
Find Us




Windows 10 Forums