switch Legacy to UEFI

  1. T J
    Posts : 59
    10 Home 64-bit 21H1

    switch Legacy to UEFI

    have Dell Inspiron 660, A12 BIOS 3/20/2018
    currently have Legacy with Secure Boot disabled
    If I change to UEFI with Secure Boot enabled
    will W10 20H2 start up correctly?
    thanks (saw the W11 stream today)
      My Computers

  2. Paul Black's Avatar
    Posts : 15,376
    Win 10 Pro 64-bit v1909 - Build 18363 Custom ISO Install

    Hello @T J,

    Have you looked at this? => How to Convert Windows 10 from Legacy BIOS to UEFI without Data Loss

    Also, have a look at the Related Tutorials at the bottom of the above Tutorial.

    I hope this helps.
      My Computer

  3. T J
    Posts : 59
    10 Home 64-bit 21H1
    Thread Starter


    - - - Updated - - -

    I tried the tutorial method. While the validation completed successfully; the convert portion failed.
    switch Legacy to UEFI-dell-mbr2gpt.jpg
    Same error in W10 or command prompt at boot. Might be a Dell problem?

    Purchased AOMEI Partition Assistant Professional couple years ago; it can convert MBR to GPT (or GPT to MBR) without data loss. I'll give that a try.
    Thanks for any Dell or AOMEI tips.

    - - - Updated - - -

    AOMEI Partition Assistant 8.0 converted 3-partition hard drive (in Dell) from MBR to GPT.
    Now have UEFI and Secure Boot ON. also updated BIOS to a13 yesterday.
    Thanks Paul for getting me on the right track.
    Last edited by T J; 26 Jun 2021 at 18:07.
      My Computers

  4. AddRAM's Avatar
    Posts : 4,506
    Windows 10 Pro

    Partition Wizard has that option too, not positive if it will retain all data.
      My Computers

  5. T J
    Posts : 59
    10 Home 64-bit 21H1
    Thread Starter

    Dell Utility (39 MB) is still Fat16.
    MR7 shows that Recovery (18.25 GB) is now FAT32 (it was NTFS).
    Recovery appears to be EMPTY now; it had 10.5 GB of W7 recovery items; wasn't planning on going back to W7.
    OS (C:) percentage appears to be the same as before.
    AOMEI Partition Assistant Pro didn't add another partition like the mbr2gpt command does.
    Dell is working great. Dell partitions may have problems with the mbr2gpt.

    switch Legacy to UEFI-mbr-gpt.jpg
      My Computers


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 07:46.
Find Us

Windows 10 Forums