I decided to install Windows 10 on an old computer in my basement (at least 15 years old) in order to see how it would perform. It already had Windows XP Pro installed. This was my plan:

1. Install Windows 10 Pro 32-bit onto a virtual machine using an All-In-One Windows ISO that I have.
2. Use AOMEI Backupper to create an image of the virtual machine and save the image on my thumbnail drive.
3. On the old computer, shrink the partition Windows XP is installed on to make space for Windows 10 using GParted (bootable disk partitioning utility) and move it to the back of the HDD.
4. Install AOMEI Backupper on the old machine, plug in the thumbnail drive, and use it to restore the system drive of Windows 10 from the image onto the now-unallocated space on the Windows XP HDD (in the front of the HDD).
6. Use a Windows 10 32-bit Repair Disc (created by Windows 10 virtual machine) to fix the now-unbootable computer.
7. Do whatever.

My problem is that the repair disc will not work. I insert it into the PC, boot from it, and the Windows logo shows up with no loading icon underneath. It is presumably loading files as the disc drive is making noise and the access indicator is lit up. No HDD activity. After a few minutes, the PC will reset by itself. The loading icon underneath the Windows logo never shows up. If I eject the disc while the Windows logo is visible, I will receive a blue screen with an I/O error message telling me to reinsert the disc and press Enter, so it's not completely broken. If I reinsert the disc and press Enter, the Windows logo will reappear then the computer will reset after a while. I tried two disc drives and both had the same problem. I know that the disc drives are operational, though, because GParted and a 64-bit Windows 7 Repair Disc worked (although the Windows 7 disc did not fully initiate, due to the fact that the computer is 32-bit). I also verified that the Windows 10 repair disc was not broken by booting it in the virtual machine, which was successful. It asked me for my language and gave me the repair options. Is there anything that I'm doing wrong?

The computer does meet the minimum requirements, by the way.