Unable to install Windows 10 on NVMe drive on B550 MB

Page 1 of 2 12 LastLast

  1. Posts : 51
    Windows 10
       #1

    Unable to install Windows 10 on NVMe drive on B550 MB


    I have had no problem in the past installing Windows 10 on SATA drive, but I am failing now to install it on a 500GB WD-Black SN750 NVMe drive installed on a Gigabyte B550 Aurus Master.In the MB BIOS, I disabled all the boot drive options other than WDS500G3XHC-00SJG0 (which, I assume, is the NVMe drive).

    Other settings were:
    Fast boot Disabled
    CSDM Support Enabled
    Storage Boot Option Control UEFI only

    I then booted a USB drive containing the Windows 10 Installation software, and input the activation code. The NVMe drive was recognised by the installation software, which I then used to create a partition. I then waited while the software appeared to be installing Windows 10 on the partition. But when the PC rebooted, it booted back into Windows 10 Installation USB drive, beginning the installation process again from the start.

    I removed the USB drive and tried to reboot, but no drive was found.

    I tried repeating the installation process, deleting the partition created by the first installation attempt and creating a new partition, and the same thing happened.

    I tried going through the installation process again, but instead of deleting the partition created by the previous installation attempt, asking the installation software to use the partition created in the previous attempt, but it said that it could not use that partition.

    I tried performing a Start-up Repair instead of a fresh installation, but it was unable to do this.

    Any suggestions would be much appreciated!
      My Computer


  2. Posts : 17,273
    Windows 11 Pro
       #2

    Why are you manually creating partitions?
      My Computer


  3. Posts : 51
    Windows 10
    Thread Starter
       #3

    I will be having more than 1 partition on the disk, with WIndows on the first partition. This is the approach that I've taken in the past.

    - - - Updated - - -

    I'm now getting a 0x80300024 error whether or not a try to create a partition first, so possibly there is a hardware error with the NVMe drive?
      My Computer


  4. Posts : 17,273
    Windows 11 Pro
       #4

    Here's a few things I am seeing. You say you have CSDM Support Enabled and disabled all the boot drive options other than WDS500G3XHC-00SJG0. That sounds to me like you are setting up the NVMe SSD to boot in legacy BIOS mode (assuming CSDM support means CSM - UEFI bios option to boot the computer in legacy BIOS mode). Then you have Storage Boot Option Control UEFI only set. That would seem to indicate that it is going to boot the USB flash drive in UEFI mode.

    The result is that Windows is creating a UEFI install, partitioning the drive as GPT, and then on reboot, the computer is trying to find an active partition on an MBR drive to boot in legacy BIOS (CSM) mode and it can't find it.

    1. Assuming CSDM mode means CSM (legacy BIOS) mode, you need to disable that. When that is disabled, you like won't see WDS500G3XHC-00SJG0 as a boot option any longer because that is likely a legacy BIOS (CSM) option and not a UEFI option. After you complete the Windows 10 install, there should be a Windows Boot Manager entry that appears in UEFI boot priority settings, which will be the new EFI system partition on the SSD to boot from.

    Also, how did you create the USB flash drive that you are installing from? Please don't say rufus.
      My Computer


  5. Posts : 51
    Windows 10
    Thread Starter
       #5

    Thank you for the detailed response.

    I downloaded the standard Windows 10 installation software from Microsoft's site.

    On the first occasion that I tried to install Windows on the partition created during the previous unsuccessful installation attempt, it reported that it was unable to install Windows on a GPT drive, which is consistent with your supposition.

    I have now disabled CSM, and the Storage Boot Option Control BIOS option disappeared. However, I was unable to check the effect of this, since whatever I do, the installation software returns the 0x80300024 error whenever I ask it to proceed with the installation.

    I think that I now need to investigate the 0x80300024 error further.
      My Computer


  6. Posts : 17,273
    Windows 11 Pro
       #6

    Ubtree said:
    I think that I now need to investigate the 0x80300024 error further.
    Boot from the flash drive. On the very first screen for installation press shift+F10 to open a command prompt. Then run:

    Code:
    diskpart
    list disk
    select disk # <-replace # with the actual number for the SSD drive
    clean  <-this will completely erase the disk selected above.  Make sure it is the SSD!
    exit
    exit
    Proceed through the installation, but select the unallocated space on the SSD to install to. Do not create any partitions. If this fixes the installation, you can shrink the C: drive partition after installation to make room for additional data partitions.
      My Computer


  7. Posts : 51
    Windows 10
    Thread Starter
       #7

    I have followed the instructions, and diskpart reported that the disk had been successfully cleaned, but unfortunately when I selected the drive it still reported "We couldn't install Windows in the location you chose. Please check your media drive. Here's more information about what happened: 0x80300024."
      My Computer


  8. Posts : 17,273
    Windows 11 Pro
       #8

    I would recreate the USB flash drive and/or try a different flash drive. Also, try plugging the flash drive into one of the black USB ports on the back of the computer above/beside the HDMI port.

    If all that fails, you might have a bad SSD.
      My Computer


  9. Posts : 51
    Windows 10
    Thread Starter
       #9

    Thank you for the further suggestions. I've now tried both, but with the same result.

    I'll now investigate the BIOS settings in detail, and if nothing comes of that, I'll have to try a new drive.
      My Computer


  10. Posts : 3,987
    Windows 7 HP 64 - Windows 10 Pro - Lubuntu
       #10

    If you do have any other drive, I suggest you to detach it (take off the power cable)
    Are you booting the Win 10 installation drive as UEFI?
    Insert the USB disk on a black USB port.
    Start the computer and repeatedly press F12 to launch the boot menu. You may see the USB drive in two modes: Legacy and UEFI. You must choose UEFI.
    During installation, delete all partitions on the MVMe drive and then proceed.
      My Computers


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 13:52.
Find Us




Windows 10 Forums