WIndows 10 installation media Storport.sys error when trying to intall


  1. Posts : 1
    Windows 10
       #1

    WIndows 10 installation media Storport.sys error when trying to intall


    So im trying to install windows 10 pro into a IBM x3650 M4 Raid 0, and on boot from the installation usb, it gives me a blue screen with error "Driver IRQL not less or equal" and it says the Storport.sys failed. but when i clear my Raid configuration it boots up just fine,keep in mind i had it working just fine before i re configured the raid, i have no idea why and i've scoured Windows community, but couldn't figure out to post so here i am, any help is appreciated.
      My Computer


  2. Posts : 2,805
    Windows 11 Pro, 22H2
       #2

    Welcome to TenForums!

    This is almost certainly a result of needing a specific driver for your disk controller that is not included with Windows. It may well be that a driver included with Windows is "close enough" to work when you are not using a RAID configuration, but not suitable for use when RAID is configured. I've seen that same symptom myself. You will need to do the following to remedy this:

    1) Locate a driver for your controller. Note that there may be a seperate driver specifically for use during setup - that is what you want.

    2) Extract the contents of the driver if downloaded in the form of a ZIP or other archive file and place those files on a thumb drive or other media accessible during installation.

    3) When you get to the point in setup where you you need to choose the disk to install onto, you will see an option to load a driver. Use that option to load the driver that you downloaded.
      My Computers


  3. Posts : 1,867
    Windows 10 Pro 2004 20H1
       #3

    Easiest thing to try first -

    Device Manager > Storage Controllers

    Expand the section, right-click on the entry and select Update driver.

    Device Manager > IDE ATA/ATAPI controllers

    Expand the section, right-click on the entry and select Uninstall device.

    Reboot.

    MS may have the correct driver.
      My Computer


  4. Posts : 2,805
    Windows 11 Pro, 22H2
       #4

    @OldNavyGuy - he's getting a blue screen during installation so he won't be able to try that unfortunately, however, your post gives me another idea:

    If you cannot locate a driver to use during a clean install, you could try an upgrade install, assuming that you already have a Windows installation in place on that system.
      My Computers


  5. Posts : 1,867
    Windows 10 Pro 2004 20H1
       #5

    I was going by these statements -

    "but when i clear my Raid configuration it boots up just fine"

    "i had it working just fine before i re configured the raid"
      My Computer


  6. Posts : 1
    win 11 21h2
       #6

    hsehestedt said:
    @OldNavyGuy - he's getting a blue screen during installation so he won't be able to try that unfortunately, however, your post gives me another idea:

    If you cannot locate a driver to use during a clean install, you could try an upgrade install, assuming that you already have a Windows installation in place on that system.
    @hsehestedt i m having the same problem here, with Win10 1909 the server works OK, but with 20h1 does this problem. Do you have some sucess to resolve it?
      My Computer


  7. Posts : 2,805
    Windows 11 Pro, 22H2
       #7

    lpboldrini said:
    @hsehestedt i m having the same problem here, with Win10 1909 the server works OK, but with 20h1 does this problem. Do you have some sucess to resolve it?
    Welcome to TenForums! Unfortunately, I'm not the person who was experiencing the difficulties. We'll have to ask the OP if they were able to resolve the issue.

    @Nightmare1223 - were you able to resolve the problem?
      My Computers


  8. Posts : 1
    Windows
       #8

    I'm having a similar problem trying to install windows server 2022 with an older but well established LSI 9286-8e card. If I boot off my USB - it doesn't even get to the install screen. If I delete the array before booting off the USB stick - I can boot up to the windows installer properly. Any luck here?
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 04:50.
Find Us




Windows 10 Forums