Can't boot uefi


  1. Posts : 3
    Windows 10
       #1

    Can't boot uefi


    Hello,

    Recently I helped a friend with upgrading to an SSD and installed Windows 10 Pro. I used a custom .iso and burned it using Rufus gpt. I set the computer to boot uefi, disabled secure boot.

    The computer worked perfectly, however after sometime they started getting a bsod with winload.efi, after doing some searches I decided to try and reinstall windows. At that point I found that none of my bootable drives were working, all would fail to boot.

    I tried many ways of recreating my usb drives using many different tools, (rufus, yummy, winusb, easyusb, easy2boot among others)


    My installations would fail, either they would stop after bootx64.efi or I would get video lines on my display and the install would fail. The failures would really depend on what I would use to try and create the bootable usb.

    I had been using a modified custom windows installation and it was only until I used diskpart to manually create a 32GB partition formatted with fat32 on my 64GB usb drive that I noticed an error. When copying the contents of the iso file I received an error that the install.esd was too large.

    After further research, I found this article: USB install media with WIM file larger than 4GB – Win10.Guru

    I started going down the rabbit hole:

    - Converted the .esd to .wim
    - Tried Splitting the .wim on a Windows PE USB (32GB formatted with FAT32)
    - Tried Single .wim on a usb drive with a fat32 primary partition and an ntfs one
    - Tried Suggestions on the article and subsequent comments using the included batch files

    At the moment when I try to boot not just the HP, just about any laptop I own, whether it be Dells or HP's. I get lines on the display like the video doesn't work. I can't figure out what's going on. I have tried with different Windows versions, pro, enterprise, but no luck.

    Apologies if the post is too long or if I missed any details, this is my first post ever here. I tried replying on the attached article, but wasn't able to.

    - - - Updated - - -

    This is an image of what I get
      My Computer


  2. Posts : 20
    Win10
       #2

    You cannot copy a file greater than 4GB to a FAT32 partition. In your case this is a red herring.
    I would suggest you make a bootable USB drive using the official Windows tool and download.
    Just Google for 'Windows 10 download' and pick the Microsoft link.
    You do not need to activate the OS for 30 days and that should be enough time to find out if it is reliable or not. If you get the same issues then you know the hardware is faulty.
    Also, why do you need to do a EFI install? Is the first boot disk >2TB? Does your friend need Secure Boot? If not then try a Legacy\MBR install.
      My Computer


  3. Posts : 17,349
    Windows 11 Pro
       #3

    syslogs said:
    Hello,

    Recently I helped a friend with upgrading to an SSD and installed Windows 10 Pro. I used a custom .iso and burned it using Rufus gpt. I set the computer to boot uefi, disabled secure boot.
    Where did you obtain this custom .ISO from and what is custom about it?
      My Computer


  4. Posts : 4,078
    Windows 7 HP 64 - Windows 10 Pro - Lubuntu
       #4

    You don't need to use Rufus or any other tool to make a boot able installation drive.
    Manually create Bootable Windows 10 USB for Legacy BIOS and UEFI in Command Prompt

    Rufus may create a USB drive that is GPT. You shold revert it to MBR (using Diskpart)

    As already mentioned, you can't have any file bigger than 4 G on the installation drive, that must be Fat32 to boot as UEFI.
    Normally the biggest file is \sorces\Install.wim or \sorces\install.esd or \sorces\Install.swm

    You said you have a install.esd. How bit it is?
      My Computers


  5. Posts : 3
    Windows 10
    Thread Starter
       #5

    Thank you for the replies:

    - @SteveSi - The drive is under 2TB, I always thought though that UEFI was used for performance. So I will try Legacy. I downloaded the tools you referred to, but haven't gone down that rabbit hole :). I'll let you know

    - @NavyLCDR - I started with my base Windows .iso, but I started adding updates using instructions found online. I did find out ways to modify the .iso and been doing that here and there. I always have to relearn the process whenever I do any changes. I wasn't too organized about them, so I would make a copy every time I'd change something, although I've tried even the base windows untouched .iso of win 10 pro and had the same issues as well, practically with any hardware I'd try it on.

    - @Megahertz - I haven't tried this method, but I've tried using the Windows PE method and other methods in the above referenced article.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 03:21.
Find Us




Windows 10 Forums