Samsung All-in-One model dp500a2p

After getting the 10 upgrade and letting it activate I decided to reset it to rid my PC of the various crap I had downloaded over the last 2 years. It had been running 10 for 2 days at that point with no issues.

That reset failed, ending in a blank screen. I had downloaded and burned the Win 10 installation media so I booted that and tried to rollback, which also failed with same result. I went through the various troubleshooting options included with no luck. Every option either told me it had failed and it eventually rebooted to the same blank screen.

So giving up on the previous install I tried to do a clean install using that same recovery media. It went through all the usual installation steps and restarted; back to the same blank screen. I repeated the process, thinking that perhaps I had failed to partition it right or something. I deleted all 4 existing partitions and let it recreate its partitions from a blank drive. Same result, it went through the install steps until restart and then nothing. Once it fails to restart into Windows there is no life. No cursor, no hard drive activity, nothing.

I've tried multiple times now with no luck. I've downloaded and burned the installation media three times and tried to install via USB also. I've never gotten past the restart step of installation. It restarts, shows the Samsung splash then goes dark with hard drive activity, after 20-30 seconds the HD stops and that's it; same result every time.

I've used the SystemRescue Linux application to format the drive from outside. I don't think the drive failed. I can get into command line from the recovery menu when using the Win 10 Installation disc so I think the PC is alive at some level still.

I've tried many ideas found on the web like disabling secure boot and/or UEFI in BIOS. I came across a post about the OS choosing the wrong display and had hope but nada. Once it restarts it goes to the blank screen and that's it.

In the many times I've booted into the installer I've seen a few things other than the usual installation menu, once when asked to repair it saw 2 copies of Win 10, another time it gave me the 0XC0000001 error.

That's it, I'm at a loss at this point.

Any ideas will be appreciated. Thanks for reading this rather long post.