Page 1 of 2 12 LastLast
  1.    10 Aug 2015 #1
    Join Date : Aug 2015
    Posts : 5
    Windows 7 & 10

    Windows 10 upgrade has trashed my laptop


    After trying the Win 7 - Win 10 upgrade on my old Compaq knockabout laptop, and it going fine other than completely loosing the Internet Security suite (COMODO), I decided to upgrade my main laptop, an Acer Travelmate 5740.

    The upgrade itself went fine; however, on booting into Windows 10, the first thing I noticed was that I was down to a basic Microsoft Video driver, offering 1024x768 resolution, instead of the native 1366 x 768. No problem, I though, I'll just hop online and download the latest driver. And then I noticed that I had "limited" WiFi connectivity - on all networks I tried to connect to.
    I tried forgetting the networks and reconnecting - it can see them all OK, and "connect" to them, but Limited (this on a network with at least 7 other devices connecting fine (Win 7, Win 10, Linux, MacOS, Android). I looked for the old VPN software issue: not present. I reset the TCP/IP stack - no change. I connected to a LAN cable - no connection. Both adapters are correctly identified, although the WiFi adapter shows as "shared" although no sharing tab appears in properties. And ipconfig only displays "Windows IP configuration" with no IP information. Diagnosis shows a driver problem (no kidding), but can't fix it.

    And the Acer site shows no Windows 10 drivers for the laptop.
    I'm tempted to suggest spent more time on the logo than on the OS.
    Any suggestions?
    Thanks
      My ComputerSystem Spec
  2.    10 Aug 2015 #2
    Join Date : Jul 2015
    Posts : 9,552
    Windows 10 Pro

    Open the network and sharing center, click on the left column change adapter settings. How many network adapters are showing? Try disabling all of them except for your actual physical wireless and LAN adapters, reboot, go back and see if they are still disabled and if you have internet access.
      My ComputerSystem Spec
  3.    10 Aug 2015 #3
    Join Date : Aug 2015
    Posts : 5
    Windows 7 & 10
    Thread Starter

    Thanks NavyLCDR.

    There are only two adaptors listed, both Broadcom: a NetLink Gigabit Ethernet and an 802.11n.
      My ComputerSystem Spec
  4.    10 Aug 2015 #4
    Join Date : Jul 2015
    Posts : 9,552
    Windows 10 Pro

    Quote Originally Posted by boniface53 View Post
    Thanks NavyLCDR.

    There are only two adaptors listed, both Broadcom: a NetLink Gigabit Ethernet and an 802.11n.
    What about assigning static IP addresses to it in the IP4 properties under the WiFi adapters? Seems like it is not pulling IP addresses from the router's DHCP server.
      My ComputerSystem Spec
  5.    11 Aug 2015 #5
    Join Date : Aug 2015
    Posts : 5
    Windows 7 & 10
    Thread Starter

    Tried that: still showed problems with drivers (both ethernet & Wifi) even after installing the latest drivers from the Broadcom site. And ifconfig showed nothing.
      My ComputerSystem Spec
  6.    11 Aug 2015 #6
    Join Date : Jul 2015
    Posts : 9,552
    Windows 10 Pro

    Maybe turn IPv6 off for the network adapters?

    The only other thing would be to do another upgrade. Go back to a previous OS, make sure everything is working. Use an ISO file for the upgrade and this time before doing the upgrade make sure the computer cannot connect to the internet. No cable connected to Ethernet and disable the wireless adapter (even just in Windows if that is all you can do). Try the upgrade without connection to the internet, then when it is up and running plug a cable into the Ethernet adapter.
      My ComputerSystem Spec
  7.    11 Aug 2015 #7
    Join Date : Apr 2014
    Space coast of Florida
    Posts : 5,382
    Windows 10 Pro X64 16299.19

    On the Acer site there is a link to HWVendorDetection.exe.

    Click image for larger version. 

Name:	Trl5740.jpg 
Views:	6 
Size:	24.3 KB 
ID:	30534

    Run that and see what it says for your LAN and Wireless. May be able to find a Windows 10 (or Windows 8) driver that works for you.
      My ComputersSystem Spec
  8.    11 Aug 2015 #8
    Join Date : Aug 2015
    Posts : 5
    Windows 7 & 10
    Thread Starter

    I've previously tried turning of IPV6, with no result. The Acer utility showed the LAN and WiFi devices were Broadcom; the new drivers I installed were from Broadcom, and described as
    "NetLink®/NetXtreme® I Desktop/Mobile/Server (x64) This driver does not support BCM5700, BCM5701 and BCM5702 devices. The following Operating Systems are supported: Windows Vista, Windows 7, Windows 8, Windows 8.1, Windows 10 and Windows 2008, Windows 2008 R2, Windows 2012 and Windows 2012 R2.


    BCM5705 , BCM5703 , BCM5721 , BCM5751 , BCM5788 , BCM5704 , BCM5752 , BCM5789 , BCM5723 , BCM5761 , BCM5787 , BCM5755 , BCM5722 , BCM5754 , BCM5718 , BCM57765 , BCM57761 , BCM5719 , BCM5725 , BCM5762 , BCM5720 , BCM57766 "

    Not quite sure whether it's possible to find out if I have one of the unsupported devices.
      My ComputerSystem Spec
  9.    11 Aug 2015 #9
    Join Date : Jul 2015
    Posts : 9,552
    Windows 10 Pro

    Right click on the network adapter in Device Manger and click properties. Then click the details tab, scroll down in the Properties dialog box to hardware ids. Copy the top one. Should look something like:
    PCI\VEN_10EC&DEV_8168&SUBSYS_3591103C&REV_06

    Then google it.
      My ComputerSystem Spec
  10.    11 Aug 2015 #10
    Join Date : Aug 2015
    Posts : 5
    Windows 7 & 10
    Thread Starter

    So I booted into Linux, ran lspci, which immediately told me what my chipsets were: and searching identified there are no drivers past Windows 7.

    I would have thought that an upgrade process designed for non-geeks would have some sort of process to ensure that an upgrade does not proceed if there are no compatible drivers. The Linux Live DVD identified and loaded the correct drivers and I was immediately able to browse the web,

    So I'm rolling back to Windows 7. I guess that's a solution of sorts.
      My ComputerSystem Spec

 
Page 1 of 2 12 LastLast


Similar Threads
Thread Forum
Solved Laptop Shuts Straight Off During Windows 10 Upgrade
Hey Guys, i have a lenovo e425 laptop that recently received the windows 10 upgrade from microsoft. i am currently running windows 8.1 Pro and when i started the upgrade to windows 10, everytime it reaches the 30% part where it finishes the copying...
Installation and Upgrade
Impossible for laptop to upgrade to Windows 10
Yesterday i received a notification that my laptop was approved and confirmed ready to upgrade to Windows 10. So i launched the Windows 10 Upgrade popup and initiated the upgrade. It reached the screen where a round circle appears with the...
Installation and Upgrade
Accidently trashed BCD and resolution
I started with a dual-boot system: * Windows 7 Pro * Windows 8.1 Pro I upgraded to: * Windows 7 Pro * Windows 10 Pro I used EasyBCD to change the default O/S from Windows 10 to Windows 7. After that the boot menu was messed up. * Windows 7
Installation and Upgrade
Laptop won't turn off or restart properly since Windows 10 upgrade
Hi. I'm new to this forum, but not to computers. And this is weird... I recently started trying out Windows 10. It's buggy and frustrating, but it's still in preview mode, so... That's expected. Nothing was working when I installed build 10074...
Installation and Upgrade
Build 10041 got Trashed
First of all, I'm not looking for any help, just going to rant for a moment about my latest experience. My Build 10041 got hosed, not sure if it was hardware related or software. I applied the update to the build when it became available moving...
Windows Insider
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 15:01.
Find Us
Twitter Facebook Google+ Ten Forums iOS App Ten Forums Android App



Windows 10 Forums