Something happened 0x80070002 - 0x20016

Page 1 of 3 123 LastLast

  1. Posts : 353
    Windows 10 Professional

    Something happened 0x80070002 - 0x20016

    I'm SURE this has been hammered to death, but my searches aren't finding the 20016 error...........

    <flame on>

    As a user of Windows since 3.1 and DOS before that, I'm used to new versions having problems with installs, running like crap, crashing regularly, and all the other problems we've come to expect from Microsoft. But this one revealed that even my cynical self can still be surprised... I don't know if this whole thing is some kind of test, a massive joke at our expense, or just a total lack of MS ENSURING their @#$%^&* software will even TRY TO RUN...

    Downloaded the MediaCreationToolx64 and figured "I just want to burn a DVD with an ISO. This SHOULD BE TRIVIAL." I'm running on a massively overpowered system with 8.1, so there should be any problem. Fire it up, let it download, burn the DVD... AH, but that's where the gods at MS played their galactic practical joke.....

    Ran the MediaCreationTool. It sat there like floop in a punchbowl for a few seconds then said:

    Something happened 0x80070002 - 0x20016

    Having received this VERY understandable message - I mean what could POSSIBLY confusing about "something happened", I jumped onto the Internet to get the fix.....

    THREE HOURS, at least a DOZEN reboots, and having tried things from the maybe likely, to the not likely, to the silly, to the utterly ridiculous, I'm still receiving "Something happened 0x80070002 - 0x20016" on ALL THREE MACHINES I've tried it on... Won't work on the 8.1 desktop, won't work on the Win 7/SP1 desktop, won't work on the Win 7/SP1 laptop...

    I did a search in here and found an astonishing number of installation problems for something that's been out less than two weeks, but didn't see a topic for this.

    SO, what IS the magical incantation to get this utter POS to let me download the ISO?

    And while I'm asking, HOW do I download the update without having to go through that stupid "mother may I" process where they'll "let me know" when they've decided I should be allowed to update?

    The folks at Apple must be catatonic from the laughter. 20+ years of Windows and they still can't even get the DOWNLOADER to work reliably?

    I've tried "run as administrator" which didn't work
    "Change Local and Language Settings to English" which didn't work
    "Disable or Uninstall Antivirus Program or Internet Security Suite" which didn't work
    "Make sure all these services are turned on automatic" WHICH DIDN'T WORK
    "run wuauclt.exe /updatenow" which didn't work
    "stuck a new keyword in the registry" which DIDN'T WORK
    ran some MS piece of software that was going to FIX my system so the download would work - which didn't WORK

    and on and on through things I can't even remember at this point...

    SO, as opposed to this random rummaging and hoping SOMETHING will get this to work, WHAT do I have to do to get this software to let me download? Although, at this point I ALREADY hate Windows 10, so it will HAVE to be absolutely incredible after this ridiculous start...

    <flame off>
      My Computers

  2. Posts : 353
    Windows 10 Professional
    Thread Starter

    It just keeps getting better.... Finally grabbed my WIFE's laptop to try the last remaining PC in the house... This time at LEAST it got to the point of saying "Create installation media for another PC".......

    Then it churns for a long time, downloading. Gets to 100% then says something like "creating media". I saw it get to at least 22%, then it PUKES ALL OVER IT'S FEET... This time it's an error "Something happened 0x80070070 - 0xc19001DF"...

    Hoping SOMEBODY has a clue what needs to be done to get this thing to work...
      My Computers

  3. Posts : 18
    windows 10 Home 64bit

    Out of the 4 machines that you have, can you spare one and do a clean install of Win 7 SP1 or Win 8.1 or do a recovery to factory state for the laptop? Activate it and do all the Microsoft and driver updates but don't install any other software. Then try the Media Creation Tool again. Hopefully you can create the Windows 10 ISO on DVD and used that to upgrade the machine that you have picked for clean install of Win 7 or 8 or did factory recovery. In my experience, the cleanly installed machines are the easiest to upgrade to Windows 10. Afterwards, try upgrading the other machines if you still like Windows 10 after trying the first one. If for any reason that the upgrade for the other machine fails, you may consider to do a clean install of Win 7 or 8 or do a factory recovery same as the first machine.

    To play safe, I suggest you do a system image backup of the machines to external drive first so in case all of the above doesn't work as expected, you can use the system image backup to recover your machine to the present state, i.e. undo all the changes. Make sure you also make a recovery DVD after you make the system image backup.

    It is just a suggestion for you to consider. It is going to be very time consuming to do the above but trying to troubleshoot your problem is also going to be very time consuming too unless someone with similar problem as yours gives you a quick solution.
      My Computer

  4. Posts : 22
    Win 10 64bit

    If you want to force the Windows Update to enable direct upgrade from there (Windows Update)
    1) Delete everything in the windows/softwaredistrubtion/download folder
    Open CMD window to run as Admin and enter wuauclt.exe /updatenow
    execute 'check for updates' - if your system is not up to date, you will need to install any important ones it finds, then repeat the process
    2) If that does not work
    locate the registry key: [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\OSUpgrade]
    If does not exist, create it.
    Create a new DWORD (32-bit) Value with Name = "AllowOSUpgrade” (without the quotes), and set the Value = 0x00000001.
    Last edited by DEcosse; 11 Aug 2015 at 02:26.
      My Computer

  5. Posts : 16,278

    Probably won't make any difference, but you could try getting the download from MS's Techbench:
      My Computer

  6. Posts : 353
    Windows 10 Professional
    Thread Starter

    In THEORY, I could take my laptop and install a clean version of Windows 7. Seems undesirable to waste an entire day putting an old O/S on so I can create a source to put a new O/S on. If it's that screwed up I think I'll just delay Windows 10 for a few months til Microsoft fixes some of the more screwed up parts.....

    To make things more interesting, YESTERDAY, my laptop apparently decided to UPGRADE TO WINDOWS 10... When I went into Windows Upgrade, it said I have 23 Important updates. Told it to install them and it said "Downloading Windows 10". Figured, OK, it's apparently going to upgrade..... Let it sit and download for hours. Eventually it SAID it HAD Windows 10 and was going to start the installation... At which point it just sat indefinitely without doing anything. Never did get anything installed...

    As for forcing it to upgrade:
    The download folder is empty on my desktop AND on my laptop. Didn't make a bit of difference.
    Opened the command window as an administrator and TRIED to run wuauclt.exe / updatenow and it just tells me there's no such command. Tried putting "c:\windows\system32" on the front and still get the same message. Perhaps I'm not getting the command window to run as an admin, although I'm following the instructions for Windows 7... Go to accessories, find CMD, right click, select "Run as Administrator"..... Seems pretty idiot-proof but it doesn't find the command. I checked in the folder and there IS a wuauclt.exe sitting there.

    Went into the registry to CREATE "AllowOSUpgrade" but in the key
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate] there is NO "OSUpgrade". How do I create that so I can create the DWORD for AllowOSUpgrade?

    TODAY, since it never actually "updated" to Windows 10, when I rebooted the laptop and went into Windows Update, and tried to install the 15 important updates that need installing, it SAYS it's downloading windows 10 - it sits at 8.9MB for a while, then says "Preparing for installation". Sits there for a while while (according to the network status) it appears to be VERY slowly downloading something...

    Eventually, it told me 2 updates had succeeded and 13 had failed, and had me reboot. And after all that, it's still Windows 7. BUT, now Windows update SAYS, "Downloading Windows 10", which we've seen before and SAYS it's 2712.6 MB. And we're back to waiting.... I figure it'll eventually either actually download something and upgrade, or puke again...
      My Computers

  7. Posts : 4,431
    Win 11 Pro 22000.652

    All that I can suggest is using the Media Creation Tool to download the .iso. (It doesn't literally do that, but you end up with an .iso.)

    On an 8.1 machine, you can mount the .iso as a virtual DVD and run the upgrade from that. It's what I did on my two 8.1 machines. (Transferred the .iso to the second machine using a USB drive. Both were running 8.1 Pro X64.) Maybe that will run.

    Alternately, you might get the .iso from a chum who doesn't have whatever weirdness inhabits your 4 machines. Lots of people are having trouble with the upgrade, but I can't believe they're in the majority. I also think that it'd be very unlikely that the upgrade would fail on 4 machines as a coincidence.
      My Computers

  8. Posts : 16,278

    The command you typed - wuauclt.exe / updatenow - has an extra space in it. There should not be a space after the forward slash (/). Not sure if you just made a typo in this post, or if you were trying to run the command with that extra space. The correct command is wuauclt.exe /updatenow. The trick is, open the administrative command prompt, type the command, go to Windows Update, click check for updates, and then immediately hit enter in the command prompt window, to force the update to download. (An administrative command prompt will have C:\WINDOWS\system32> at the blinking cursor.) But, you've got the download coming through now, so that's not an issue any more.

    Leftovers from deleted user accounts can cause it to "puke". Leftovers from older/previous VPNs can cause it to "puke". Incompatible drivers can cause it to "puke". Having external drives attached will cause it to "puke". Having a third-party antivirus installed will also cause it to "puke". Bloatware from OEMs can cause it to "puke". Personally, if it's giving you that much trouble to automatically update, either update from a clean install of W7, or wait a month or two, until more of the obscure upgrade bugs are identified and squashed, and your upgrade comes through successfully. There's a reason it's not upgrading on your system(s). Could be that forcing an upgrade at this point will leave you worse off than keeping the old OS for a while longer. Upgrading from a clean install of W7 will make life easier for you in the long run, I think.
      My Computer

  9. Posts : 1
    windows 10

    I stumbled here too - in my case I ran Windows 8.1 Enterprise Edition, which is not eligible for a free upgrade :-( - and it ends up with this weird error message. With the proper version of windows 10 I was able to upgrade, but not with any of the discussed tools here.
      My Computer

  10. Posts : 22
    Win 10 64bit

    simrick said:
    The command you typed - wuauclt.exe / updatenow - has an extra space in it.
    GracieAllen said:
    ... Opened the command window as an administrator and TRIED to run wuauclt.exe / updatenow and it just tells me there's no such command.
    Note that I provided the correct syntax - you added that extra space.

    DEcosse said:
    Open CMD window to run as Admin and enter wuauclt.exe /updatenow
    ... Went into the registry to CREATE "AllowOSUpgrade" but in the key
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate] there is NO "OSUpgrade". How do I create that so I can create the DWORD for AllowOSUpgrade? ...
    Are you sure you followed the tree correctly?
    HKey_LOCAL_MACHINE -> SOFTWARE -> Microsoft -> Windows ->Current Version -> Windows Update -> OSUpgrade

    Is the Windows 7 at least up to date with all important update installed, with no failures?
    If you have any failures you need to re-attempt them - run "check for updates" again and install any it finds; if you have fails, then you need to pursue why they won't install (post the error messages here if you need help)
    If system IS up to date (no updates found) but you don't have the install windows 10 prompt in the update screen, then run the wuauclt.exe /updatenow and if it still does not appear revisit the registry for the OSUpdate key
      My Computer


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 09:57.
Find Us

Windows 10 Forums