upgrade from LTSC 2015 to 2016 not working  

  1. Posts : 3
    Windows 10

    upgrade from LTSC 2015 to 2016 not working

    Hello Forum,

    I need to bring a computer that controls a machine from Windows 7 pro to Windows 10 Enterprise LTSB 2016. That is the version that the producer of the machine is delivering with newer systems, so chances are best that their software will rund smoothly. The idea is to go to LTSB 2015 first and then to LTSB 2016 (because the direct path is not allowed by Microsoft).

    Part 1 was no problem. LTSB 2015 seems to work just nice. But when trying to go from there to LTSB 2016, the update won't let me keep my programs. I only can select "keep personal files only" or "Nothing". The desired option "keep personal files and apps" is grayed out and at the bottom it says "Your files, apps, and settings can't be kept because you're installing an edition of Windows that's different than the one you're currently using."

    So in what way could these two versions be different? I first thought it was language, the 2015 was first en-GB and the 2016 en-us. But then I rolled back and tried again with both versions en-US. Same result.

    I suspected that the problem could be that LTSC was not yet activated. So I did the activation and this also made no difference.

    If someone has an idea how to solve this problem or what else to check I would appreciate that very much. I hope this is a good place to ask. If you should recommend another site for this admittedly specific question, let me also know.

    Thanks for any help.
      My Computer

  2. Posts : 40,578
    Win 10 Pro (22H2) (2nd PC is 22H2)

    Hi I don't know if this helps or just confuses, but seems relevant. (I'm no expert on Enterprise, sorry!)
      My Computers

  3. Posts : 14,009
    Windows 11 Pro X64 22H2 22621.1848
      My Computers

  4. Posts : 3
    Windows 10
    Thread Starter

    Thanks, dalchina and Ztrucker. Both links revolve around the same topic, but unfortunately do not provide a solution. The technet looks interesting. I'll look into that.
      My Computer

  5. Posts : 14,009
    Windows 11 Pro X64 22H2 22621.1848

    Did you try mounting the ISO (right click on the ISO, select Mount) as described? That seemed to provided the keep files and apps you wanted.
      My Computers

  6. Posts : 3
    Windows 10
    Thread Starter

    hi again, more or less by accident I found out what the problem was. My first iso file, for the LTSB 2015 was WIN_ENT_LTSB_10_2015_64BIT_English and the second was WIN_ENT_N_LTSB_2016_64BIT_English.
    See the difference? I didn't for quite some time. But the additional N makes it a different version in the eyes of Microsoft so the second upgrade was blocked.

    So the solution was to get an iso without N for LTSB 2016, then it worked.

    Thanks anyway for your tips.
      My Computer

  7. Posts : 13,170
    Win10 Version 21H2 Pro and Home, Win11 Pro and Home

    But the additional N makes it a different version in the eyes of Microsoft so the second upgrade was blocked.
    Yeah, the N is a different version mostly because of various licensing laws or software competition in countries other than the USA, goes back a few years.
    What Is an “N” or “KN” Edition of Windows?
    Windows 7 N: The 'N' editions explained - CNET
      My Computers


  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 18:16.
Find Us

Windows 10 Forums