Can't Update to Windows 10 1903 on System with Unique Bootloader Setup


  1. Posts : 1
    Windows 10
       #1

    Can't Update to Windows 10 1903 on System with Unique Bootloader Setup


    Hi folks,

    Got a problem with updating a machine to Windows 10 1903. It's kind of an unusual situation, though.

    This particular machine has a cheapo RAID card in it along with two 2 TB hard drives configured in a RAID 0 array.

    Because it is a 4 TB volume, it had to be configured as a GPT partition. However, this is an older machine that does not have UEFI; it is BIOS only. Which means that Windows 10 did not support booting from a GPT partition and there was no room to add a third hard drive with an MBR boot partition.

    Following some instructions I found online (see below), I moved the Windows bootloader to a USB flash drive that has an MBR partition. This has worked flawlessly in allowing Windows 10 to boot properly and still be housed on a GPT partition even though this is a BIOS system.

    Recently, however, I have been trying to do the update to version 1903, since the current version (1803) goes unsupported as of November 12th. Every time, whether through automatic updates or through the manual installer, the update appears to download and install. But then when it goes to reboot, there is no indication that it is actually doing any work, and when it reboots, it is still on 1803. The attempted update does not show in the update history, nor are there any errors in Event Viewer related to the update attempt. It's as if it just never happen.

    Here are the instructions I referenced:
    Booting Windows 7 / 10 from GPT Disk on BIOS (non-UEFI) systems | Windows OS Hub

    I know that there was a known issue updating to 1903 on systems that have a USB flash drive or SD card attached, and that Microsoft had put a safeguard hold on updating those systems earlier this year. However, according to Microsoft, that issue was resolved as of July 11th and the safeguard hold was removed. So I am assuming that is not the issue in play here.

    Does anyone have any idea what's going on? Could this be some problem due to the unique setup with the bootloader? Or do you think it is some other issue? How can I begin troubleshooting this?

    Thanks.
      My Computer


  2. Posts : 8,701
    Mac OS Catalina
       #2

    Some systems are still not and may never be 1903 ready. When 1909 or 2001 come out, maybe the drivers will be ready or these systems will be stuck at 1809 forever.

    Also trying to recreate the wheel like you did just causes major headaches.
    Last edited by bro67; 31 Oct 2019 at 11:18.
      My Computer


  3. Posts : 17,372
    Windows 11 Pro
       #3

    When there is a major version upgrade, Windows will attempt to update the System Partition. The fact that your System Partition resides on a removable USB flash drive is likely preventing the upgrade from updating the System Partition which is expected to be on an internal fixed disk. That would cause the upgrade to fail.

    It might be better to put a small SSD in a USB enclosure and boot from that. That drive should show up as a fixed drive in Windows and allow the upgrade to update the system partition. Also you could use the remaining free space on the SSD for extra storage. You could also save the ISO file for the Windows upgrade on the SSD as a backup installation source.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 23:03.
Find Us




Windows 10 Forums