Recently my laptop would not boot up. There are actually 2 Win 10 Pro 64 partitiions, "production" and "test and scratch," which I select either using the boot menu. I set up the multi-boot using EasyBCD.

When my system would not boot up, MiniTool was saying that there were empty partition where the system reserved partition and both Windows partitions. I always keep all my data in a separate D: drive. I was getting nowhere fast trying to use a backup software tool to restore the system reserve and Windows partitions, but I really needed to get some of that data off the system.

So I use Minitool to reduce the size of the data partition by 30 GB and installed 1903, using the MCT to create an install image. I did the install with the "I don't have a serial number" option and it all worked. Suddenly both "lost" Windows partitions appeared to be intact and with drive letters assigned.

Don't ask me how this all happened, because I can't explain it. So I installed EasyBCD into the new Windows install, set up my real production partition as default, and it all worked! Again, I can't explain it, but I'm not complaining. And I didn't need to run diskpart, which is very powerful but I'm always worried that I might destroy important data.

x509