Bootrec /fixboot → "Element not found"

Page 3 of 3 FirstFirst 123

  1. Posts : 35
    Windows 10
    Thread Starter
       #21

    Hey @topgundcp, thanks for the detailed instructions. I had to assign S: to the System Reserved partition because R: is used by my CD/DVD-ROM drive. When I rebooted after everything was done, Windows gave me a "Windows failed to start" BSOD with the error code 0xc000000f.
      My Computer


  2. Posts : 2,790
    Linux Mint 20.1 Win10Prox64
       #22

    When you run fix windows boot problems. Did you select the system reserved partition (letter S:) only ? and did you access the BIOS and set the BOOT PRIORITY and the BOOT ORDER to be the new SSD disk ?

    Normally, the boot disk should be connected to the first Sata port and shown as disk 0. I suggest that you disconnect all other disks. Only leave the new SSD connected. Re-run fix boot problems, you should get a screen same as shown in post #20.
      My Computer


  3. Posts : 35
    Windows 10
    Thread Starter
       #23

    I made sure my HDD and old SDD were disconnected and booted into the Reflect rescue DVD. Only one drive was found to have a Windows installation on it. I made sure to only check "System Recovery" and had Reflect fix Windows boot problems.

    The one thing I hadn't noticed before: the last step, "Creating BCD store", resulted in a red X. This explains why booting into the new SSD creates a Windows boot error 0xc000000f applying to the file "\Boot\BCD".

    Can you help me with this Reflect problem or should I take this to the Macrium Reflect forum?
      My Computer


  4. Posts : 2,790
    Linux Mint 20.1 Win10Prox64
       #24

    Let us try to fix boot disk manually.
    IMPORTANT: Make sure you only have the new SSD connected. Disconnect all other disks.
    Boot up Macrium Rescue disk
    On the bottom left, click on the command prompt icon.

    Type:
    diskpart
    select disk 0
    list par ===> this will list 2 partitions where partition 1 = 579MB
    select par 1
    format quick fs=ntfs Label="System Reserved"
    active
    assign letter=S
    select par 2
    assign letter=H
    exit

    next type:
    bcdboot H:\windows /s S: /f BIOS
    The result should create the new BCD successfully.
    reboot
      My Computer


  5. Posts : 35
    Windows 10
    Thread Starter
       #25

    My version of bcdboot didn't support the /f switch. Since MS says that bcdboot will use BIOS by default on a BIOS system, I simply omitted the switch. Unfortunately:
    Bootrec /fixboot → "Element not found"-img_20191018_201149-cropped-.jpg
    I checked the bootmgr file in case you wanted some advance info:
    Bootrec /fixboot → "Element not found"-img_20191018_201812-shrunk-.jpg
    What's the next step? Thanks.
      My Computer


  6. Posts : 17,252
    Windows 11 Pro
       #26

    I would say back up your Windows partition. Wipe the entire drive, do a clean install, then restore the old Windows over the top of the newly installed Windows partition.
      My Computer


  7. Posts : 35
    Windows 10
    Thread Starter
       #27

    Damn, I'm so close.

    1. Using diskpart, I wiped the new SSD with its clean command.
    2. I powered down, disconnected all drives except the new SSD, and booted using the Windows 10 install media I created from a fresh Microsoft download.
    3. I installed Windows 10 on the new SSD. It created the small boot and larger OS partitions.
    4. I powered down, reconnected the drives, and rebooted.
    5. Using Reflect, I deleted the large OS partition on the new SSD, dragged the image backup of my old SSD's C: partition, and expanded it to maximum size. Reflect restored the image backup onto the new SSD.
    6. I powered down, disconnected the old SSD (leaving my D: data HDD connected), and rebooted.
    7. I got the Windows logo + spinner for a while, then a black screen. The monitor remained on. I waited a few minutes but still no successful boot.
    8. I tried disconnecting the HDD and booting with the Reflect rescue CD and "Fix Windows boot problems"; as before, it failed on the last step, "Creating BCD store".

    What can I do to debug the black-screen step?
    Last edited by Blaq; 23 Oct 2019 at 18:59.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 07:15.
Find Us




Windows 10 Forums