Update failed (0x80070003) from 1809 to 1903

Page 1 of 2 12 LastLast

  1. Posts : 4
    Windows 10
       #1

    Update failed (0x80070003) from 1809 to 1903


    Hi,
    I've a problem to update Windows 10 from 1809 to 1903 with error code 0x80070003.
    I've tried :
    - To uninstall my AV (Bitdefender)
    - To rename the Software Distribution and Catroot2 folder
    - Windows Update
    - Windows Update Tool (In-place Upgrade and Iso)
    Each time the same error...
    I've retrieved the setuperr.log and setupact.log files from the $Windows.~BT\Sources\Panther and also ran SetupDiag.exe.
    I've uploaded the files to my Google Drive.
    In setuperr.log, I see :
    Code:
    Operation failed: Mount WIM file C:\$WINDOWS.~BT\Sources\SafeOS\winre.wim, index 1 to C:\$WINDOWS.~BT\Sources\SafeOS\SafeOS.Mount. Error: 0x80070003[gle=0x000000b7]
    Does anyone know how to fix this error (without a clean install)?

    Thanks in advance!
      My ComputerSystem Spec

  2. dalchina's Avatar
    Posts : 19,871
    Win 10 Pro (1903)
       #2

    Hi, recommend
    a. As a matter of routine, run
    chkdsk c: /scan
    from an admin command or powershell prompt and check the report is ok

    b. Perform a manual ugrade- don't use WU.
    - Download the 1903 iso, rt click and mount it, run setup.exe

    You can choose not to accept updates as part of the procedure to simplify things

    - or do you mean you've already tried this? please confirm.
    Windows Update Tool (In-place Upgrade and Iso)
    Update 1809, failed update. Error code: (0x80070003) : Windows10
    .

    Note: before making major changes to your system, make sure you have a current disk image of Windows e.g. Macrium Reflect (free) which is recommended so frequently here. Then if something goes wrong, you have a fallback option.

    Noted this early on in your setuperr.log which I've seen before:
    Failed to add user mode driver [%SystemRoot%\system32\DRIVERS\UMDF\uicciso.dll]

    Failure to mount wim:
    E.g.
    https://social.technet.microsoft.com...in10itprosetup

    Perhaps some other security product or a leftover of Bitdefender. You might try using a cleanup tool if BD offers one.
    Last edited by dalchina; 12 Jun 2019 at 05:46.
      My ComputersSystem Spec


  3. Posts : 4
    Windows 10
    Thread Starter
       #3

    Hi,
    Thanks for the answer.

    dalchina said: View Post
    Hi, recommend
    a. As a matter of routine, run
    chkdsk c: /scan
    from an admin command or powershell prompt and check the report is ok
    I've done :

    sfc /scannow
    dism /online /cleanup-image /restorehealth
    chkdsk /scan

    from an admin command and everything is fine.

    I've also tried the manual upgrade and I get the same error.

    I just used "Bitdefender_2019_Uninstall_Tool.exe" and I'm going to try another manual upgrade.
    Will report back.
    Thanks for the help.

    - - - Updated - - -

    Still the same error.

    Is it possible that the driver problem is causing the mount problem ?
      My ComputerSystem Spec

  4. dalchina's Avatar
    Posts : 19,871
    Win 10 Pro (1903)
       #4

    Hi, the link I quoted above - albeit an older one- gave an example of a fixed case:

    Thanks RTFM and Karen for very good answers. In the mean time I solved the above mounting permission problem. Turned out indeed to be third party security product. I did remember to disable non Microsoft services first but somehow I guess some kernel component of the Checkpoint Endpoint protection software was blocking the mount. Uninstalled Checkpoint and winre.wim could be mounted ok manually. Therefore also the install script could continue ok and mount it at safeOS\SafeOS.Mount ok.
    - but you've now run the BD cleanup tool.

    So I guess time to look for other possible conflicting software. Do you have any other security software?
    You could try a clean boot, then try upgrading.

    Also see this solved case:
    Need help with setuperr.log on failed upgrades to Build 10586
      My ComputersSystem Spec


  5. Posts : 4
    Windows 10
    Thread Starter
       #5

    Thanks, I'll look at the link you wrote tonight after work.
    Do you think it's worth to try to update by booting from the iso (on a USB drive)?
      My ComputerSystem Spec

  6. dalchina's Avatar
    Posts : 19,871
    Win 10 Pro (1903)
       #6

    Booting from a bootable installation medium offers you two basic options:
    a. Repair your computer (command prompt, system restore etc etc )
    b. A clean install (= delete all partitions created when Windows was installed).

    You cannot 'update' that way, only from being logged in normally.
      My ComputersSystem Spec


  7. Caledon Ken's Avatar
    Posts : 15,670
    Windows 10 Pro x64 Build 1809
       #7

    If you thing this is drivers please navigate to Windows.~BT\Sources\Panther

    do you see files with the name CompatData_XXXXXX.XXXX.xml

    where xxx.xxxx is a date time.

    Find the latest xml file and open it in Edge.

    Look down the column with the words "BlockMigration="

    Are any drivers marked as True? If so they are blocking your migration.

    I use Rapr to then determine what these drivers are from the OEMyy.inf name.

    Release DriverStore Explorer v0.9.10 . lostindark/DriverStoreExplorer . GitHub

    When you start Rapr right click on the column titles and place a check mark by OEM.inf to view oem.inf column in the display.
      My ComputerSystem Spec


  8. Posts : 4
    Windows 10
    Thread Starter
       #8

    dalchina said: View Post
    I tried to clear de wimp image with DISM but still got the same error afterwards...
    I had a day off today, so I did a clean install. Everything is fine now.
    I don't know what the problem was.
    Thanks to all for the help.
      My ComputerSystem Spec

  9. Caledon Ken's Avatar
    Posts : 15,670
    Windows 10 Pro x64 Build 1809
       #9

    Glad it is fixed.
      My ComputerSystem Spec


  10. Posts : 320
    Windows 10
       #10

    I was getting a backlog of failed updates from June 27th to yesterday. Since nothing else worked, I ran a re-install of Windows-10 (keeping existing files) and now the updates are installing fine. No more 80070003 error when booting up after the restart.
      My ComputerSystem Spec


 
Page 1 of 2 12 LastLast

Related Threads
Need Suggestions for a failed 1809 update in Windows Updates and Activation
I have an old Dell laptop running 1803 fine. It decided to do the 1809 update today. It did it's thing for quite some time (downloading and such). It displayed some results of checking and indicated everything was OK. When it rebooted, I think...
Hi, Running Windows 10 Pro 64Bit version 1809. I tried to update today to new 1903 version, but it BSOD(Blue Screen Of Death) during the install? I tried both Windows Update and the standalone Windows Update Tool with same result. Any ideas?...
Being in the slow ring, 1903 turned up on checking via Windows Update. I fresh installed 1809 a few months ago, don't particularly want to do that again with all the settings and software to sort. Have now installed 1903 at least 6 times, allegedly!...
Received this message in the update history. The full message was: Feature update to Windows 10, version 1809 amd64 2019-04 Failed to install on ‎4/‎15/‎2019 - 0x80240034 I can't tell what update failed to install. Any thoughts would be...
I've tried many times over the course of two weeks and I keep getting the same errors. From the research that I have done, it seems that it may be video driver related. I updated to the latest Nvidia drivers and it didn't work....
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 15:44.
Find Us