DISKPART VIRTUAL DISK ERROR...."The object is not found."


  1. Posts : 3
    Windows 10
       #1

    DISKPART VIRTUAL DISK ERROR...."The object is not found."


    Hello all,

    My apologies up front for a long post, and most likely some information that you don't need. But I want to be thorough and make sure I include everything that might be pertinent.

    I built a desktop back in October of 2018, and it's worked great up until a couple days ago.

    CPU: Intel Core i7-8700K
    Motherboard: Z370-EGAMING LGA1151
    Video: ASUS GeForce GTX 1060 6GB
    HDD: 970 EVO Plus
    OS: Windows 10 Pro

    I have a total of 4 monitors hooked up. ASUS sent out an update for my graphics card on 5/9/19, and that's when the problems started. After I downloaded and installed the graphics update, I was playing Witcher 3 and everything went haywire. The graphics system became very unstable, the game crashed (which isn't all that rare), and I could only use 1 monitor for whatever reason. I re-installed the video card drivers, and that fixed the problem temporarily.

    Everything seemed to be working fine....played the game again, and voila, same thing happened....graphics became unstable, and I could only use 1 monitor. So I reinstalled the video card drivers again, to no avail. Down to 1 monitor.

    Long story short, I decided the best course of action was to just reinstall everything, including Windows 10. In hindsight, I should have posted here first.

    So when I attempt to load Windows from the bootable USB stick, I get to the point where it asks:

    "Where do you want to install Windows?"

    Drive 0 Unallocated Space - Total size 232.9GB - Free Space 232.9 GB

    When I attempt to select this drive, at the bottom it says, "Windows can't be installed on this drive". When I click on that message it says, "Windows cannot be installed to this disk. This computer's hardware may not support booting to this disk. Ensure that the disk's controller is enabled in the computer's BIOS menu."

    So I did some research, and found DISKPART.

    Here's where I'm at now:

    Disk ### Status Size Free Dyn Gpt
    ------------ --------------------------- ----------- ---------- ----- ------
    Disk 0 Online 232 GB 232 GB
    Disk 1 Online 14GB 857 MB

    (Disk 1 is the Windows USB Stick)

    I've cleaned the Disk 0, and that command works fine.


    When I attempt to CREATE PARTITION PRIMARY, I get this message:

    DISKPART> CREATE PARTITION PRIMARY

    Virtual Disk Service error:
    The object is not found.


    Unfortunately, among all the research I've done, and youtube videos I've watched, there's not one that addresses this specific issue.

    When I run the DETAIL command, I get:

    DISKPART> DETAIL DISK

    Samsung SSD 970 EVO Plus 250GB
    Disk ID: 00000000
    Type : NVMe
    Status : Online
    Path : 0
    Target : 0
    LUN ID : 0
    Location Path : PCIROOT(0)#PCI(1D00)#PCI(0000)#NVME(P00T00L00)
    Current Read-only State: No
    Read-only: No
    Boot Disk: No
    Pagefile Disk: No
    Hibernation File Disk: No
    Crashdump Disk: No
    Clustered Disk: No

    There are no volumes.

    You guys have any ideas?

    Thanks in advance for any help.
      My Computer

  2. Caledon Ken's Avatar
    Posts : 24,469
    Windows 10 Pro x64 Version 2004
       #2

    Hi sameltopia. Welcome to the TenForums @sameltopia

    Enter your BIOS and disable secure boot and fastboot. Then with only 970 connected

    Boot the computer from Windows 10 installation USB flash drive or DVD. When the first screen comes up press shift + F10. In the command window that opens run the following commands. This will erase the entire hard drive!

    diskpart
    List disk
    select disk 0 (ensure zero is where you want to install)
    clean
    Convert gpt (if required for UEFI)
    exit
    exit

    Proceed with installation. When you get to screen where it says where do you want to install windows you should have only one drive, all unallocated..... click "Next" Ignore message as long as "Next" is enabled.


    Once Windows installed you can enable secure boot and bios Fastboot. (Fast boot might be called something different is your BIOS).

    Clean Install Windows 10


    Ken
      My Computer

  3. hsehestedt's Avatar
    Posts : 2,212
    Windows 10 Pro, 20H2
       #3

    Could you tell me how the USB stick was created? I want to be sure it's not a disk that was customized for unattended install for a BIOS only system as an example.
    Also, could you try something and let me know what happens? I'm making the assumption that your BIOS is configured to UEFI mode. With that assumption, go into diskpart, select disk 0, and run "convert gpt". Exit diskpart.

    Try again to install Windows from the USB stick.

    Let me know what happens.
      My Computers


  4. Posts : 3
    Windows 10
    Thread Starter
       #4

    Thank you for the warm welcome Ken.

    I followed your directions as stated.

    When I get to the 'Convert gpt' step, I get an error message:

    Virtual Disk Service error:
    The object is not found.

    - - - Updated - - -

    hsehestedt,

    Thanks for your reply.

    See comments above.

    The BIOS is indeed configured in UEFI mode.

    The USB stick is the actual stick I received from Microsoft. I've got the stick and the product key.

    The problem is that I can't get past this Virtual Disk Service error: The object is not found.
      My Computer

  5. Caledon Ken's Avatar
    Posts : 24,469
    Windows 10 Pro x64 Version 2004
       #5

    How old is this device?

    You said you had errors, reload, worked, more errors.

    This article talks about the possibility of a failing drive.

    Quick Fix: Virtual Disk Service Error The Object Is Not Found
      My Computer


  6. Posts : 3
    Windows 10
    Thread Starter
       #6

    It was brand new when I bought it in October 2018. It was working great until 2 days ago. The initial problem was with the video card, not the hard drive.

    My gut says it wasn't the drive, not at least initially. I may have screwed it up somehow in the meantime.
      My Computer

  7. Caledon Ken's Avatar
    Posts : 24,469
    Windows 10 Pro x64 Version 2004
       #7

    Okay.

    I hope yo have another computer.

    If you create this recovery disk

    Windows 10 Recovery Tools - Bootable Rescue Disk

    It has a couple of Partitioning tools. That link mentions and walks you through creating a Partition with AOMEI. This tool is on desktop of recovery disk.

    There is also Minitool Partition Wizard.

    See if either of these tools sees a partition or allows you to create. I very much doubt you did something. Stuff fails.

    Something I haven't tested. Carefully consider before considering. With the recovery disk giving you an OS could you run Samsung Magician to secure erase the device?
      My Computer


  8. Posts : 1
    windows 7/10
       #8

    I believe the problem using Diskpart for partitioning, as in my case was that once I converted the disk to GPT then I gotthe same error message as the title thread and could only use the Create Volume command to create partitions on a GPT converted drive/disk and so to convince myself I clean ed the disk/drive and converted the drive/disk back to MBR . Then I could use the diskpart Create Partition command but not the create Volume command to create partition s and this is where a few of the online tutorials may not point this out, suggesting if you convert to GPT then go on to use the create partition command to showing examples and similarly with convert ing to MBR and not able to use create volume command.
    Hope that helps but as others suggested there are a few free or limited partition manager softwares for doing partitioning and the resizing of .I had a specific reason for wanting to try using diskpart when Win10 wouldnt install after using a free partition manager then I discovered other quicker partition managers but just went back to win7 as it still didnt install for ME using MBR partitioning .
      My Computer

  9. Matthew Wai's Avatar
    Posts : 5,425
    Windows 10 Home 20H2
       #9

    I have never used a third-party software to partition a disk before installing Windows 10 on it.
      My Computer


 

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 12:02.
Find Us




Windows 10 Forums