Can't Upgrade, Error 0x8007001F - 0x2006 and more, Stuck on 1709


  1. Posts : 4
    Windows 10 1709
       #1

    Can't Upgrade, Error 0x8007001F - 0x2006 and more, Stuck on 1709


    Hello, for the past year my brother's computer has been stuck on Windows 10 Ver. 1709 (Build 16299.371) and I haven't paid much attention to the issue until recently this month.

    I've been trying to upgrade to 1803/1809 but been unable to due to Windows Update failing with this issue:
    "A current driver on your PC may be better than the driver we're trying to install. We'll keep trying to install."

    Can't Upgrade, Error 0x8007001F - 0x2006 and more, Stuck on 1709-update-errors-1.png

    The problem is that all my drivers are up-to-date and the update that's trying to install:
    "Feature Update to Windows 10, version 1803 x64 05-05B"

    Always fail, with the installed attempts error in my update history being error 0x80240034 as shown below.

    Can't Upgrade, Error 0x8007001F - 0x2006 and more, Stuck on 1709-update-errors-2.png

    Windows Update isn't completely broken though as it installs other updates like definition updates to windows defender fine. Though only this one feature/cumulative update fails and I'm out of options on what to do.

    I tried about everything I can to fix this issue ranging from uninstalling some of my drivers (audio, wifi, bluetooth) and updating them through Windows Update, downloading windows 10 official update assistance and media creation tool both failing. The main error being from the media creation tool (both upgrade and through iso) being error 0x8007001F - 0x2006 as shown below:

    Can't Upgrade, Error 0x8007001F - 0x2006 and more, Stuck on 1709-unable-upgrade-through-media-creation.png

    I tried sfc /scannow multiple times with no error/corruption found, DISM Online CleanupImage RestoreHealth which also completed 100% with no error/corruption found, and even chkdsk (at boot) which found nothing wrong with my drive.

    I tried even using the WUMT (Windows Update MiniTool) to see if I can download and update the broken update but it also didn't work, giving me a failure to download: 0x80240022 error. Looking in the logs showed that when attempting to download the update, it kept on giving "404" errors.

    Indeed I'm at a loss on what to do which is why I'm on here to ask for help.

    Also lastly, I don't know why but the "Turn Windows features on or off" appears blank:

    Can't Upgrade, Error 0x8007001F - 0x2006 and more, Stuck on 1709-turn-windows-features-off-blank.png

    I already went into services and turned "Windows Module Installer" to automatic and start it up
    but the features window still appeared blank after starting it. That and it reverts to manual after
    every restart (though I read online that's normal and probably resets itself to manual by TiWorker? I personally don't know.)

    The computer I'm using is an ASUS Desktop M11BB Computer that my brother brought online
    back in 2017 which came with Windows 10 Pre-installed. I've updated my profile with the specs of
    the computer in case you need to know whats in it. (I don't know all the specs but I believe the more important specs are enough).

    I'm going to do everything to help upgrade windows to the newest version...hopefully.
      My Computer

  2. Caledon Ken's Avatar
    Posts : 20,170
    Windows 10 Pro x64 Version 1909
       #2

    Hi JakeWell. Welcome to the TenForums @JakeWell

    This article has some information that maybe of use to you. You will notice a SetupDiag executable that could also shed some light.

    There are some quick fixes that can apply. Things like disconnect all gear not required for boot, remove (not disable) third party AV's, they have a full list.

    https://docs.microsoft.com/en-gb/win...dy_UpgradeTips

    I see you have bootable media created with MCT tool. I would use this with machine disconnected from network and if ask about updates skip.


    While this is not a fix and may appear to be more work, have you considered a clean install. Might actually be the fastest way with the best base to move forward. I would recommend creating a system image before doing so or installing to a new storage device. Both give you a route back to where you are now. (Create and test boot media for any tool selected). When shutting down windows if you were to switch disks please hold shift key down and click shutdown for a complete shutdown.

    Backup and Restore with Macrium Reflect


    Ken
      My Computer


  3. Posts : 4
    Windows 10 1709
    Thread Starter
       #3

    Kind thanks Caledon Ken, I'll be sure to check it out! Actually I tried setupdiag before a few days ago, i'll give it a go again and post what error I saw in it as it's interesting...

    Hmm..ah I already tried installing through MCT with everything disconnected (speakers, wireless mouse, cordless keyboard) but it still gave me the error despite doing that....though I haven't disconnected the monitor though, I could try it again without it connected but I don't know if it'll work. I'll try it later!

    Also thanks for the suggestion to try an clean install, while it's an choice that could work out everything in the end...
    I personally prefer on solving the issue that's plaguing my poor bro's pc then to take it all out with a fresh install.
    However I'll consider it if everything doesn't work as a last resort...or maybe not, I don't know until that point comes.

    Anyways I'll try the link you gave and give it all a try (doing setupdiag again too), see ya for now!
      My Computer


  4. Posts : 4
    Windows 10 1709
    Thread Starter
       #4

    I'm back from doing all that research from that link you gave me Ken, thank you again for it.

    I read and did everything that was in the link and been researching all the logs I have on my computer, checking each error and linking them to one common problem.

    I'm still not sure but I think I have an idea what the main problem is and it has to do with the component store, mainly one or more packages not being valid/corrupted.

    That and when I ran the following command in CMD:
    Dism /online /Get-Features

    This is the result:
    "The specified package is not valid Windows package. Error: 800f0805"

    Can't Upgrade, Error 0x8007001F - 0x2006 and more, Stuck on 1709-dism-get-features-error.png

    This seems to be the issue, after reading through the CBS.log file, which had mention of a missing Foundation package, Optional Component Status not found, and that a missing matching version for the servicing stack is not found.

    It pointing to this package of the servicing stack with the error:
    C:\WINDOWS\winsxs\amd64_microsoft-windows-servicingstack_31bf3856ad364e35_10.0.16299.367_none_16d8803832210dee\

    Not being found with error code 0x80070490 - ERROR_NOT_FOUND.
    I like to upload all the logs that I read, as you guys may know more on what's wrong.
    It contains the setupact logs, cbs, dism, etc. I also included the setupdiag results log and chkdsk results too!

    I don't plan on taking any action to repair my computer just yet until I have an idea on what should be done.
    From what I know, I think I may have to repair the package by replacing it completely with a fresh new one if possible but I'm not sure if that will fix everything.

    If you need anything else, just ask me and i'll provide!
    Also, I like to note that both DISM and SFC scan did not found any errors as shown below:

    Can't Upgrade, Error 0x8007001F - 0x2006 and more, Stuck on 1709-dism-no-errors.png

    Can't Upgrade, Error 0x8007001F - 0x2006 and more, Stuck on 1709-sfc-scannow-no-issues.png

    I took this pics before discovering the error above btw.
    Thanks again for helping!
    Can't Upgrade, Error 0x8007001F - 0x2006 and more, Stuck on 1709 Attached Files
      My Computer

  5. Caledon Ken's Avatar
    Posts : 20,170
    Windows 10 Pro x64 Version 1909
       #5

    You could do a repair install which leaves everything intact, programs and data. That said I always recommend you back up data.

    You can go here and get a copy of 1709 to do the repair with.

    Microsoft Windows and Office ISO Download Tool

    Once you have the ISO you would follow the repair upgrade tutorial only you use the ISO you created above.

    Repair Install Windows 10 with an In-place Upgrade

    With the 1709 iso you could also try these dism commands using and EXTERNAL source. (The iso you created.)

    Use DISM to Repair Windows 10 Image


    While all of these may provide relief I already commented on what I though is the best plan of action for a fix and long term foundation, a clean install.
      My Computer


  6. Posts : 32,341
    windows 10 professional version 1607 build 14393.969 64 bit
       #6

    Clean install is the best option if files are backed up.
    Next best is reset save files or reset save files equivalent.


    For the error code: 800
    Code:
    Result codes starting with the digits 0x800 are also important to understand. These error codes indicate general operating system errors, and are not unique to the Windows upgrade process. Examples include timeouts, devices not functioning, and a process stopping unexpectedly.
    See the following general troubleshooting procedures associated with a result code of 0x800xxxxx:
    https://docs.microsoft.com/en-us/win...res#0x800xxxxx

    These have the same result but different extend codes:


    Code
    8007001F - 0x3000D

    Cause
    The installation failed in the FIRST_BOOT phase with an error during MIGRATE_DATA operation.

    Mitigation
    Analyze log files in order to determine the files or registry entries that are blocking data migration. This error can be due to a problem with user profiles. It can occur due to corrupt registry entries under HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\ProfileList or invalid files in the \Users directory. Note: If a previous upgrade did not complete, invalid profiles might exist in the Windows.old\Users directory. To repair this error, ensure that deleted accounts are not still present in the Windows registry and that files under the \Users directory are valid. Delete the invalid files or user profiles that are causing this error. The specific files and profiles that are causing the error will be recorded in the Windows setup log files.
    Code
    8007001F - 0x4000D

    Cause
    General failure, a device attached to the system is not functioning.

    Mitigation
    Analyze log files in order to determine the device that is not functioning properly. Disconnect, update, or replace the device.
      My Computer



  7. Posts : 4
    Windows 10 1709
    Thread Starter
       #7

    Hehehe...so it's been sometime but i'm here to happily report that...
    I fixed it, yup I FIXED WINDOWS UPDATE WITHOUT DOING A CLEAN INSTALL/IN-PLACE UPGRADE!
    Can't Upgrade, Error 0x8007001F - 0x2006 and more, Stuck on 1709-classic-jannanigans.jpg

    WABAM! Window Update working again, up-to-date on Ver. 1809 finally!
    Can't Upgrade, Error 0x8007001F - 0x2006 and more, Stuck on 1709-everything-finally-working...all-thanks-research-time.png

    I want to thank you ken for that link you first posted above for without it I wouldn't
    have took the time to discover the problem after a lot of research!

    So I found out why Windows Update was not working and I'll explain how I fixed it!

    During my research after discovering the "get-packages" issue not working, I had a curious thought it
    my mind that something was wrong in the registry as I searched online. This curiosity grew as I read both DISM.log/CBS.log files, live with notepad++ and it's "tail" function.

    Looking at many threads online, I learned about the "Component Based Servicing" registry tree and took a look at it, thus leading to finding out this was the main problem of it all...
    Can't Upgrade, Error 0x8007001F - 0x2006 and more, Stuck on 1709-main-problem-missing-registry-cbs.png

    Many of the subkeys in the "Component Based Servicing" tree were both empty or completely missing (e.g PackageIndex, CapabilityIndex, Features on Demand, etc).

    The following keys below were completely empty:
    • DriverOperations*
    • Packages
    • Version

    *Note: In the image, I already fixed the key which in-turn fixed the "A Current Driver may be better" problem. Fixing it caused WU to not report it but the error 0x800f0805 instead.

    These keys were the reason I was unable to update, due to WU being unable to find important packages to loadup. I'll explain how I fixed all of these keys, first by explaining what repairing each key caused.

    First off, repairing the "version" key caused the error message that CBS in dism.log throws:
    missing matching version for the servicing stack not found
    missing matching version for the servicing stack
    to stop, now reporting that they successfully loaded the correct servicing pack version.

    Second, repairing the DriverOperations key fixed the "Current Driver may be better" problem, as I said in the note above. Honestly I felt good when I found a connection to fixing the problem with that!

    Now for the next two important keys, one that's missing and one that's empty...
    I learned from reading a thread online that two important subkeys are required for WU to function (otherwise a repair install, system restore, etc is need) and they are "Packages" and "PackageIndex".

    Both sub-keys are one of the major causes of WU not working for me, the dism command "get-packages" telling me that "no packages" were found being one of the reasons I looked up and discovered the registry tree for CBS!

    It was not easy trying to find a way to repair this, but I had to download an iso with the same version as my Win10 Build 16299.371 that the updates installed (or slightly higher, like say 16299.402), mount the wim file with dism /mountwim command, load the SOFTWARE Hive within "X:\(MountDir)\Windows\System32\Config" and export the "Packages" and "PackageIndex" subkey (plus I exported the DriverOperations and Version Subkey from it, modifying them to import into my own registry with further modifications to match my version).

    After importing both Packages and PackageIndex, I took the time to sort through almost every package key within them to remove any packages that weren't on my computer. (Probably didn't have to since I was upgrading but still).

    I used the program "Everything" by VoidTools to search what packages were on my computer. (Basically by copying the package key name, then putting it into everything to see if it's installed or not.

    It's better to show an example of what I mean then explain it:
    Can't Upgrade, Error 0x8007001F - 0x2006 and more, Stuck on 1709-tedious-but-probably-important-removal-updates...not-installed-my-computer.png

    Tedious as it was, It took no longer then two or so hours to sort through each key but
    I believe it was worth it.

    Since after I finished deleting those non-existence package keys, I then imported "CapabilityIndex"
    and "Features on Demand" subkeys, then I restarted my computer and tried updating again and BAM
    it started to download and install!
    Can't Upgrade, Error 0x8007001F - 0x2006 and more, Stuck on 1709-its-working-wu-upgrading-finally-.png

    Everything downloaded, installed and my computer upgraded without a problem!
    I never felt so happy that my research lead me to fixing this hopeless computer...not so hopeless now.

    Anyways I want to thank y'all for helping, you guys suggestions were last resort suggestions but I stubbornly didn't want to clean-install this computer and well...I'm happy.

    I took the time, energy, and patience to fix WU and upgrade. See y'all around, hopefully this may be helpful to those out there that may be experiencing this problem too...if you're experienced enough that is otherwise don't be afraid to ask for help!
      My Computer

  8. Caledon Ken's Avatar
    Posts : 20,170
    Windows 10 Pro x64 Version 1909
       #8

    Wow.... Herculean effort. Well done.
      My Computer

  9. eLPuSHeR's Avatar
    Posts : 2,178
    Windows 10 Home x64
       #9

    Congratulations on a job very well done.
      My Computer


 

Related Threads
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 13:16.
Find Us




Windows 10 Forums