Bluescreen during Windows 10 installation

  1.    #1

    Bluescreen during Windows 10 installation

    Hello all,

    I am new here but I hope I can still get some help

    First I'd like to say I'm very experienced when it comes to hardware, and I work with enterprise hardware and Windows server, yet I am at a loss here.

    First my setup:
    Intel i7 7700K
    Gigabyte Z270X Gaming 9
    2x AMD R9 290 (reference cards with fullcover waterblocks)
    2x Samsung M.2 OEM drives pulled from new Lenovo laptop (RAID 0)

    So, my problem is that whenever I get to where I need to select the drive I want to install Windows to they don't show up. I load the RAID driver but during this loading I get the bluescreen WHEA_UNCORRECTABLE_ERROR and I cannot for the life of me figure out why.

    This is an upgrade from two ADATA SATA SSD's in RAID 0 that was running legacy RAID BIOS to UEFI M.2 RAID 0.

    First I found out that my GPU's do not support UEFI. Something about a GOP driver for the BIOS. I have updated both GPU's to a newer BIOS that supports UEFI. Before when I disabled CSM I would get no picture, now I get a picture and the BIOS can see what GPU I have.

    After this I created the RAID volume which is seen by the BIOS, and by going into "Intel RST" in the BIOS I see the volume and it says "BOOTABLE". Finally ready for Windows 10!

    First problem is that Windows 10 isn't finding the drives. I guess that is down to Windows 10 not having the proper NVMe driver. I have a USB key with the driver on. I press on load driver, I find the driver and I press next. Windows is loading the driver but as the green bar is being filled for the 22nd time it freezes completely.
    This also happens if I simply press "refresh" to refresh the drives. After a while of loading the installations freezes and after about 30 seconds the bluescreen pops up.

    System is running default, Only Windows 8/10 and CSM disabled has been set in BIOS.
    I've tried upping the voltage for VCORE, VCCIO, SA, DDR and cache to the point I'd normally be running when overclocking to this system's limit. Still no dice. Still stock speeds.

    System is fully watercooled, CPU, GPU's, RAM and VRM, all of which does not exceed 35 degrees celcius when installing Windows 10.

    I have tried two different BIOS for my motherboard. The newest is F9b which is a BETA BIOS. I've been running with that for 3 years but for the sake of it I downgraded to F7 which is latest stable. Still nothing.

    Windows 10 USB key was made with Rufus to make it UEFI bootable instead of legacy. USB key shows up as UEFI in BIOS.

    I have tried Windows 10 1511, 1709 and 1807 I believe it was, all of which are giving me exactly the same bluescreen.

    System is stable and can boot Linux no problem. System has been stable for the past 3 years with SATA RAID 0.

    Where do I go from here? If this system wouldn't be 50kg+ it would have gone out the window but I guess I'm stuck with it. Please, suggestions are very welcome!
      My ComputerSystem Spec

  2.    #2

    H, discussion on what sounds rather similar here:
    Windows 10 setup does not detect RAID 0 | Toms Hardware Forum
    - might offer an idea.. esp. towards the end.
      My ComputersSystem Spec

  3.    #3

    Thank you for your reply!

    Sadly I don't think the problem is the same. The guy was having problems seeing his RAID volume, I believe Windows would be able to see mine if I only could load the driver or refresh the drive list, only everytime I do so I get the bluescreen.

    I just thought that I should try a different USB key. I have a 2.0 key where I'm using a 3.0 key right now.

    But thank you for reading, I know it is a long post.

    Any other suggestions are welcome!
      My ComputerSystem Spec

  4.    #4

    In case anyone needs it (My problem seem very system specific but here we go anyway) I finally fixed ALL of the problems I was having.

    There were so many different things to try, but ultimately I changed from my Kingston Datatraveler G4 16GB (USB 3) USB key to an intenso 32GB USB 2 drive. This got me another bluescreen but it was progress, since what I got was MACHINE_CHECK_EXCEPTION. This seems to be a more common problem but no threads I could find on google was any helpful.

    My motherboard has two BIOS chips and I was running on the backup one, which is running version F9b, which is a BETA BIOS. I changed the BIOS to the primary one that's running F7 and BINGO, no bluescreens anymore!

    Next problem was that the driver I had for the iRST was not the correct one. I tried various I could find on the official website but none of those worked. It would write something with unable to install driver contact your vendor.
    If it didn't show that message it would endlessly load the little green bar, I stopped it after 30 minutes.

    I popped in the driver DVD (yeah I still have DVD drive), navigated to the iRST driver (located at /boot/iRST) and BINGO AGAIN! Drive showed up and the system is currently at Windows 10 desktop, no issues and insanely fast speeds from two NVMe drives in RAID 0!

    That was an incredibly long journey but it finally worked out. If you have the same issue trying different BIOS versions might help, and try all available iRST drivers before giving up!
      My ComputerSystem Spec


Related Threads
Windows 10 bluescreen problem in BSOD Crashes and Debugging
Hi Today i bought Windows 10 And installed it on my PC. When I try to connect to wifi, my PC shows bluescreen with this info: PAGE_FAULT_IN_NONPAGED_AREA What failed:netr28ux.sys
Windows 10 BlueScreen mrxsmb.sys in BSOD Crashes and Debugging
Hi i have problem on my notebook. İ5 1st gen. 8gb ddr3 ram 120gb ssd (Windows installed on ssd) 750gb hdd Today when i try to boot bluescreen appeared. Error message :
Bluescreen Crashes in Windows 10 in BSOD Crashes and Debugging
I have a Intel Core I7 7820 and a Asus x299 prime deluxe motherboard and I am getting all kinds of errors and reboots, any idea what caused them?
Solved nvlddmkm.sys Bluescreen / Windows 10 in BSOD Crashes and Debugging
Hello, sorry, i have no Bug Report yet cause i downgraded back to Win7 at the moment. The Problem i have/ had is: After upgrade Win7 -> Win10 i get after 5-10 Minutes latest a Bluescreen caused by: nvlddmkm.sys
Bluescreen on Windows 10 in BSOD Crashes and Debugging
Hello, I am experiencing BSODs for quite some time and I would appreciate your assistance. Currently I don't have many ideas about the cause and I will update the title of the post when I know more. Please find attached my log files. ...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 21:10.
Find Us