Windows 10 Upgrade Failed - Error: 0xC1900101 - 0x20017

Page 1 of 2 12 LastLast
  1. addas's Avatar
    Posts : 20
    Windows 10 Pro
       #1

    Windows 10 Upgrade Failed - Error: 0xC1900101 - 0x20017


    Hey there!
    I am trying to upgrade my Win10 18334 to 18836 using an ISO but I get this error 0xC1900101 - 0x20017 - The installation failed in the SAFE_OS phase with an error during BOOT operation
    Is there anyway to fix it? I uploaded my error log too!
    Thanks in advance!

    Regards,
    addas
      My Computer

  2. Caledon Ken's Avatar
    Posts : 24,417
    Windows 10 Pro x64 Version 2004
       #2

    Your code

    Windows 10 Upgrade Failed - Error: 0xC1900101 - 0x20017-image.png

    Try running the setupdiag exe listed on this page. Hoping it id's drivers.

    https://docs.microsoft.com/en-gb/win...dy_UpgradeTips
      My Computer

  3. addas's Avatar
    Posts : 20
    Windows 10 Pro
    Thread Starter
       #3

    It didn't detect ID of the drivers
      My Computer

  4. Caledon Ken's Avatar
    Posts : 24,417
    Windows 10 Pro x64 Version 2004
       #4

    Can you post output from tool
      My Computer

  5. addas's Avatar
    Posts : 20
    Windows 10 Pro
    Thread Starter
       #5

    Here you go!
      My Computer

  6. addas's Avatar
    Posts : 20
    Windows 10 Pro
    Thread Starter
       #6

    btw I am running Windows 10 on AMD RAID 0? Is it possible that Windows don't have RAID drivers that's why it is failing? As I had to load AMD drivers manually during clean install.
      My Computer

  7. Caledon Ken's Avatar
    Posts : 24,417
    Windows 10 Pro x64 Version 2004
       #7

    There is a log missing

    Windows 10 Upgrade Failed - Error: 0xC1900101 - 0x20017-image.png

    Setuperr


    Maybe it holds the clue.


    Did you try the list of quick fixes which include removal of third party AV.
      My Computer

  8. addas's Avatar
    Posts : 20
    Windows 10 Pro
    Thread Starter
       #8

    I finally found the culpirt, looks like my Windows Insider Build has a bug with AMD RAID Controller, I used an older Windows 10 Insider Build and used latest RAID driver and it worked!
    Source: AMD Raid Controller not working on Windows 10 I... | Community
      My Computer

  9. Caledon Ken's Avatar
    Posts : 24,417
    Windows 10 Pro x64 Version 2004
       #9

    Nice. Thanks for posting your solution and marking it solved. Will help others.
      My Computer


  10. Posts : 2
    Windows 10 Pro 1809
       #10

    addas said:
    I finally found the culpirt, looks like my Windows Insider Build has a bug with AMD RAID Controller, I used an older Windows 10 Insider Build and used latest RAID driver and it worked!
    Source: AMD Raid Controller not working on Windows 10 I... | Community
    I am having exactly the same issue with my computer, i have a MSI X399 MEG CREATION and a raid 0 volume of two Samsung 970 Pro 512GB, i have exactly the same error when trying to upgrade from 1809 to 18362.30
    What older build did you try that worked for you?
    Could you then upgrade to the latest build without issue?
    Finally, what RAID drivers did you use that worked?
    Thanks! There is no one else that had this issue (that i found) so i am hopeful! :)
    EDIT : i just upgraded the RAID driver to 9.2.0.87 (i had 9.2.0.70), it did not change anything regarding the issue.
    I also tried upgrading to build 18342.8, but it was again the same (error 0xc1900101 - 0x20017).
    I will try again with older builds...

    - - - Updated - - -

    I was able to upgrade up to build 18334 but nothing after this build works, i tried builds 18342.1, 18342.8, 18362.1, 18362.30, every time i get a "freeze" in the first reboot : the spinning dots are spinning, but no disk activity, nothing happens.
    It rolls back to the previous version when i force stop the computer, then display this error message (0xc1900101 - 0x20017).
    I disabled secure boot and i am doing another attempt, but i don't know what else to try...
    EDIT : ok so the raid system appears to not be compatible with 19h1 and 20h1 :
    https://social.technet.microsoft.com...7-30f2a4ac830f
    https://community.amd.com/thread/237808#comment-2906497
    I think i am stuck with this build until a new driver is released...
    Last edited by Blubster; 09 Apr 2019 at 04:19.
      My Computer


 
Page 1 of 2 12 LastLast

  Related Discussions
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 00:08.
Find Us




Windows 10 Forums