MBR2GPT Not Working (Disk Layout validation failed for disk 1) Solved

  1.    09 Dec 2018 #1

    MBR2GPT Not Working (Disk Layout validation failed for disk 1)

    Hi there, I keep getting this error when trying to convert my system from MBR to GPT.

    I had a system made for me (for work) and the company installed my OS in legacy mode... I have two drives, one 512gb NVME Samsung 960 EVO and one Seagate 1 TB disk drive.

    I'm booting into command prompt mode (from advanced recovery options) and running the command mbr2gpt /validate /disk:1 .

    I had one partition only and even shrunk it by 3 Gigs (unallocated) just to give the tool space (it worked for other users) however I ran into the same issue even after doing that.

    Just another note, the 1tb drive (non os) has a System Reserve Partition of 500mb

    Any suggestions?
      My ComputerSystem Spec

  2.    09 Dec 2018 #2

    Can you post a screenshot of disk management using the instructions in this tutorial, please?
    Disk Management - How to Post a Screenshot of | Tutorials

    As well as providing us with complete system specifications such as make/model # of computer or motherboard?
      My ComputerSystem Spec

  3.    09 Dec 2018 #3

    Click image for larger version. 

Name:	disk tool.PNG 
Views:	8 
Size:	181.6 KB 
ID:	216748

    It's a custom system, specs below:

    Intel 8700k
    Gigabyte Auroras Gaming 5 Z370 Motherboard
    32 GB Kinston HyperX Ram
    Samsung 960 EVO 512 nvme m.2 ssd
    1 TB SATA Drive
    Gigabyte Auroras Nvidia 1080ti
      My ComputerSystem Spec

  4.    09 Dec 2018 #4

    Your system partition is on your hard drive, not on your SSD. The company that installed your Windows 10 did not know what they were doing. If your only goal is to boot in UEFI mode, you do not need a GPT partitioned drive to do that. Your computer, however, does likely need a FAT32 partition with the proper boot files in it to boot in UEFI mode from. You can create this partition on the SSD by opening a Command Prompt (Admin) or Powershell (Admin) and running the following commands:

    select disk 1
    create partition primary size=100
    format fs=fat32 quick
    assign letter=t
    bcdboot C:\Windows /s T: /f UEFI

    In the command prompt, the sequence should look like this:

    Microsoft Windows [Version 10.0.17134.1]
    (c) 2018 Microsoft Corporation. All rights reserved.
    Microsoft DiskPart version 10.0.17134.1
    Copyright (C) Microsoft Corporation.
    On computer: Win10XPE
    DISKPART> select disk 1
    Disk 1 is now the selected disk.
    DISKPART> create partition primary size=100
    DiskPart succeeded in creating the specified partition.
    DISKPART> format fs=fat32 quick
      100 percent completed
    DiskPart successfully formatted the volume.
    DISKPART> assign letter=t
    DiskPart successfully assigned the drive letter or mount point.
    DISKPART> exit
    Leaving DiskPart...
    X:\windows\System32>bcdboot C:\Windows /s T: /f UEFI
    Boot files successfully created.
    Then when you reboot your computer, you should be able to boot from the SSD in UEFI mode. You will likely have to change the UEFI firmware settings to boot in UEFI mode, and possibly change the boot priority to boot from the SSD first. Also, the new FAT32 partition will be created right at the end of the C: drive partition, so if you want to reclaim the empty space at the end of the SSD, you will have to use a program like MiniTool Partition Wizard to move the new FAT32 partition to the end of the drive, then extend the C: drive partition to fill the empty space.
      My ComputerSystem Spec

  5.    09 Dec 2018 #5

    I was so confused, because my SSD was set as the C drive and everything was installing onto it. That makes sense. Its a new machine, so I'll just do a clean install and run through everything again tomorrow. Already created a boot usb drive.

    Thanks for the help!

    Should have just installed the OS my self...
      My ComputerSystem Spec

  6.    09 Dec 2018 #6

    When you do the clean install, remove either the data or power cable from the hard drive so the Windows installer sees only the SSD. That will ensure all the partitions get made on the SSD and not on the hard drive in error.
      My ComputerSystem Spec

  7.    09 Dec 2018 #7

    Yep already had that in mind, thanks again!
      My ComputerSystem Spec


Related Threads
Unsupported Disk Layout for UEFI firmware in Installation and Upgrade
1803 will nt install. I get an error message saying I have an unsupported disk layout for UEFI firmware. The OS is on an MBR disk. Does this mean I have to make it a GPT?
Solved Disk layout recommendation in Drivers and Hardware
Hello I have 3 512GB NVMe drives and am trying to decide the best way to setup in a new build. Should I create a 1TB D drive or put all 3 512TB drives into a RAID0 group for a single 1.5TB C drive? My other PC has a 128GB SSD C drive and a 2TB...
I have read the information on this page below and found it very interesting but it hasn't solved my problem unfortunately. https://www.tenforums.com/tutorials/3548-disk-write-protection-enable-disable-windows.html A couple of days ago a got...
Is this disk layout an issue? in Drivers and Hardware
I converted my system to two RAID 0 2 TB SSDs, so I have one C: drive using both SSDs. I created the RAID 0 array using Ctrl-I on boot. I then restored a Macrium image. After I did that, I booted up Windows 10 Pro, and I looked at Disk...
So, after about 2 weeks of experiencing Windows 10 I've decided to revert back to Windows 8.1, since I was more experienced at it. So I followed every step to downgrade the system, waited for about a few hours, then I noticed that when Windows...

Tags for this Thread

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 20:00.
Find Us