MDT: Capture and sysprepped reference image

  1. Fafaxx's Avatar
    Posts : 14
    Windows 10
       #1

    MDT: Capture and sysprepped reference image


    Hello All,

    This is my first post in this forum. However I have already followed the excellent tutorials about Windows 10 customization and used some tricks. Now I need some help.

    I use MDT 8450 to create a reference image for Windows 10 Pro 1803 with Sysprep. After installing the reference image with a MDT deploy task sequence - task most things are automated.

    I run sysprep /generalize /oobe /shutdown

    Log in in audit mode and customize the Administrator profile. After that I run sysprep again.

    sysprep /generalize /oobe /shutdown /unattend:C:\folder/copyprofile.xml

    the unattend xml file has only the copyprofile true switch in it.

    Once the system is shut down (VM) I boot into PXE and start the standard capture task of MDT. I switched off the Syspre section of the MDT task since I already ran Sysprep. The wim file is created fine.

    After that re-start the VM (not the captured wim file) and now it comes what iritates me. Windows 10 starts a bit slower and ends up at the login screen and not with the OOBE process. I see the same if I replace instal.wim of the Windows 10 ISO with the captured WIM and start the ISO in a VM it installs Windows 10, but ends up at the login screen too and not going through OOBE process.

    I would expect after I captured a WIM file, the VM would start with the OOBE process since sysprep run with shutdown option. The only thing between was I PXE booted and captured it. It seems during the capture process something has happened which might Windows think OOBE process is already done. I have to revert to last snapshot and then Windows does the OOBE process.

    Thanks

    Edy
      My Computer

  2. Fafaxx's Avatar
    Posts : 14
    Windows 10
    Thread Starter
       #2

    I resolved it, it was an issue with the unattend.xml file, but not the unattend.xml I used for copyprofile.

    In MDT the capture task also has an unattend file from the OS and this caused the trouble. I edited that unattend.xml file and deleted section 7 OOBE.

    Once the capture process was finsihed, Windows 10 started the OOBE process.
      My Computer


 

Related Threads
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 16:57.
Find Us




Windows 10 Forums