Windows 10: UEFI install boot fail @ Asian-market gigabyte motherboard...

  1.    03 Jul 2018 #1

    UEFI install boot fail @ Asian-market gigabyte motherboard...


    Hey guys! I have an issue that's relatively specific, but maybe someone has experience with this topic.

    My friend moved to China and bought a used PC from a (not so tech-savvy) person. It came preinstalled with Win7, and he decided to do a clean install of Win10 on it. It's a Skylake CPU on a B350 chipset Gigabyte motherboard, so naturally, the board natively supports UEFI booting, evem tho the Win7 was installed in Legacy mode (I'm not entirely certain whether or not you can install Win7 in UEFI mode anyways, but that's not what matters now)

    So, he created a bootable Win10 USB install using the Media Creation Tool, changed the BIOS settings to accomodate the new OS (things like boot priorities, fastboot, and UEFI-only booting - just in case) and - it won't boot from the USB. Now, having practical experience with this kind of issue, I figured a motherboard BIOS update usually does the trick (especially for Gigabyte boards, even though they still have "windows 8/10" support written in them somewhere, so they aren't older than the OS, which always confused me). But, just to be safe, he checked the USB boot drive on his roommate's laptop first, and it booted just fine.

    So, now comes the tricky part. His motherboard is a Gigabyte GA-B150M-D2VX-SI, which I think is an Asian market variant of the GA-B150M-D2V. The issue is, it seems as if Gigabyte doesn't even have a listing for the board. I instructed my friend to try and find (if not the update itself, then atleast) the motherboard listing somewhere official on the internet, since I figured I might have that part of the internet blocked, knowing that he's in China, and I'm in Serbia, but that didn't reap anything. We also tried tampering with the settings in the motherboard, figuring maybe the BIOS updates just do the set-up part which we could have done by hand, but no luck. We even tried to make the USB boot in Legacy mode, but it wouldn't even present us with that option, we could only choose how the internal hard drive could boot (we checked to plug the USB drive both into the 2.0 and 3.0 port), it would just boot the win7 drive. We even disabled other boot options, but it would just boot into the bios settings automatically. It's rather nerve-wracking and I already had major issues when it comes to Gigabyte motherboards (I once almost bricked my friend's PC for forcefully trying to update his motherboard with the wrong BIOS, even though the model number and revision number matched up - but we realized just later that the board that he owned had a "-DDR3" suffix to it, and that board just didn't even bother showing up in our Google search results, which automatically made me assume that it was the right update package, and that the board was just a stubborn arse. Now, I check if the BIOS version and release date of the current BIOS on the motherboard and the websites match up - if I notice that the, for instance, F2 version on his baord was released in October 2015, and the F2 version on the website says it was released in December 2015, I know I'm not in the right place)


    So, my question is:

    Does anyone have experience with acquiring proper BIOS updates from (presumably) Asian-market-specific motherboards? How on earth does it even make sense not to list them anywhere officially, or at least anywhere publicly? Since the only listings I found for it were on AliExpress and such

    Is there a way for us to maybe set this board up manually ourselves for it to boot from the USB drive? Maybe the update itself isn't mandatory, but it always solved this issue for me, even for other board manufacturers

    Can we at least forcefully boot the USB drive in legacy mode in any way??


    Thank you everyone, and I hope I posted this question in the right area!!
      My ComputerSystem Spec

  2.    03 Jul 2018 #2

    Shrink C drive by about 6GB.

    Create a new fat32 partition in unallocated space and give it a drive letter

    Copy files from usb flash drive to that partition

    Run setup.exe from the sources folder on that new partition.

    Select custom install and reinstall.
      My ComputerSystem Spec

  3.    03 Jul 2018 #3

    cereberus said: View Post
    Shrink C drive by about 6GB.

    Create a new fat32 partition in unallocated space and give it a drive letter

    Copy files from usb flash drive to that partition

    Run setup.exe from the sources folder on that new partition.

    Select custom install and reinstall.
    Oh, I forgot we could start the install that way. I do have a few questions tho.

    Why the need to copy everything to a new local partition instead of just running it off the USB stick? Will it have to boot from it later on during the install?

    Will the newly installed Win10 be in Legacy mode as was the Win7?

    And will that do a clean install? Why reinstall? (I mean, they are not the same OS, so just the term "reinstalling" kind of confuses me)


    Thank you for your feedback, though! Very appreciated
      My ComputerSystem Spec

  4.    03 Jul 2018 #4

    shalabajza said: View Post
    Oh, I forgot we could start the install that way. I do have a few questions tho.

    Why the need to copy everything to a new local partition instead of just running it off the USB stick? Will it have to boot from it later on during the install?

    Will the newly installed Win10 be in Legacy mode as was the Win7?

    And will that do a clean install? Why reinstall? (I mean, they are not the same OS, so just the term "reinstalling" kind of confuses me)


    Thank you for your feedback, though! Very appreciated
    I do not think it works from a usb drive - I guess it is driver related?

    I think it must end up as legacy bios as hard drive is mbr formatted. You can later convert that to UEFI.

    I mean install w10 overwriting w7 OS partition - you could delete that if you prefer.
      My ComputerSystem Spec

  5.    03 Jul 2018 #5

    Is the USB flash drive plugged into a black USB port off the motherboard itself (back of computer)? That is where it would be most reliable.
      My ComputerSystem Spec

  6.    03 Jul 2018 #6

    cereberus said: View Post
    I do not think it works from a usb drive - I guess it is driver related?

    I think it must end up as legacy bios as hard drive is mbr formatted. You can later convert that to UEFI.

    I mean install w10 overwriting w7 OS partition - you could delete that if you prefer.
    Ohh, okay, I didn't know conversion of the drive and boot system was possible without a full wipe... Thank you very much! We'll try it out like that, and I'll post the results here.

    NavyLCDR said: View Post
    Is the USB flash drive plugged into a black USB port off the motherboard itself (back of computer)? That is where it would be most reliable.
    We tried both the black and the blue USB, with the same results, sadly, both in the front and back. :c I've been met with this very issue almost all the time with Gigabyte boards (that were manufactured before 2015), so I'm seriously starting to question what the culprit could be, since it's not just a one-time bug occurrence...
      My ComputerSystem Spec

  7.    03 Jul 2018 #7

    We just ended up using the Media Creation Tool to upgrade the old OS to Win10, and weeding out everything we could to make it "feel" like a fresh install at least.

    Although if anyone finds out why the regular USB booting without updating the BIOS didn't work (and how to fix it), or maybe even has an update for the motherboard model itself, I'd still very much appreciate it! Thanks a lot for everything, guys <3
      My ComputerSystem Spec


 

Related Threads
is there a such a thing a 4 pin grb to a 5 pin grbw adapter? I can't find any anywhere to buy any. I know the W pin isn't necessary. Thanks
Hi there, My system is facing problems with an intermittent machine_check_exception BSOD during the OS boot, after I recently replaced my motherboard and reinstalled Windows. The BSOD screen states it will restart for me, but never does. When...
Solved Gigabyte Motherboard does not save OC settings? in PC Custom Builds and Overclocking
Hi I have the GA-P35-S3L Motherboard and a Core 2 Quad Q6600. I OCed my Q6600 and set the voltage to 1.3v but when I check task manager it shows maximum speed at 2.40ghz which is the normal clock speed of the processor. I checked CPU-Z and...
I just installed windows 10 for the first time and Ive got no sound. I went to the gigabyte driver site and installed the latest driver they have. (VIA HD Audio). I have read other threads on here about lowering the Bitrate down to 16 but that does...
Just curious .. Not sure if it makes much difference , but should I pick Win 8 or other OS in my bios?

Tags for this Thread

Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

Designer Media Ltd
All times are GMT -5. The time now is 18:19.
Find Us