I'm running into a weird issue - haven't seen this before. I have a MacBook Air running High Sierra, Bootcamped into Windows 10. When I installed Windows 10, it would always get stuck at "Getting Started" screen - tried 6 times with the same result. With lot of googling, I found that disconnecting the USB Installer flash drive, and adding internet connectivity with ethernet cable, it does install fine, and it really did.

By the way getting the partition GPT ready for windows was hell of a trouble. The first time I partition the disk through bootcamp on Mac OSX and get into windows installer, it wouldn't let me pick the partitioned drive stating that its not GPT partition. It will let me delete the format but won't let me reformat either. I have to go back to OSX, remove the partition, add it again and reboot into installer, and the second time it will let me delete and choose the drive to proceed with the installation. I had to do this all the 7 times I tried to install. Please remember - everytime you remove and re add the partition through bootcamp, you lose some space allocated to a hidden partition which you won't see until you run a partition utility - found it the hard way.

Now, everytime I boot up my MaBook, it requires the lightning Ethernet adapter to be plugged into it. If it doesn't find one, keyboard doesn't work, and mouse move works but mouse click doesn't work - on the login screen. Plugging in Ethernet adapter while I'm on the login screen doesn't help - I need to have it inserted when I press the ON button.

I'm forced to use the lightning Ethernet adapter as a hardware security key for my macbook air. As soon as I login, I'm able to disconnect the adapter, and eveything works normally.