Windows 10: Cannot update 1709 to 1803 - old laptop

  1.    21 Jun 2018 #1

    Cannot update 1709 to 1803 - old laptop


    Hello.

    I am having big trouble trying to update an old Acer laptop (2GB RAM) which works perfectly fine under w10 v1709

    If I run the setup.exe from installation media, I got an error on the boot phase.

    I deleted all partitions and tried to install it clean. I get a IRQL NOT LESS OR EQUAL error when media starts booting. I have tried from both a usb stick and from dvd. Same results. Same BSOD.

    The only thing left to try is letting wu download it but I have the feeling it is going to fail too.

    Any ideas. For me v1803 is the worst w10 version released ever.
      My ComputerSystem Spec

  2.    21 Jun 2018 #2

    Go into the BIOS setup and see if "Cache Memory" is enabled. If it is, disable it. Be sure to save the changes when exiting.

    Ben
      My ComputerSystem Spec

  3.    21 Jun 2018 #3

    Video bios cacheable and system bios cacheable are indeed enabled = BAD IDEA but you cannot touch any BIOS options except for very basic ones for laptops. I have never seen any laptop that could enable changing all options in BIOS.
      My ComputerSystem Spec

  4.    21 Jun 2018 #4

    All my efforts have been in vain. 1709 works perfectly. 1803 BSODs even when doing a clean installation. It is now downloading it from WU. I guess it will fail too.
      My ComputerSystem Spec

  5.    22 Jun 2018 #5

    Check the manufacturer's support site for a BIOS upgrade and driver updates for 1803. Also check the relevant laptop user forum for issues.

    It's worth running sfc /scannow before an update to check for any issues.
      My ComputersSystem Spec

  6.    22 Jun 2018 #6

    SFC /scannow completed without integrity violations. I will check if there is a BIOS upgrade, although I am beginning to think to leave it at 1709. I am pretty sure 17134.1 is borked somehow, or it has become extremely picky (maybe it's MS forcing us to upgrade our hardware).
      My ComputerSystem Spec


 

Related Threads
HP i5 laptop used by a young teenager mostly for playing games including Steam updated to 1803 Home resulting in multiple problems. I rolled it back to 1709 and all works fine. Will future windows updates try to push 1803 back onto this laptop in...
When I received the upgrade to 1803, everything seemed fine for a couple of days but then I needed to scan a document and found that I could not communicate with my Epson printer/scanner. To cut a very long story short, I eventually found that...
There were two updates waiting for me today. An NVIDIA update which installed OK and the laptop ran fine afterwards, then an update for Windows 10 Pro 64 bit. I left it to update and reboot and then I came back to a BSOD. I restarted and I got a...
A couple of days ago, update 1803 for Windows 10 Home (64 bit) installed on our desktop with no problems. However, today 1803 tried to install on our Lenovo Z50-70 laptop (also 64 bit Windows 10). We left the house, and when we got back, the...
At the end of the update process during restart Windows 10 is dark desktop where all shortcut icons are not working with an “object is unavailable” error message. At this point none of the shortcuts or Windows icons are functional. Startup does...
Our Sites
Site Links
About Us
Windows 10 Forums is an independent web site and has not been authorized, sponsored, or otherwise approved by Microsoft Corporation. "Windows 10" and related materials are trademarks of Microsoft Corp.

© Designer Media Ltd
All times are GMT -5. The time now is 16:33.
Find Us